<!DOCTYPE html>
<html class="html post-template-default single single-post postid-448133 single-format-standard" lang="en-US" ontouchmove>
<head>
<meta charset="utf-8">
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="alternate" type="application/rss+xml" title="Vision Times Feed" href="https://www.visiontimes.com/feed">

<script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">
	var gtm4wp_datalayer_name = "dataLayer";
	var dataLayer = dataLayer || [];
</script>


<link media="all" href="https://www.visiontimes.com/wp-content/cache/autoptimize/css/autoptimize_30504b26d1b6338c10f62a416f1796e1.css" rel="stylesheet" /><title>US Sending an Additional $400 Million in Military Aid to Ukraine - Vision Times</title>
<meta name="description" content="The U.S. will send another $400 million in military equipment to Ukraine, including four more advanced rocket systems, a senior defense official said Friday," />
<meta name="robots" content="follow, index, max-snippet:-1, max-video-preview:-1, max-image-preview:large" />
<link rel="canonical" href="https://www.visiontimes.com/2022/07/08/us-sending-an-additional-400-million-in-military-aid-to-ukraine.html" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="US Sending an Additional $400 Million in Military Aid to Ukraine - Vision Times" />
<meta property="og:description" content="The U.S. will send another $400 million in military equipment to Ukraine, including four more advanced rocket systems, a senior defense official said Friday," />
<meta property="og:url" content="https://www.visiontimes.com/2022/07/08/us-sending-an-additional-400-million-in-military-aid-to-ukraine.html" />
<meta property="og:site_name" content="Vision Times" />
<meta property="article:tag" content="Donbas Region" />
<meta property="article:tag" content="High Mobility Artillery Rocket System (HIMARS)" />
<meta property="article:tag" content="luhansk" />
<meta property="article:tag" content="US Military Aid to Ukraine" />
<meta property="article:section" content="US" />
<meta property="og:updated_time" content="2022-07-08T17:21:45-04:00" />
<meta property="og:image" content="https://img.visiontimes.com/2022/07/GettyImages-1241438648-600x393.jpg" />
<meta property="og:image:secure_url" content="https://img.visiontimes.com/2022/07/GettyImages-1241438648-600x393.jpg" />
<meta property="og:image:width" content="600" />
<meta property="og:image:height" content="393" />
<meta property="og:image:alt" content="Ukraine-US-Military-Aid-Donbas-Region-Getty-Images-1241438648" />
<meta property="og:image:type" content="image/jpeg" />
<meta property="article:published_time" content="2022-07-08T17:17:56-04:00" />
<meta property="article:modified_time" content="2022-07-08T17:21:45-04:00" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:title" content="US Sending an Additional $400 Million in Military Aid to Ukraine - Vision Times" />
<meta name="twitter:description" content="The U.S. will send another $400 million in military equipment to Ukraine, including four more advanced rocket systems, a senior defense official said Friday," />
<meta name="twitter:image" content="https://img.visiontimes.com/2022/07/GettyImages-1241438648-600x393.jpg" />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="Vision Times News" />
<meta name="twitter:label2" content="Time to read" />
<meta name="twitter:data2" content="2 minutes" />
<script type="application/ld+json" class="rank-math-schema">{"@context":"https://schema.org","@graph":[{"@type":["NGO","Organization"],"@id":"https://www.visiontimes.com/#organization","name":"Vision Times","url":"https://www.visiontimes.com"},{"@type":"WebSite","@id":"https://www.visiontimes.com/#website","url":"https://www.visiontimes.com","name":"Vision Times","publisher":{"@id":"https://www.visiontimes.com/#organization"},"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://img.visiontimes.com/2022/07/GettyImages-1241438648.jpg","url":"https://img.visiontimes.com/2022/07/GettyImages-1241438648.jpg","width":"2384","height":"1560","caption":"Ukraine-US-Military-Aid-Donbas-Region-Getty-Images-1241438648","inLanguage":"en-US"},{"@type":"BreadcrumbList","@id":"https://www.visiontimes.com/2022/07/08/us-sending-an-additional-400-million-in-military-aid-to-ukraine.html#breadcrumb","itemListElement":[{"@type":"ListItem","position":"1","item":{"@id":"https://www.visiontimes.com","name":"Home"}},{"@type":"ListItem","position":"2","item":{"@id":"https://www.visiontimes.com/c/us","name":"US"}},{"@type":"ListItem","position":"3","item":{"@id":"https://www.visiontimes.com/2022/07/08/us-sending-an-additional-400-million-in-military-aid-to-ukraine.html","name":"US Sending an Additional $400 Million in Military Aid to Ukraine"}}]},{"@type":"Person","@id":"https://www.visiontimes.com/author/visiontimesnews","name":"Vision Times News","url":"https://www.visiontimes.com/author/visiontimesnews","image":{"@type":"ImageObject","@id":"https://img.visiontimes.com/2021/04/vt-logo.png","url":"https://img.visiontimes.com/2021/04/vt-logo.png","caption":"Vision Times News","inLanguage":"en-US"},"worksFor":{"@id":"https://www.visiontimes.com/#organization"}},{"@type":"WebPage","@id":"https://www.visiontimes.com/2022/07/08/us-sending-an-additional-400-million-in-military-aid-to-ukraine.html#webpage","url":"https://www.visiontimes.com/2022/07/08/us-sending-an-additional-400-million-in-military-aid-to-ukraine.html","name":"US Sending an Additional $400 Million in Military Aid to Ukraine - Vision Times","datePublished":"2022-07-08T17:17:56-04:00","dateModified":"2022-07-08T17:21:45-04:00","author":{"@id":"https://www.visiontimes.com/author/visiontimesnews"},"isPartOf":{"@id":"https://www.visiontimes.com/#website"},"primaryImageOfPage":{"@id":"https://img.visiontimes.com/2022/07/GettyImages-1241438648.jpg"},"inLanguage":"en-US","breadcrumb":{"@id":"https://www.visiontimes.com/2022/07/08/us-sending-an-additional-400-million-in-military-aid-to-ukraine.html#breadcrumb"}},{"@type":"NewsArticle","headline":"US Sending an Additional $400 Million in Military Aid to Ukraine - Vision Times","keywords":"US","datePublished":"2022-07-08T17:17:56-04:00","dateModified":"2022-07-08T17:21:45-04:00","author":{"@id":"https://www.visiontimes.com/author/visiontimesnews"},"publisher":{"@id":"https://www.visiontimes.com/#organization"},"description":"The U.S. will send another $400 million in military equipment to Ukraine, including four more advanced rocket systems, a senior defense official said Friday,","name":"US Sending an Additional $400 Million in Military Aid to Ukraine - Vision Times","@id":"https://www.visiontimes.com/2022/07/08/us-sending-an-additional-400-million-in-military-aid-to-ukraine.html#richSnippet","isPartOf":{"@id":"https://www.visiontimes.com/2022/07/08/us-sending-an-additional-400-million-in-military-aid-to-ukraine.html#webpage"},"image":{"@id":"https://img.visiontimes.com/2022/07/GettyImages-1241438648.jpg"},"inLanguage":"en-US","mainEntityOfPage":{"@id":"https://www.visiontimes.com/2022/07/08/us-sending-an-additional-400-million-in-military-aid-to-ukraine.html#webpage"}}]}</script>

<script id='Vision/assets-js-extra'>
var VisionData = {"templateDirectoryUri":"https:\/\/www.visiontimes.com\/wp-content\/themes\/vt","locale":"en_US","admin_ajax_url":"https:\/\/www.visiontimes.com\/wp-admin\/admin-ajax.php","post_id":"448133"};
var VisionDataComment = {"comment":"1","site":"https:\/\/www.visiontimes.com","article_link":"https:\/\/www.visiontimes.com\/2022\/07\/08\/us-sending-an-additional-400-million-in-military-aid-to-ukraine.html"};
</script>
<script type="application/javascript" src="https://sdki.truepush.com/sdk/v2.0.3/app.js" async></script>
<script>
    var truepush = window.Truepush || [];
        truepush.push( function() {
        truepush.Init({
            id : "620c00246daffbb98a21b770",
fromWordpress : true,
local : false,
wordpresspath : "https://www.visiontimes.com/wp-content/plugins/truepush-free-web-push-notifications/",
        },function(error){
          if(error) console.error(error);
        })
    });
    </script>
<link rel="icon" href="https://img.visiontimes.com/2021/04/cropped-favicon-512x512-1-1-32x32.png" sizes="32x32" />
<link rel="icon" href="https://img.visiontimes.com/2021/04/cropped-favicon-512x512-1-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://img.visiontimes.com/2021/04/cropped-favicon-512x512-1-1-180x180.png" />
<meta name="msapplication-TileImage" content="https://img.visiontimes.com/2021/04/cropped-favicon-512x512-1-1-270x270.png" />
</head>
<body>
<a href="#mainContent" class="skipLink">
Skip to main content
</a>
<div class="pageWrapper">
<header class="mainHeader">
<div is="vision-top-header">
<nav class="visionComponent  navigation-TopBarMenu" aria-label="Main">
<div class="wrap">
<div class="header-menu header-menu-menu">
<ul class="menu">
<li class="menu-item " tabindex="-1">
<a class="menu-link" href="#" tabindex="-1">Editions</a>
<ul class="sub-menus">
<li class="menu-item">
<a class="menu-link" href="https://www.secretchina.com/">Chinese</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://es.visiontimes.com/">Spanish</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.fr/">French</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.it/">Italian</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://visiontimesjp.com/">Japanese</a>
</li>
</ul>
<i class="fas fa-angle-down"></i>
</li>
<li class="menu-item " tabindex="-1">
<a class="menu-link" href="https://visiontimes.us1.list-manage.com/subscribe?u=7e5b1c29f989d8d053d774db4&#038;id=3feabe35e7" tabindex="-1">Newsletter</a>
</li>
<li class="menu-item " tabindex="-1">
<a class="menu-link" href="https://www.visiontimes.com/donations" tabindex="-1">Donate</a>
</li>
<li class="menu-item " tabindex="-1">
<a class="menu-link" href="https://www.visiontimes.com/about-us" tabindex="-1">About US</a>
</li>
</ul>
</div>
<div class="header-menu header-menu-user">
<nav is="vision-user-side-bar" class="visionComponent vision-user-side-bar">
<div class="overlay"></div>
<div class="section-button">
<div class="large-section-button">
<a href="https://myaccount.visiontimes.com/subscribe/print.php" target="_blank">
<div class="text">Subscribe</div>
</a>
</div>
<div class="large-section-button user-login login-btn">
<div class="text">Sign in</div>
<i class="fas fa-user"></i>
</div>
</div>
<div class="user-side">
<div class="user-menu ">
<div class="user-menu-button"></div>
<div class="user-block">
<div class="user-name"></div>
<a href="https://myaccount.visiontimes.com/subscribe/print.php" target="_blank">
<div class="e-button">
<span class="text">Subscribe</span>
</div>
</a>
<div class="user-sign-out logout-btn">Sign out</div>
</div>
<ul class="user-menu-items">
<li class="user-menu-item  menu-item menu-item-type-custom menu-item-object-custom menu-item-446748  user-menu-first  level-1">
<a class="user-menu-link" href="https://myaccount.visiontimes.com/accountprofile.php">Account Settings</a>
</li>
<li class="user-menu-item  menu-item menu-item-type-custom menu-item-object-custom menu-item-446749  level-1">
<a class="user-menu-link" href="https://myaccount.visiontimes.com/newsletter.php?code=en">Newsletters</a>
</li>
<li class="user-menu-item  menu-item menu-item-type-custom menu-item-object-custom menu-item-446750  level-1">
<a class="user-menu-link" href="https://myaccount.visiontimes.com/subscribe.php?code=en">Subscriptions</a>
</li>
</ul>
</div>
</div>
</nav>
</div>
</div>
</nav>
<div class="header-top-middle">
<div class="vision-weather-widget" is="vision-weather-widget">
<div class="top-left-wrap">
<nav is="vision-navigation-side" class="visionComponent">
<div class="overlay"></div>
<div class="section-button">
<div class="large-section-button">
<div class="text">SECTIONS</div>
<i class="fas fa-bars"></i>
</div>
<div class="sm-section-button">
<img src="https://www.visiontimes.com/wp-content/themes/vt/dist/assets/images/menu-mobile-926eb40a4c.svg">
</div>
</div>
<div class="nav-side">
<div class="menu ">
<div class="e-button">
<a href="https://visiontimes.us1.list-manage.com/subscribe?u=7e5b1c29f989d8d053d774db4&#038;id=3feabe35e7">
<span class="text">Newsletter</span>
</a>
</div>
<div class="menu-button"></div>
<ul class="menu-items">
<li class="menu-item  menu-item menu-item-type-custom menu-item-object-custom menu-item-428032  menu-first  level-1">
<a class="menu-link" href="/">Home</a>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-423521 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/news">News</a>
<i class="fas fa-angle-right"></i>
<div class="sub-menu-wrap">
<ul class="sub-menus">
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423525 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/politics">Politics</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423526 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/society">Society</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33185 menu-item-has-children level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/tech">Tech</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423523 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/health">Health</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423524 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/human-rights">Human Rights</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423522 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/analysis">Analysis</a>
</li>
</ul>
<i class="fas fa-caret-left"></i>
</div>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category menu-item-444027  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/opinions">Viewpoints</a>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-357119 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/us">US</a>
<i class="fas fa-angle-right"></i>
<div class="sub-menu-wrap">
<ul class="sub-menus">
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423514 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/us/us-politics">Politics</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423520 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/us/us-foreign-policy">Foreign Policy</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423515 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/us/new-york">New York</a>
</li>
</ul>
<i class="fas fa-caret-left"></i>
</div>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category menu-item-220229 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/china">China</a>
<i class="fas fa-angle-right"></i>
<div class="sub-menu-wrap">
<ul class="sub-menus">
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-437130 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/china/china-politics">Politics</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-437131 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/china/china-economy">Economy</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-437133 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/china/china-foreign-relations">International Relations</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-437129 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/china/china-society">Society</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-413925 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/china/china-culture">Chinese Culture</a>
</li>
</ul>
<i class="fas fa-caret-left"></i>
</div>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category menu-item-447634  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/world/americas/canada">Canada</a>
</li>
<li class="menu-item  world menu-item menu-item-type-taxonomy menu-item-object-category menu-item-989 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/world">World</a>
 <i class="fas fa-angle-right"></i>
<div class="sub-menu-wrap">
<ul class="sub-menus">
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-414013 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/world/americas">Americas</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-414014 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/world/asia-pacific">Asia-Pacific</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-414015 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/world/europe">Europe</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-447637 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/world/europe/uk">UK</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-414016 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/world/south-asia">South Asia</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-414012 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/world/africa">Africa</a>
</li>
</ul>
<i class="fas fa-caret-left"></i>
</div>
</li>
<li class="menu-item  life menu-item menu-item-type-taxonomy menu-item-object-category menu-item-985 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/life">Life</a>
<i class="fas fa-angle-right"></i>
<div class="sub-menu-wrap">
<ul class="sub-menus">
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-447636 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/culture">Culture</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423493 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/life/wellness">Wellness</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423518 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/life/mind-spirit">Mind &amp; Spirit</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423517 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/life/gardening">Gardening</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423516 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/life/entertainment">Entertainment</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-447635 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/china/china-culture">Chinese Culture</a>
</li>
</ul>
<i class="fas fa-caret-left"></i>
</div>
</li>
<li class="menu-item  science menu-item menu-item-type-taxonomy menu-item-object-category menu-item-997 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/nature">Nature</a>
<i class="fas fa-angle-right"></i>
<div class="sub-menu-wrap">
<ul class="sub-menus">
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33187 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/nature/environment">Environment</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-425150 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/nature/disasters">Disasters</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33191 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/nature/mysteries">Mysteries</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33183 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/space">Space</a>
</li>
</ul>
<i class="fas fa-caret-left"></i>
</div>
</li>
</ul>
</div>
</div>
</nav>
<div class="search">
<form is="vision-search-form-expandable" id="searchform" name="searchform" class="search-form" method="post" action="https://www.visiontimes.com">
<input type="text" class="search-field" name="s" placeholder="Search" value="">
<button class="btn search-button"><i class="fas fa-search"></i></button>
</form>
</div>
</div>
<div class="vision-current-date-widget" is="vision-current-date-widget"></div>
</div>
<div class="vision-top-banner">
<ul class="menu">
<li class="menu-item ">
<a class="menu-link" href="/">
HOME
</a>
</li>
<li class="menu-item ">
<a class="menu-link" href="https://www.visiontimes.com/c/news">
NEWS
</a>
</li>
<li class="menu-item ">
<a class="menu-link" href="https://www.visiontimes.com/c/opinions">
VIEWPOINTS
</a>
</li>
<li class="menu-item ">
<a class="menu-link" href="https://www.visiontimes.com/c/us">
US
</a>
</li>
<li class="menu-item ">
<a class="menu-link" href="https://www.visiontimes.com/c/china">
CHINA
</a>
</li>
<li class="menu-item ">
<a class="menu-link" href="https://www.visiontimes.com/c/world/americas/canada">
CANADA
</a>
</li>
<li class="menu-item ">
<a class="menu-link" href="https://www.visiontimes.com/c/world">
WORLD
</a>
</li>
<li class="menu-item ">
<a class="menu-link" href="https://www.visiontimes.com/c/life">
LIFE
</a>
</li>
<li class="menu-item ">
<a class="menu-link" href="https://www.visiontimes.com/c/nature">
NATURE
</a>
</li>
</ul>
<div>
<a href="https://www.visiontimes.com" title="Home"><img src="https://www.visiontimes.com/wp-content/themes/vt/dist/assets/images/vision-times-logo-fc9b3d60e2.svg" alt="Vision Times"></a>
</div>
</div>
<div class="vision-e-paper">
<a href="https://visiontimes.us1.list-manage.com/subscribe?u=7e5b1c29f989d8d053d774db4&#038;id=3feabe35e7" rel="noreferrer noopener">
<div class="e-button">
<span class="text">Newsletter</span>
</div>
</a>
<a href="http://pdf.secretchina.com/index.php?city=NewYork_en" target="_blank">
<div class="e-button prime-white">
<span class="text">e-Paper</span>
</div>
</a>
</div>
</div>
<div class="top-border">Truth, Inspiration, Hope.</div>
</div>
<nav class="visionComponent vision-sticky-bar " is="vision-top-bar-sticky" aria-label="Main">
<div class="wrap">
<nav is="vision-navigation-side" class="visionComponent">
<div class="overlay"></div>
<div class="section-button">
<div class="large-section-button">
<div class="text">SECTIONS</div>
<i class="fas fa-bars"></i>
</div>
<div class="sm-section-button">
<img src="https://www.visiontimes.com/wp-content/themes/vt/dist/assets/images/menu-mobile-926eb40a4c.svg">
</div>
</div>
<div class="nav-side">
<div class="menu ">
<div class="e-button">
<a href="https://visiontimes.us1.list-manage.com/subscribe?u=7e5b1c29f989d8d053d774db4&#038;id=3feabe35e7">
<span class="text">Newsletter</span>
</a>
</div>
<div class="menu-button"></div>
<ul class="menu-items">
<li class="menu-item  menu-item menu-item-type-custom menu-item-object-custom menu-item-428032  menu-first  level-1">
<a class="menu-link" href="/">Home</a>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-423521 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/news">News</a>
<i class="fas fa-angle-right"></i>
<div class="sub-menu-wrap">
<ul class="sub-menus">
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423525 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/politics">Politics</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423526 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/society">Society</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33185 menu-item-has-children level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/tech">Tech</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423523 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/health">Health</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423524 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/human-rights">Human Rights</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423522 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/analysis">Analysis</a>
</li>
</ul>
<i class="fas fa-caret-left"></i>
</div>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category menu-item-444027  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/opinions">Viewpoints</a>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-357119 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/us">US</a>
<i class="fas fa-angle-right"></i>
<div class="sub-menu-wrap">
<ul class="sub-menus">
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423514 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/us/us-politics">Politics</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423520 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/us/us-foreign-policy">Foreign Policy</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423515 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/us/new-york">New York</a>
</li>
</ul>
<i class="fas fa-caret-left"></i>
</div>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category menu-item-220229 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/china">China</a>
<i class="fas fa-angle-right"></i>
<div class="sub-menu-wrap">
<ul class="sub-menus">
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-437130 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/china/china-politics">Politics</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-437131 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/china/china-economy">Economy</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-437133 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/china/china-foreign-relations">International Relations</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-437129 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/china/china-society">Society</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-413925 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/china/china-culture">Chinese Culture</a>
</li>
</ul>
<i class="fas fa-caret-left"></i>
</div>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category menu-item-447634  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/world/americas/canada">Canada</a>
</li>
<li class="menu-item  world menu-item menu-item-type-taxonomy menu-item-object-category menu-item-989 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/world">World</a>
<i class="fas fa-angle-right"></i>
<div class="sub-menu-wrap">
<ul class="sub-menus">
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-414013 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/world/americas">Americas</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-414014 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/world/asia-pacific">Asia-Pacific</a>
</li>
 <li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-414015 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/world/europe">Europe</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-447637 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/world/europe/uk">UK</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-414016 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/world/south-asia">South Asia</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-414012 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/world/africa">Africa</a>
</li>
</ul>
<i class="fas fa-caret-left"></i>
</div>
</li>
<li class="menu-item  life menu-item menu-item-type-taxonomy menu-item-object-category menu-item-985 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/life">Life</a>
<i class="fas fa-angle-right"></i>
<div class="sub-menu-wrap">
<ul class="sub-menus">
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-447636 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/culture">Culture</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423493 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/life/wellness">Wellness</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423518 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/life/mind-spirit">Mind &amp; Spirit</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423517 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/life/gardening">Gardening</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423516 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/life/entertainment">Entertainment</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-447635 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/china/china-culture">Chinese Culture</a>
</li>
</ul>
<i class="fas fa-caret-left"></i>
</div>
</li>
<li class="menu-item  science menu-item menu-item-type-taxonomy menu-item-object-category menu-item-997 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/nature">Nature</a>
<i class="fas fa-angle-right"></i>
<div class="sub-menu-wrap">
<ul class="sub-menus">
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33187 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/nature/environment">Environment</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-425150 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/nature/disasters">Disasters</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33191 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/nature/mysteries">Mysteries</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33183 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/space">Space</a>
</li>
</ul>
<i class="fas fa-caret-left"></i>
</div>
</li>
</ul>
</div>
</div>
</nav>
<div class="search">
<form is="vision-search-form-expandable" id="searchform" name="searchform" class="search-form" method="post" action="https://www.visiontimes.com">
<input type="text" class="search-field" name="s" placeholder="Search" value="">
<button class="btn search-button"><i class="fas fa-search"></i></button>
</form>
</div>
</div>
<ul class="menu">
<li class="menu-item">
<a class="menu-link" href="/">
HOME
</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/c/news">
NEWS
</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/c/opinions">
VIEWPOINTS
</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/c/us">
US
</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/c/china">
CHINA
</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/c/world/americas/canada">
CANADA
</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/c/world">
WORLD
</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/c/life">
LIFE
</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/c/nature">
NATURE
</a>
</li>
</ul>
<div class="header-menu-social">
<ul>
<li><a href="" target="_blank" rel="nofollow" title="Telegram"><i class="fab fa-telegram-plane"></i></a></li>
<li><a href="" target="_blank" rel="nofollow" title="Twitter"><i class="fab fa-twitter"></i></a></li>
<li><a href="" target="_blank" rel="nofollow" title="Youtube"><i class="fab fa-youtube"></i></a></li>
<li><a href="" target="_blank" rel="nofollow" title="Facebook"> <i class="fab fa-facebook-f"></i></a></li>
</ul>
</div>
</nav>
<nav is="vision-navigation-burger" class="visionComponent" aria-label="Main">
<nav class="navigation-TopBarMenu-mobile" aria-label="Main">
<div class="wrap">
<div class="header-menu header-menu-menu">
<ul class="menu">
<li class="menu-item menu-item-1 " tabindex="-1">
<a class="menu-link" href="#">Editions</a>
<ul class="sub-menus">
<li class="menu-item">
<a class="menu-link" href="https://www.secretchina.com/">Chinese</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://es.visiontimes.com/">Spanish</a>
 </li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.fr/">French</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.it/">Italian</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://visiontimesjp.com/">Japanese</a>
</li>
</ul>
<i class="fas fa-angle-down"></i>
</li>
<li class="menu-item menu-item-2 " tabindex="-1">
<a class="menu-link" href="https://visiontimes.us1.list-manage.com/subscribe?u=7e5b1c29f989d8d053d774db4&#038;id=3feabe35e7">Newsletter</a>
</li>
<li class="menu-item menu-item-3 " tabindex="-1">
<a class="menu-link" href="https://www.visiontimes.com/donations">Donate</a>
</li>
<li class="menu-item menu-item-4 " tabindex="-1">
<a class="menu-link" href="https://www.visiontimes.com/about-us">About US</a>
</li>
</ul>
</div>
<div class="header-menu header-menu-user">
<nav is="vision-user-side-bar" class="visionComponent vision-user-side-bar">
<div class="overlay"></div>
<div class="section-button">
<div class="large-section-button">
<a href="https://myaccount.visiontimes.com/subscribe/print.php" target="_blank">
<div class="text">Subscribe</div>
</a>
</div>
<div class="large-section-button user-login login-btn">
<div class="text">Sign in</div>
<i class="fas fa-user"></i>
</div>
</div>
<div class="user-side">
<div class="user-menu ">
<div class="user-menu-button"></div>
<div class="user-block">
<div class="user-name"></div>
<a href="https://myaccount.visiontimes.com/subscribe/print.php" target="_blank">
<div class="e-button">
<span class="text">Subscribe</span>
</div>
</a>
<div class="user-sign-out logout-btn">Sign out</div>
</div>
<ul class="user-menu-items">
<li class="user-menu-item  menu-item menu-item-type-custom menu-item-object-custom menu-item-446748  user-menu-first  level-1">
<a class="user-menu-link" href="https://myaccount.visiontimes.com/accountprofile.php">Account Settings</a>
</li>
<li class="user-menu-item  menu-item menu-item-type-custom menu-item-object-custom menu-item-446749  level-1">
<a class="user-menu-link" href="https://myaccount.visiontimes.com/newsletter.php?code=en">Newsletters</a>
</li>
<li class="user-menu-item  menu-item menu-item-type-custom menu-item-object-custom menu-item-446750  level-1">
<a class="user-menu-link" href="https://myaccount.visiontimes.com/subscribe.php?code=en">Subscriptions</a>
</li>
</ul>
</div>
</div>
</nav>
</div>
</div>
</nav>
<div class="container centerMaxWidthContainer">
<div class="vision-hamburger" is="vision-hamburger">
<div class="top-left-wrap">
<nav is="vision-navigation-side" class="visionComponent">
<div class="overlay"></div>
<div class="section-button">
<div class="large-section-button">
<div class="text">SECTIONS</div>
<i class="fas fa-bars"></i>
</div>
<div class="sm-section-button">
<img src="https://www.visiontimes.com/wp-content/themes/vt/dist/assets/images/menu-mobile-926eb40a4c.svg">
</div>
</div>
<div class="nav-side">
<div class="menu lite">
<div class="e-button">
<a href="https://visiontimes.us1.list-manage.com/subscribe?u=7e5b1c29f989d8d053d774db4&#038;id=3feabe35e7">
<span class="text">Newsletter</span>
</a>
</div>
<div class="menu-button"></div>
<ul class="menu-items">
 <li class="menu-item  menu-item menu-item-type-custom menu-item-object-custom menu-item-428032  menu-first  level-1">
<a class="menu-link" href="/">Home</a>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-423521 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/news">News</a>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category menu-item-444027  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/opinions">Viewpoints</a>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-357119 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/us">US</a>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category menu-item-220229 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/china">China</a>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category menu-item-447634  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/world/americas/canada">Canada</a>
</li>
<li class="menu-item  world menu-item menu-item-type-taxonomy menu-item-object-category menu-item-989 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/world">World</a>
</li>
<li class="menu-item  life menu-item menu-item-type-taxonomy menu-item-object-category menu-item-985 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/life">Life</a>
</li>
<li class="menu-item  science menu-item menu-item-type-taxonomy menu-item-object-category menu-item-997 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/nature">Nature</a>
</li>
</ul>
</div>
</div>
</nav>
<div class="search">
<form is="vision-search-form-expandable" id="searchform" name="searchform" class="search-form" method="post" action="">
<input type="text" class="search-field" name="s" placeholder="Search" value="">
<button class="btn search-button"><i class="fas fa-search"></i></button>
</form>
</div>
</div>
</div>
<div class="logo">
<a href="https://www.visiontimes.com" title="Home"><img src="https://www.visiontimes.com/wp-content/themes/vt/dist/assets/images/vision-times-sm-logo-66a6be678b.svg" alt="Vision Times"></a>
</div>
<div class="vision-e-paper">
<a href="https://visiontimes.us1.list-manage.com/subscribe?u=7e5b1c29f989d8d053d774db4&#038;id=3feabe35e7" rel="noreferrer noopener">
<div class="e-button">
<span class="text">Newsletter</span>
</div>
</a>
</div>
</div>
<div class="top-border">Truth, Inspiration, Hope.</div>
</nav>
</header>
<main id="mainContent" class="mainContent" aria-label="Content">
<div class="content-wrapper single-wrapper">
<header>
<nav aria-label="breadcrumbs" class="rank-math-breadcrumb"><p><a href="https://www.visiontimes.com">Home</a><span class="separator"> &raquo; </span><a href="https://www.visiontimes.com/c/us">US</a><span class="separator"> &raquo; </span><span class="last">US Sending an Additional $400 Million in Military Aid to Ukraine</span></p></nav><div is="bread-crumbs">
</div>
<div is="vision-block-post-header-vt">
<h1>US Sending an Additional $400 Million in Military Aid to Ukraine</h1>
<div class="meta">
<div class="author-time">
<div class="visionComponent" is="vision-authors-custom">
<div class="authors">
<div class="author">
<div class="img"><img alt='' src='https://img.visiontimes.com/2021/04/vt-logo.png' srcset='https://img.visiontimes.com/2021/04/vt-logo.png' class='multiple_authors_guest_author_avatar avatar' height='30' width='30' /></div>
<div class="info">
<div class="name">By
<a href="https://www.visiontimes.com/author/visiontimesnews">
Vision Times News
</a>
</div>
<div class="desc"></div>
</div>
</div>
</div>
<div class="date">Published: July 8, 2022</div>
</div>
</div>
<div class="view-comment">
<div is="vision-media-share" class="visionComponent">
<div class="share-button">
<i class="far fa-share-square"></i>
<div class="share-wrap">
<div class="up-triangle"></div>
<div class="share-padding">
<ul class="share-menu">
<li>
<a target="_blank" href="https://twitter.com/intent/tweet?text=US%20Sending%20an%20Additional%20%24400%20Million%20in%20Military%20Aid%20to%20Ukraine&amp;url=https%3A%2F%2Fwww.visiontimes.com%2F2022%2F07%2F08%2Fus-sending-an-additional-400-million-in-military-aid-to-ukraine.html" rel="noopener noreferrer nofollow">
<i class="fab fa-twitter"></i>
</a>
</li>
<li>
<a target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.visiontimes.com%2F2022%2F07%2F08%2Fus-sending-an-additional-400-million-in-military-aid-to-ukraine.html" rel="noopener noreferrer nofollow">
<i class="fab fa-facebook"></i>
</a>
</li>
<li>
<a target="_blank" href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.visiontimes.com%2F2022%2F07%2F08%2Fus-sending-an-additional-400-million-in-military-aid-to-ukraine.html&amp;media=https%3A%2F%2Fimg.visiontimes.com%2F2022%2F07%2FGettyImages-1241438648.jpg&amp;description=Ukraine-US-Military-Aid-Donbas-Region-Getty-Images-1241438648" rel="noopener noreferrer nofollow" data-pin-no-hover="true" data-pin-custom="true" data-pin-do="skip" data-pin-description="Ukraine-US-Military-Aid-Donbas-Region-Getty-Images-1241438648">
<i class="fab fa-pinterest"></i>
</a>
</li>
<li>
<a target="_blank" href="https://www.linkedin.com/sharing/share-offsite/?url=https%3A%2F%2Fwww.visiontimes.com%2F2022%2F07%2F08%2Fus-sending-an-additional-400-million-in-military-aid-to-ukraine.html" rel="noopener noreferrer nofollow">
<i class="fab fa-linkedin"></i>
</a>
</li>
<li>
<a href="/cdn-cgi/l/email-protection#e4db868b809dd9adc1d6d496818580c1d6d4908c8d97c1d6d4948b9790c1d6d4858a80c1d6d493858a908180c1d6d4908bc1d6d4978c859681c1d6d48d90c1d6d4938d908cc1d6d49d8b91cac1d6d4ac819681c1d6d397c1d6d4908c81c1d6d4888d8a8fc1d7a5c1d6d48c90909497c1d7a5c1d6a2c1d6a2939393ca928d978d8b8a908d898197ca878b89c1d6a2d6d4d6d6c1d6a2d4d3c1d6a2d4dcc1d6a29197c997818a808d8a83c9858ac98580808d908d8b8a8588c9d0d4d4c9898d88888d8b8ac98d8ac9898d888d9085969dc9858d80c9908bc9918f96858d8a81ca8c908988c2858994df9791868e818790d9a5c1d6d4948b9790c1d6d4938b96908cc1d6d4978c85968d8a83c1d7a5c1d6d4b1b7c1d6d4b7818a808d8a83c1d6d4858ac1d6d4a580808d908d8b8a8588c1d6d4c1d6d0d0d4d4c1d6d4a98d88888d8b8ac1d6d48d8ac1d6d4a98d888d9085969dc1d6d4a58d80c1d6d4908bc1d6d4b18f96858d8a81" rel="noopener noreferrer nofollow">
<i class="fas fa-envelope"></i>
</a>
</li>
</ul>
</div>
</div>
</div>
</div>
<span class="comment-count" title="Jump to comment"><i class="far fa-comments"></i></span>
</div>
</div>
<div class="social-btns">
<div is="social-buttons">
<a class="button twitter" target="_blank" href="https://twitter.com/intent/tweet?text=US%20Sending%20an%20Additional%20%24400%20Million%20in%20Military%20Aid%20to%20Ukraine&amp;url=https%3A%2F%2Fwww.visiontimes.com%2F2022%2F07%2F08%2Fus-sending-an-additional-400-million-in-military-aid-to-ukraine.html" rel="noopener noreferrer nofollow"><span class="txt">Twitter</span></a>
<a class="button facebook" target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.visiontimes.com%2F2022%2F07%2F08%2Fus-sending-an-additional-400-million-in-military-aid-to-ukraine.html" rel="noopener noreferrer nofollow"><span class="txt">Facebook</span></a>
<a class="button pinterest" target="_blank" href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.visiontimes.com%2F2022%2F07%2F08%2Fus-sending-an-additional-400-million-in-military-aid-to-ukraine.html&amp;media=https%3A%2F%2Fimg.visiontimes.com%2F2022%2F07%2FGettyImages-1241438648.jpg&amp;description=Ukraine-US-Military-Aid-Donbas-Region-Getty-Images-1241438648" rel="noopener noreferrer nofollow" data-pin-no-hover="true" data-pin-custom="true" data-pin-do="skip" data-pin-description="Ukraine-US-Military-Aid-Donbas-Region-Getty-Images-1241438648"><span class="txt">Pinterest</span></a>
<a class="button linkedin" target="_blank" href="https://www.linkedin.com/shareArticle?mini=1&amp;url=https%3A%2F%2Fwww.visiontimes.com%2F2022%2F07%2F08%2Fus-sending-an-additional-400-million-in-military-aid-to-ukraine.html&amp;title=US%20Sending%20an%20Additional%20%24400%20Million%20in%20Military%20Aid%20to%20Ukraine&amp;source=https%3A%2F%2Fwww.visiontimes.com" rel="noopener noreferrer nofollow"><span class="txt">LinkedIn</span></a>
<a class="button email" href="/cdn-cgi/l/email-protection#3f005d505b4602761a0d0f4d5a5e5b1a0d0f4b57564c1a0d0f4f504c4b1a0d0f5e515b1a0d0f485e514b5a5b1a0d0f4b501a0d0f4c575e4d5a1a0d0f564b1a0d0f48564b571a0d0f46504a111a0d0f775a4d5a1a0d084c1a0d0f4b575a1a0d0f535651541a0c7e1a0d0f574b4b4f4c1a0c7e1a0d791a0d794848481149564c5650514b56525a4c115c50521a0d790d0f0d0d1a0d790f081a0d790f071a0d794a4c124c5a515b565158125e51125e5b5b564b5650515e53120b0f0f125256535356505112565112525653564b5e4d46125e565b124b50124a544d5e56515a11574b5253195e524f044c4a5d555a5c4b027e1a0d0f4f504c4b1a0d0f48504d4b571a0d0f4c575e4d5651581a0c7e1a0d0f6a6c1a0d0f6c5a515b5651581a0d0f5e511a0d0f7e5b5b564b5650515e531a0d0f1a0d0b0b0f0f1a0d0f725653535650511a0d0f56511a0d0f725653564b5e4d461a0d0f7e565b1a0d0f4b501a0d0f6a544d5e56515a" rel="noopener noreferrer nofollow"><span class="txt">Email</span></a>
</div>
</div>
</div>
</header>
<section class="post-main">
<div class="col-left">
<div class="with-gray-border-right">
<div class="col-left-content">
<div class="featuredImage">
<div class="visionComponent visionComponent--sizeLarge  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/07/GettyImages-1241438648-768x503.jpg" srcset="
                                    https://img.visiontimes.com/2022/07/GettyImages-1241438648-1920x1256.jpg 1920w,
            https://img.visiontimes.com/2022/07/GettyImages-1241438648-1068x699.jpg 1440w,
            https://img.visiontimes.com/2022/07/GettyImages-1241438648-1068x699.jpg 1320w,
            https://img.visiontimes.com/2022/07/GettyImages-1241438648-1068x699.jpg 1024w,
            https://img.visiontimes.com/2022/07/GettyImages-1241438648-768x503.jpg 800w,
            https://img.visiontimes.com/2022/07/GettyImages-1241438648-696x455.jpg 600w,
                                                            https://img.visiontimes.com/2022/07/GettyImages-1241438648-485x360.jpg 375w" data-sizes="auto" alt="Ukraine-US-Military-Aid-Donbas-Region-Getty-Images-1241438648">
<figcaption class="figure-caption">Ukrainian troops ride a tank on a road of the eastern Ukrainian region of Donbas on June 21, 2022, as Ukraine says Russian shelling has caused "catastrophic destruction" in the eastern industrial city of Lysychansk. The US has announced an additional $400 million in military aid to Ukraine. (Image: ANATOLII STEPANOV/AFP via Getty Images)</figcaption>
</figure>
</div>
</div>
</div>
<div class="article-content">
<p>The U.S. will send another $400 million in military equipment to Ukraine, including four more advanced rocket systems, a senior defense official said Friday, in an effort to bolster Ukrainian efforts to strike deeper behind Russian frontlines in the eastern Donbas region.</p>
<p>The aid comes as Moscow this week claimed full control of Ukraine&#8217;s Luhansk province in the Donbas, but Ukrainian officials say their troops still control a small part of the province and fierce fighting continues in several villages.</p>
<p>The defense official said that the eight High Mobility Artillery Rocket Systems, or HIMARS, that were previously sent are still being used by Ukraine forces in the fight. This will give them four more to help hit Russian command and control nodes, logistics capabilities and other systems that are further back behind the battlefront. A senior military official said at least 100 Ukrainian troops have been trained on the HIMARs. Both officials spoke on condition of anonymity to discuss details not yet made public.</p>
<p>Russia in recent days has launched dozens of missiles across Ukraine and pinned down Ukrainian forces with continuous long-range fire for sometimes hours at a time. The U.S. military official said that 10 to 15 Russian battalion tactical groups are in the Donbas region, but that Russia has sustained significant losses in the recent fighting and may have to pause to reorganize and reset equipment. There are between 800 to 1,000 troops in a battalion tactical group.</p>
<p>Ukraine&#8217;s leaders have publicly called on Western allies to quickly send more ammunition and advanced systems that will help them narrow the gap in equipment and manpower. The precision weapons can help Ukraine hit Russian weapons that are farther away and are being used to bombard Ukrainian locations.</p>
<p>The latest aid is the 15th package of military weapons and equipment transferred to Ukraine from Defense Department stocks since last August. In addition to the HIMARS, the U.S. will also send 1,000 rounds of 155 millimeter artillery which has an increased precision capability that also will help Ukraine hit specific targets. The package also will include three tactical vehicles, counter battery radar systems, spare parts and other equipment.</p>
<p>Looking ahead to the coming months, the official said that a key goal is to build up Ukraine&#8217;s logistics and repair capabilities so troops can maintain its weapons systems and continue the fight into the future.</p>
<p>Overall, the U.S. has sent about $7.3 billion in aid to Ukraine since the war began in late February.</p>
<p>Luhansk is one of two provinces that make up the Donbas, a region of mines and factories where pro-Moscow separatists have fought Ukraine&#8217;s army for eight years and declared independent republics that Russian President Vladimir Putin recognized before he sent troops into Ukraine.</p>
<p>Putin on Thursday warned that Kyiv should accept Moscow&#8217;s terms or brace for the worst, saying that Russia hasn&#8217;t yet &#8220;started anything in earnest.&#8221;</p>
<p>U.S. and other western officials have said that Russia has been making slow, incremental progress in the Donbas but has not made gains as rapidly as Moscow initially intended. President Joe Biden has said that the U.S. is giving Ukrainians the aid needed to continue to resist Russian aggression.</p>
<p>&#8220;I don&#8217;t know how it&#8217;s going to end, but it will not end with a Russian defeat of Ukraine in Ukraine,&#8221; Biden said last week.</p>
<p><em>By the Associated Press</em></p>
</div>
</div>
</div>
<footer class="post-meta">
<div class="visionComponent" is="vision-block-post-footer">
<div class="content centerContentMaxWidth">
<ul class="tags">
<li class="tags-item">Tag:</li>
<li class="tags-item"><a class="tags-itemLink pill" href="https://www.visiontimes.com/tag/donbas-region"><span class="visuallyHidden">Tag:</span> Donbas Region</a></li>
<li class="tags-item"><a class="tags-itemLink pill" href="https://www.visiontimes.com/tag/high-mobility-artillery-rocket-system-himars"><span class="visuallyHidden">Tag:</span> High Mobility Artillery Rocket System (HIMARS)</a></li>
<li class="tags-item"><a class="tags-itemLink pill" href="https://www.visiontimes.com/tag/luhansk"><span class="visuallyHidden">Tag:</span> luhansk</a></li>
<li class="tags-item"><a class="tags-itemLink pill" href="https://www.visiontimes.com/tag/us-military-aid-to-ukraine"><span class="visuallyHidden">Tag:</span> US Military Aid to Ukraine</a></li>
</ul>
</div>
</div>
</footer>
<div id="post-comments">
<div id="remark42" is="vision-block-comment" class="loading">
</div>
</div>
<section>
<div is="vision-grid-news-latest">
<h3>RELATED NEWS</h3>
<div class="news-latest">
<div class="article">
<a href="https://www.visiontimes.com/2022/07/08/state-of-florida-posts-record-21-8-billion-surplus-highest-in-state-history.html"><div class="title">State of Florida Posts Record $21.8 Billion Surplus, Highest in State History</div></a>
<a href="https://www.visiontimes.com/2022/07/08/state-of-florida-posts-record-21-8-billion-surplus-highest-in-state-history.html"><div class="img"><div class="visionComponent visionComponent--sizeTiny  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/07/GettyImages-1401781433-768x560.jpg" srcset="
                                                                        https://img.visiontimes.com/2022/07/GettyImages-1401781433-485x360.jpg 375w" data-sizes="auto" alt="Florida-record-state-surplus-Ron-DeSantis-Getty-Images-1401781433">
</figure>
</div>
</div>
</div></a>
</div>
<div class="article">
<a href="https://www.visiontimes.com/2022/07/08/biden-sells-us-oil-reserves-china.html"><div class="title">Biden Admin Selling US Oil Reserves to China, Europe Amid Energy Crisis</div></a>
<a href="https://www.visiontimes.com/2022/07/08/biden-sells-us-oil-reserves-china.html"><div class="img"><div class="visionComponent visionComponent--sizeTiny  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/07/Biden-Admin-Sells-US-Strategic-Petroleum-Reserve-China-Communist-Party-CCP-768x512.jpg" srcset="
                                                                        https://img.visiontimes.com/2022/07/Biden-Admin-Sells-US-Strategic-Petroleum-Reserve-China-Communist-Party-CCP-485x360.jpg 375w" data-sizes="auto" alt="The Biden Admin sold some of the US SPR to the CCP amid the energy crisis and inflation.">
</figure>
</div>
</div>
</div></a>
</div>
<div class="article">
<a href="https://www.visiontimes.com/2022/07/07/american-teachers-union-puts-forward-a-resolution-to-change-the-term-mother-to-birthing-parent.html"><div class="title">American Teachers Union Puts Forward Resolution to Change the Term ‘Mother’ to ‘Birthing Parent’</div></a>
<a href="https://www.visiontimes.com/2022/07/07/american-teachers-union-puts-forward-a-resolution-to-change-the-term-mother-to-birthing-parent.html"><div class="img"><div class="visionComponent visionComponent--sizeTiny  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/07/GettyImages-1233775974-768x512.jpg" srcset="
                                                                        https://img.visiontimes.com/2022/07/GettyImages-1233775974-485x360.jpg 375w" data-sizes="auto" alt="birthing-parent-mother-National-Education-Association-Getty-Images-1233775974">
</figure>
</div>
</div>
</div></a>
</div>
<div class="article">
<a href="https://www.visiontimes.com/2022/07/07/rat-sized-snails-swarm-florida-county-quarantine-put-in-place.html"><div class="title">Rat-Sized Snails Swarm Florida County, Quarantine Put in Place</div></a>
<a href="https://www.visiontimes.com/2022/07/07/rat-sized-snails-swarm-florida-county-quarantine-put-in-place.html"><div class="img"><div class="visionComponent visionComponent--sizeTiny  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/07/GettyImages-482129088-768x581.jpg" srcset="
                                                                        https://img.visiontimes.com/2022/07/GettyImages-482129088-485x360.jpg 375w" data-sizes="auto" alt="Snails-African-Giant-Florida-Pasco-County-Getty-Images-482129088">
</figure>
</div>
</div>
</div></a>
</div>
</div>
</div>
</section>
</div>
<div class="col-right">
<div is="vision-list-top-stories">
<div class="sidebar-header">
<h3>TOP STORIES</h3>
<div class="article" id="447436">
<a href="https://www.visiontimes.com/2022/06/21/used-semi-truck-auction-prices-crash.html"><div class="title">Another Bubble Is Popping: Used Semi Truck Auction Prices Are Cratering</div></a>
<a href="https://www.visiontimes.com/2022/06/21/used-semi-truck-auction-prices-crash.html"><div class="img"><div class="visionComponent visionComponent--sizeTiny  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/06/Semi-Truck-Auction-Prices-Cratering-Trucking-Industry-Bubble-Collapse-768x512.jpg" srcset="
                                                                        https://img.visiontimes.com/2022/06/Semi-Truck-Auction-Prices-Cratering-Trucking-Industry-Bubble-Collapse-485x360.jpg 375w" data-sizes="auto" alt="The trucking industry bubble is popping, shown by the price of used trucks at auction cratering.">
</figure>
</div>
</div>
</div></a>
</div>
<div class="article" id="447285">
<a href="https://www.visiontimes.com/2022/06/17/spacex-employees-fired-over-open-letter-against-ceo-elon-musk.html"><div class="title">SpaceX Employees Fired Over Open Letter Against CEO Elon Musk</div></a>
<a href="https://www.visiontimes.com/2022/06/17/spacex-employees-fired-over-open-letter-against-ceo-elon-musk.html"><div class="img"><div class="visionComponent visionComponent--sizeTiny  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/06/32504300917_dd770a1367.jpg" srcset="
                                                                        https://img.visiontimes.com/2022/06/32504300917_dd770a1367-485x333.jpg 375w" data-sizes="auto" alt="SpaceX-Elon-Musk-Open-Letter-Employees-Fired">
</figure>
</div>
</div>
</div></a>
</div>
<div class="article" id="447351">
<a href="https://www.visiontimes.com/2022/06/20/tesla-expected-to-lose-throne-to-volkswagen-as-worlds-largest-electric-vehicle-maker-bloomberg.html"><div class="title">Tesla Expected to Lose Throne to Volkswagen as World’s Largest Electric Vehicle Maker: Bloomberg</div></a>
<a href="https://www.visiontimes.com/2022/06/20/tesla-expected-to-lose-throne-to-volkswagen-as-worlds-largest-electric-vehicle-maker-bloomberg.html"><div class="img"><div class="visionComponent visionComponent--sizeTiny  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/06/GettyImages-1403832004-768x512.jpg" srcset="
                                                                        https://img.visiontimes.com/2022/06/GettyImages-1403832004-485x360.jpg 375w" data-sizes="auto" alt="Tesla-Elon-Musk-Volkswagen-Electric-Vehicles-Getty-Images-1403832004">
</figure>
</div>
</div>
</div></a>
</div>
<div class="article" id="447325">
<a href="https://www.visiontimes.com/2022/06/18/elon-musk-may-have-lost-100s-of-millions-on-his-february-bitcoin-gamble.html"><div class="title">Elon Musk May Have Lost 100s of Millions on His February Bitcoin Gamble</div></a>
<a href="https://www.visiontimes.com/2022/06/18/elon-musk-may-have-lost-100s-of-millions-on-his-february-bitcoin-gamble.html"><div class="img"><div class="visionComponent visionComponent--sizeTiny  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/06/GettyImages-1234732042-768x565.jpg" srcset="
                                                                        https://img.visiontimes.com/2022/06/GettyImages-1234732042-485x360.jpg 375w" data-sizes="auto" alt="Elon-Musk-Bitcoin-Cryptocurrency-markets-in-free-fall-Getty-Images-1234732042">
</figure>
</div>
</div>
</div></a>
</div>
<div class="article" id="447706">
<a href="https://www.visiontimes.com/2022/06/28/hacker-group-whose-members-idenitfy-as-gay-furries-declares-war-on-pro-life-states-leaks-gigabytes-of-da.html"><div class="title">Hacker Group Whose Members Idenitfy as ‘Gay Furries’ Declares War on Pro-Life States, Leaks Gigabytes</div></a>
<a href="https://www.visiontimes.com/2022/06/28/hacker-group-whose-members-idenitfy-as-gay-furries-declares-war-on-pro-life-states-leaks-gigabytes-of-da.html"><div class="img"><div class="visionComponent visionComponent--sizeTiny  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/06/GettyImages-1190596969-768x494.jpg" srcset="
                                                                        https://img.visiontimes.com/2022/06/GettyImages-1190596969-485x360.jpg 375w" data-sizes="auto" alt="Gay-Furries-Hacker-group-SiegedSec-Getty-Images-1190596969">
</figure>
</div>
</div>
</div></a>
</div>
</div>
</div>
<div is="vision-list-most-read">
<div class="sidebar-header" load_max="30" load_more="10">
<h3>MOST POPULAR</h3>
<div class="article" id="447436">
<a href="https://www.visiontimes.com/2022/06/21/used-semi-truck-auction-prices-crash.html"><div class="title">Another Bubble Is Popping: Used Semi Truck Auction Prices Are Cratering</div></a>
<a href="https://www.visiontimes.com/2022/06/21/used-semi-truck-auction-prices-crash.html"><div class="img"><div class="visionComponent visionComponent--sizeTiny  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/06/Semi-Truck-Auction-Prices-Cratering-Trucking-Industry-Bubble-Collapse-768x512.jpg" srcset="
                                                                        https://img.visiontimes.com/2022/06/Semi-Truck-Auction-Prices-Cratering-Trucking-Industry-Bubble-Collapse-485x360.jpg 375w" data-sizes="auto" alt="The trucking industry bubble is popping, shown by the price of used trucks at auction cratering.">
</figure>
</div>
</div>
</div></a>
</div>
<div class="article" id="447285">
<a href="https://www.visiontimes.com/2022/06/17/spacex-employees-fired-over-open-letter-against-ceo-elon-musk.html"><div class="title">SpaceX Employees Fired Over Open Letter Against CEO Elon Musk</div></a>
<a href="https://www.visiontimes.com/2022/06/17/spacex-employees-fired-over-open-letter-against-ceo-elon-musk.html"><div class="img"><div class="visionComponent visionComponent--sizeTiny  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/06/32504300917_dd770a1367.jpg" srcset="
                                                                        https://img.visiontimes.com/2022/06/32504300917_dd770a1367-485x333.jpg 375w" data-sizes="auto" alt="SpaceX-Elon-Musk-Open-Letter-Employees-Fired">
</figure>
</div>
</div>
</div></a>
</div>
<div class="article" id="447351">
<a href="https://www.visiontimes.com/2022/06/20/tesla-expected-to-lose-throne-to-volkswagen-as-worlds-largest-electric-vehicle-maker-bloomberg.html"><div class="title">Tesla Expected to Lose Throne to Volkswagen as World’s Largest Electric Vehicle Maker: Bloomberg</div></a>
<a href="https://www.visiontimes.com/2022/06/20/tesla-expected-to-lose-throne-to-volkswagen-as-worlds-largest-electric-vehicle-maker-bloomberg.html"><div class="img"><div class="visionComponent visionComponent--sizeTiny  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/06/GettyImages-1403832004-768x512.jpg" srcset="
                                                                        https://img.visiontimes.com/2022/06/GettyImages-1403832004-485x360.jpg 375w" data-sizes="auto" alt="Tesla-Elon-Musk-Volkswagen-Electric-Vehicles-Getty-Images-1403832004">
</figure>
</div>
</div>
</div></a>
</div>
<div class="article" id="447616">
<a href="https://www.visiontimes.com/2022/06/26/alina-lipp-german-journalist-charged-bank-frozen-ukraine-reporting.html"><div class="title">German Journalist Criminally Charged, Bank Account Seized, for Deviating From the Official Narrative</div></a>
<a href="https://www.visiontimes.com/2022/06/26/alina-lipp-german-journalist-charged-bank-frozen-ukraine-reporting.html"><div class="img"><div class="visionComponent visionComponent--sizeTiny  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/06/Alina-Lipp-Germany-Charged-Bank-Account-Frozen-Reporting-Pro-Russia-Donbass-768x395.jpg" srcset="
                                                                        https://img.visiontimes.com/2022/06/Alina-Lipp-Germany-Charged-Bank-Account-Frozen-Reporting-Pro-Russia-Donbass-485x360.jpg 375w" data-sizes="auto" alt="Alina Lipp. a 28-year-old German journalist reporting on the situation in Ukraine objectively, has been criminally charged by German authorities">
</figure>
</div>
</div>
</div></a>
</div>
<div class="article" id="447258">
<a href="https://www.visiontimes.com/2022/06/16/china-says-it-may-have-detected-alien-activity-using-sky-eye-telescope.html"><div class="title">China Says It May Have Detected Alien Activity Using ‘Sky Eye’ Telescope</div></a>
<a href="https://www.visiontimes.com/2022/06/16/china-says-it-may-have-detected-alien-activity-using-sky-eye-telescope.html"><div class="img"><div class="visionComponent visionComponent--sizeTiny  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/06/china-sky-eye-telescope-GettyImages-626582398-768x414.jpg" srcset="
                                                                        https://img.visiontimes.com/2022/06/china-sky-eye-telescope-GettyImages-626582398-485x360.jpg 375w" data-sizes="auto" alt="">
</figure>
</div>
</div>
</div></a>
</div>
<div class="article" id="447930">
<a href="https://www.visiontimes.com/2022/07/04/canadians-will-be-required-to-receive-a-covid-19-shot-every-nine-months-health-minister.html"><div class="title">Canadians Will Be Required to Receive a COVID-19 Shot Every Nine Months: Health Minister</div></a>
<a href="https://www.visiontimes.com/2022/07/04/canadians-will-be-required-to-receive-a-covid-19-shot-every-nine-months-health-minister.html"><div class="img"><div class="visionComponent visionComponent--sizeTiny  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/07/GettyImages-12375493451-768x512.jpg" srcset="
                                                                        https://img.visiontimes.com/2022/07/GettyImages-12375493451-485x360.jpg 375w" data-sizes="auto" alt="COVID-19-Canada-Vaccination-Status-booster-shot-every-nine-months-Getty-Images-1237549345">
</figure>
</div>
</div>
</div></a>
</div>
</div>
<div class="load-more">
<div class="loading load-more-loading"></div>
<a href="https://www.visiontimes.com/wp-admin/admin-ajax.php" id="load-more-button" load-most-popular>
<button>
<div class="load-more-text">LOAD MORE</div>
</button>
</a>
</div>
</div>
</div>
</section>
</div>
</main>
<footer class="mainFooter">
<div class="visionComponent themeLight" is="vision-navigation-footer">
<div class="container centerMaxWidthContainer">
<ul class="footer-nav">
<li>
<div class="heading">EDITIONS</div>
<ul class="items">
<li class="menu-item">
<a class="menu-link" href="https://www.secretchina.com/">Chinese</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://es.visiontimes.com/">Spanish</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.fr/">French</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.it/">Italian</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimesjp.com/">Japanese</a>
</li>
</ul>
</li>
<li>
<div class="heading">COMPANY</div>
<ul class="items">
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/about-us">About</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/contact-us">Contact</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/advertise">Advertise</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/submissions">Submissions</a>
</li>
</ul>
</li>
<li>
<div class="heading">INFO</div>
<ul class="items">
<li class="menu-item">
 <a class="menu-link" href="https://www.visiontimes.com/privacy">Privacy Policy</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/policies">Terms of Service</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/copyright-policy-and-infringement-notification">Copyright Policy and Infringement Notification</a>
</li>
</ul>
</li>
<li>
<div class="heading">POPULAR CATEGORY</div>
<ul class="items">
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/c/us">US</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/c/china">China</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/c/world">World</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/c/politics">Politics</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/c/human-rights">Human Rights</a>
</li>
</ul>
</li>
</ul>
<div class="footer-nav footer-nav-2">
<li>
<div class="heading">About Us</div>
<div class="items txt">Vision Times tells the world everything about China in today's context. We keep a close eye on China because of its influence now and the lessons we can learn from its ancient past to better our lives today.</div>
</li>
<li>
<div class="heading">Follow Us</div>
<ul class="items icons">
<li><a href="https://www.facebook.com/VisionTimesOfficial" target="_blank" rel="nofollow" title="Facebook"> <i class="fab fa-facebook-f"></i></a></li>
<li><a href="https://twitter.com/times_vision" target="_blank" rel="nofollow" title="Twitter"><i class="fab fa-twitter"></i></a></li>
<li><a href="https://www.youtube.com/c/VisionTimesNews" target="_blank" rel="nofollow" title="Youtube"><i class="fab fa-youtube"></i></a></li>
<li><a href="https://t.me/visiontimes" target="_blank" rel="nofollow" title="Telegram"><i class="fab fa-telegram"></i></a></li>
<li><a href="https://safechat.com/channel/2788089756776450736" target="_blank" rel="nofollow" title="SafeChat"><i class="fab fa-safechat"></i></a></li>
</ul>
</li>
</div>
</div>
</div>
</footer>
</div>
<div class="wpFooter">


<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-W8PQVQT"
height="0" width="0" style="display:none;visibility:hidden" aria-hidden="true"></iframe></noscript>
<div is="vision-block-cookie-notice" class="visionComponent boxShadow layoutFloating themeReset" role="dialog">
<div class="container centerMaxWidthContainer">
<div class="content">
<p class="header">This website uses cookies</p>
<p>We inform you that this site uses own, technical and third parties cookies to make sure our web page is user-friendly and to guarantee a high functionality of the webpage. By continuing to browse this website, you declare to accept the use of cookies.</p>
</div>
<button type="button" class="button button--small" aria-label="Close" data-close>Ok</button>
</div>
</div>


<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">
	var dataLayer_content = {"pageTitle":"US Sending an Additional $400 Million in Military Aid to Ukraine - Vision Times","pagePostType":"post","pagePostType2":"single-post","pageCategory":["us","news"],"pageAttributes":["donbas-region","high-mobility-artillery-rocket-system-himars","luhansk","us-military-aid-to-ukraine"],"pagePostAuthorID":521,"pagePostAuthor":"Vision Times News"};
	dataLayer.push( dataLayer_content );
</script>
<script data-cfasync="false">
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.'+'js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-W8PQVQT');
</script>


</div>
<script async type="text/javascript" src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script async type="text/javascript" src="https://intothebid.com/wrapper/vt/prebid.vt_en.js"></script>
<script async type="text/javascript" src="https://intothebid.com/wrapper/vt/hp_vt_en.js"></script>
<script async type="text/javascript" src="https://intothebid.com/wrapper/vt/hb_vt_en.js"></script>
<script defer src="https://www.visiontimes.com/wp-content/cache/autoptimize/js/autoptimize_6d5b05acf688e50291fd02da8c9c051d.js"></script></body>
</html>

