<!DOCTYPE html>
<html class="html post-template-default single single-post postid-445443 single-format-standard" lang="en-US" ontouchmove>
<head>
<meta charset="utf-8">
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="alternate" type="application/rss+xml" title="Vision Times Feed" href="https://www.visiontimes.com/feed">

<script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">//<![CDATA[
	var gtm4wp_datalayer_name = "dataLayer";
	var dataLayer = dataLayer || [];
//]]>
</script>


<link media="all" href="https://www.visiontimes.com/wp-content/cache/autoptimize/css/autoptimize_19e1adbaea878bd7b243641b7a471013.css" rel="stylesheet" /><title>Communist Flags Fly at Montreal ‘Workers Day’ Protest, US Flag Burned, Windows Smashed, Buildings Graffitied - Vision Times</title>
<meta name="description" content="The flag of the Communist Party of Canada and the Hammer and Sickle flew at the Montreal May Day protest where windows were smashed and businesses vandalized." />
<meta name="robots" content="follow, index, max-snippet:-1, max-video-preview:-1, max-image-preview:large" />
<link rel="canonical" href="https://www.visiontimes.com/2022/05/03/communist-flags-montreal-may-day-protest-vandalism.html" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Communist Flags Fly at Montreal ‘Workers Day’ Protest, US Flag Burned, Windows Smashed, Buildings Graffitied - Vision Times" />
<meta property="og:description" content="The flag of the Communist Party of Canada and the Hammer and Sickle flew at the Montreal May Day protest where windows were smashed and businesses vandalized." />
<meta property="og:url" content="https://www.visiontimes.com/2022/05/03/communist-flags-montreal-may-day-protest-vandalism.html" />
<meta property="og:site_name" content="Vision Times" />
<meta property="article:tag" content="canada" />
<meta property="article:tag" content="Hammer and Sickle Flag" />
<meta property="article:tag" content="Marxist Revolutionaries" />
<meta property="article:tag" content="world" />
<meta property="article:section" content="World" />
<meta property="og:updated_time" content="2022-05-03T02:02:11-04:00" />
<meta property="og:image" content="https://img.visiontimes.com/2022/05/Montreal-May-Day-Protest-Communist-Party-of-Canada-Hammer-and-Sickle-Flag-Burn-American-Flag.jpg" />
<meta property="og:image:secure_url" content="https://img.visiontimes.com/2022/05/Montreal-May-Day-Protest-Communist-Party-of-Canada-Hammer-and-Sickle-Flag-Burn-American-Flag.jpg" />
<meta property="og:image:width" content="900" />
<meta property="og:image:height" content="604" />
<meta property="og:image:alt" content="Montreal Communist Party of Canada members wielding the Hammer and Sickle burned a US Flag during the May 1 protests." />
<meta property="og:image:type" content="image/jpeg" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:title" content="Communist Flags Fly at Montreal ‘Workers Day’ Protest, US Flag Burned, Windows Smashed, Buildings Graffitied - Vision Times" />
<meta name="twitter:description" content="The flag of the Communist Party of Canada and the Hammer and Sickle flew at the Montreal May Day protest where windows were smashed and businesses vandalized." />
<meta name="twitter:image" content="https://img.visiontimes.com/2022/05/Montreal-May-Day-Protest-Communist-Party-of-Canada-Hammer-and-Sickle-Flag-Burn-American-Flag.jpg" />
<script type="application/ld+json" class="rank-math-schema">{"@context":"https://schema.org","@graph":[{"@type":["NGO","Organization"],"@id":"https://www.visiontimes.com/#organization","name":"Vision Times","url":"https://www.visiontimes.com"},{"@type":"WebSite","@id":"https://www.visiontimes.com/#website","url":"https://www.visiontimes.com","name":"Vision Times","publisher":{"@id":"https://www.visiontimes.com/#organization"},"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://img.visiontimes.com/2022/05/Montreal-May-Day-Protest-Communist-Party-of-Canada-Hammer-and-Sickle-Flag-Burn-American-Flag.jpg","url":"https://img.visiontimes.com/2022/05/Montreal-May-Day-Protest-Communist-Party-of-Canada-Hammer-and-Sickle-Flag-Burn-American-Flag.jpg","width":"900","height":"604","caption":"Montreal Communist Party of Canada members wielding the Hammer and Sickle burned a US Flag during the May 1 protests.","inLanguage":"en-US"},{"@type":"BreadcrumbList","@id":"https://www.visiontimes.com/2022/05/03/communist-flags-montreal-may-day-protest-vandalism.html#breadcrumb","itemListElement":[{"@type":"ListItem","position":"1","item":{"@id":"https://www.visiontimes.com","name":"Home"}},{"@type":"ListItem","position":"2","item":{"@id":"https://www.visiontimes.com/c/world","name":"World"}},{"@type":"ListItem","position":"3","item":{"@id":"https://www.visiontimes.com/2022/05/03/communist-flags-montreal-may-day-protest-vandalism.html","name":"Communist Flags Fly at Montreal \u2018Workers Day\u2019 Protest, US Flag Burned, Windows Smashed, Buildings Graffitied"}}]},{"@type":"Person","@id":"https://www.visiontimes.com/author/neil-c","name":"Neil Campbell","url":"https://www.visiontimes.com/author/neil-c","image":{"@type":"ImageObject","@id":"https://secure.gravatar.com/avatar/65acbc8794ba180f4e56e73085a869ca?s=96&amp;r=g","url":"https://secure.gravatar.com/avatar/65acbc8794ba180f4e56e73085a869ca?s=96&amp;r=g","caption":"Neil Campbell","inLanguage":"en-US"},"worksFor":{"@id":"https://www.visiontimes.com/#organization"}},{"@type":"WebPage","@id":"https://www.visiontimes.com/2022/05/03/communist-flags-montreal-may-day-protest-vandalism.html#webpage","url":"https://www.visiontimes.com/2022/05/03/communist-flags-montreal-may-day-protest-vandalism.html","name":"Communist Flags Fly at Montreal \u2018Workers Day\u2019 Protest, US Flag Burned, Windows Smashed, Buildings Graffitied - Vision Times","datePublished":"2022-05-03T02:02:06-04:00","dateModified":"2022-05-03T02:02:11-04:00","author":{"@id":"https://www.visiontimes.com/author/neil-c"},"isPartOf":{"@id":"https://www.visiontimes.com/#website"},"primaryImageOfPage":{"@id":"https://img.visiontimes.com/2022/05/Montreal-May-Day-Protest-Communist-Party-of-Canada-Hammer-and-Sickle-Flag-Burn-American-Flag.jpg"},"inLanguage":"en-US","breadcrumb":{"@id":"https://www.visiontimes.com/2022/05/03/communist-flags-montreal-may-day-protest-vandalism.html#breadcrumb"}},{"@type":"NewsArticle","headline":"Communist Flags Fly at Montreal \u2018Workers Day\u2019 Protest, US Flag Burned, Windows Smashed, Buildings Graffitied","keywords":"Montreal,Protest","datePublished":"2022-05-03T02:02:06-04:00","dateModified":"2022-05-03T02:02:11-04:00","author":{"@id":"https://www.visiontimes.com/author/neil-c"},"publisher":{"@id":"https://www.visiontimes.com/#organization"},"description":"The flag of the Communist Party of Canada and the Hammer and Sickle flew at the Montreal May Day protest where windows were smashed and businesses vandalized.","name":"Communist Flags Fly at Montreal \u2018Workers Day\u2019 Protest, US Flag Burned, Windows Smashed, Buildings Graffitied","@id":"https://www.visiontimes.com/2022/05/03/communist-flags-montreal-may-day-protest-vandalism.html#richSnippet","isPartOf":{"@id":"https://www.visiontimes.com/2022/05/03/communist-flags-montreal-may-day-protest-vandalism.html#webpage"},"image":{"@id":"https://img.visiontimes.com/2022/05/Montreal-May-Day-Protest-Communist-Party-of-Canada-Hammer-and-Sickle-Flag-Burn-American-Flag.jpg"},"inLanguage":"en-US","mainEntityOfPage":{"@id":"https://www.visiontimes.com/2022/05/03/communist-flags-montreal-may-day-protest-vandalism.html#webpage"}}]}</script>

<script id='Vision/assets-js-extra'>
var VisionData = {"templateDirectoryUri":"https:\/\/www.visiontimes.com\/wp-content\/themes\/vt","locale":"en_US","admin_ajax_url":"https:\/\/www.visiontimes.com\/wp-admin\/admin-ajax.php","post_id":"445443"};
var VisionDataComment = {"comment":"1","site":"https:\/\/www.visiontimes.com","article_link":"https:\/\/www.visiontimes.com\/2022\/05\/03\/communist-flags-montreal-may-day-protest-vandalism.html"};
</script>
<script type="application/javascript" src="https://sdki.truepush.com/sdk/v2.0.3/app.js" async></script>
<script>
    var truepush = window.Truepush || [];
        truepush.push( function() {
        truepush.Init({
            id : "620c00246daffbb98a21b770",
fromWordpress : true,
local : false,
wordpresspath : "https://www.visiontimes.com/wp-content/plugins/truepush-free-web-push-notifications/",
        },function(error){
          if(error) console.error(error);
        })
    });
    </script>
<link rel="icon" href="https://img.visiontimes.com/2021/04/cropped-favicon-512x512-1-1-32x32.png" sizes="32x32" />
<link rel="icon" href="https://img.visiontimes.com/2021/04/cropped-favicon-512x512-1-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://img.visiontimes.com/2021/04/cropped-favicon-512x512-1-1-180x180.png" />
<meta name="msapplication-TileImage" content="https://img.visiontimes.com/2021/04/cropped-favicon-512x512-1-1-270x270.png" />
</head>
<body>
<a href="#mainContent" class="skipLink">
Skip to main content
</a>
<div class="pageWrapper">
<header class="mainHeader">
<div is="vision-top-header">
<nav class="visionComponent  navigation-TopBarMenu" aria-label="Main">
<div class="wrap">
<div class="header-menu header-menu-menu">
<ul class="menu">
<li class="menu-item " tabindex="-1">
<a class="menu-link" href="#" tabindex="-1">Editions</a>
<ul class="sub-menus">
<li class="menu-item">
<a class="menu-link" href="https://www.secretchina.com/">Chinese</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://es.visiontimes.com/">Spanish</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.fr/">French</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.it/">Italian</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://visiontimesjp.com/">Japanese</a>
</li>
</ul>
<i class="fas fa-angle-down"></i>
</li>
<li class="menu-item " tabindex="-1">
<a class="menu-link" href="https://visiontimes.us1.list-manage.com/subscribe?u=7e5b1c29f989d8d053d774db4&#038;id=3feabe35e7" tabindex="-1">Newsletter</a>
</li>
<li class="menu-item " tabindex="-1">
<a class="menu-link" href="https://www.visiontimes.com/donations" tabindex="-1">Donate</a>
</li>
<li class="menu-item " tabindex="-1">
<a class="menu-link" href="https://www.visiontimes.com/about-us" tabindex="-1">About US</a>
</li>
</ul>
</div>
<div class="header-menu header-menu-social">
<ul>
<li><a href="https://t.me/visiontimes" target="_blank" rel="nofollow" title="Telegram"><i class="fab fa-telegram-plane"></i></a></li>
<li><a href="https://twitter.com/times_vision" target="_blank" rel="nofollow" title="Twitter"><i class="fab fa-twitter"></i></a></li>
<li><a href="https://www.youtube.com/c/VisionTimesNews" target="_blank" rel="nofollow" title="Youtube"><i class="fab fa-youtube"></i></a></li>
 <li><a href="https://www.facebook.com/VisionTimesOfficial" target="_blank" rel="nofollow" title="Facebook"> <i class="fab fa-facebook-f"></i></a></li>
<li><a href="https://safechat.com/channel/2788089756776450736" target="_blank" rel="nofollow" title="SafeChat"><i class="fab fa-safechat"></i></a></li>
</ul>
</div>
</div>
</nav>
<div class="header-top-middle">
<div class="vision-weather-widget" is="vision-weather-widget">
<div class="top-left-wrap">
<nav is="vision-navigation-side" class="visionComponent">
<div class="overlay"></div>
<div class="section-button">
<div class="large-section-button">
<div class="text">SECTIONS</div>
<i class="fas fa-bars"></i>
</div>
<div class="sm-section-button">
<img src="https://www.visiontimes.com/wp-content/themes/vt/dist/assets/images/menu-mobile-926eb40a4c.svg">
</div>
</div>
<div class="nav-side">
<div class="menu ">
<div class="e-button">
<a href="https://visiontimes.us1.list-manage.com/subscribe?u=7e5b1c29f989d8d053d774db4&#038;id=3feabe35e7">
<span class="text">Newsletter</span>
</a>
</div>
<div class="menu-button"></div>
<ul class="menu-items">
<li class="menu-item  menu-item menu-item-type-custom menu-item-object-custom menu-item-428032  menu-first  level-1">
<a class="menu-link" href="/">Home</a>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-423521 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/news">News</a>
<i class="fas fa-angle-right"></i>
<div class="sub-menu-wrap">
<ul class="sub-menus">
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423525 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/politics">Politics</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423526 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/society">Society</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33185 menu-item-has-children level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/tech">Tech</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423523 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/health">Health</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423524 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/human-rights">Human Rights</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423522 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/analysis">Analysis</a>
</li>
</ul>
<i class="fas fa-caret-left"></i>
</div>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category menu-item-444027  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/opinions">Viewpoints</a>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category menu-item-357119 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/us">US</a>
 <i class="fas fa-angle-right"></i>
<div class="sub-menu-wrap">
<ul class="sub-menus">
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423514 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/us/us-politics">Politics</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423520 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/us/us-foreign-policy">Foreign Policy</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423515 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/us/new-york">New York</a>
</li>
</ul>
<i class="fas fa-caret-left"></i>
</div>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category menu-item-220229 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/china">China</a>
<i class="fas fa-angle-right"></i>
<div class="sub-menu-wrap">
<ul class="sub-menus">
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-437130 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/china/china-politics">Politics</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-437131 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/china/china-economy">Economy</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-437133 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/china/china-foreign-relations">International Relations</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-437129 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/china/china-society">Society</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-413925 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/china/china-culture">Chinese Culture</a>
</li>
</ul>
<i class="fas fa-caret-left"></i>
</div>
</li>
<li class="menu-item  world menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-989 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/world">World</a>
<i class="fas fa-angle-right"></i>
<div class="sub-menu-wrap">
<ul class="sub-menus">
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-414013 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/world/americas">Americas</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-444029 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/world/americas/canada">Canada</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-414014 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/world/asia-pacific">Asia-Pacific</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-414016 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/world/south-asia">South Asia</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-414015 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/world/europe">Europe</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-414012 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/world/africa">Africa</a>
</li>
</ul>
<i class="fas fa-caret-left"></i>
</div>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423502 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/culture">Culture</a>
<i class="fas fa-angle-right"></i>
<div class="sub-menu-wrap">
<ul class="sub-menus">
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423512 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/culture/arts">Arts</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423503 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/culture/traditions">Traditions</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423513 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/culture/wisdom">Wisdom</a>
</li>
</ul>
<i class="fas fa-caret-left"></i>
</div>
</li>
<li class="menu-item  life menu-item menu-item-type-taxonomy menu-item-object-category menu-item-985 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/life">Life</a>
<i class="fas fa-angle-right"></i>
<div class="sub-menu-wrap">
<ul class="sub-menus">
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423493 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/life/wellness">Wellness</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423518 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/life/mind-spirit">Mind &amp; Spirit</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423517 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/life/gardening">Gardening</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423516 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/life/entertainment">Entertainment</a>
</li>
</ul>
<i class="fas fa-caret-left"></i>
</div>
</li>
 <li class="menu-item  science menu-item menu-item-type-taxonomy menu-item-object-category menu-item-997 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/nature">Nature</a>
<i class="fas fa-angle-right"></i>
<div class="sub-menu-wrap">
<ul class="sub-menus">
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33187 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/nature/environment">Environment</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-425150 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/nature/disasters">Disasters</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33191 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/nature/mysteries">Mysteries</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33183 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/space">Space</a>
</li>
</ul>
<i class="fas fa-caret-left"></i>
</div>
</li>
<li class="menu-item  newsletter menu-item menu-item-type-custom menu-item-object-custom menu-item-429905  level-1">
<a class="menu-link" href="https://visiontimes.us1.list-manage.com/subscribe?u=7e5b1c29f989d8d053d774db4&#038;id=3feabe35e7" target="_blank" rel="noopener noreferrer">Newsletter</a>
</li>
</ul>
</div>
</div>
</nav>
<div class="search">
<form is="vision-search-form-expandable" id="searchform" name="searchform" class="search-form" method="post" action="https://www.visiontimes.com">
<input type="text" class="search-field" name="s" placeholder="Search" value="">
<button class="btn search-button"><i class="fas fa-search"></i></button>
</form>
</div>
</div>
<div class="vision-current-date-widget" is="vision-current-date-widget"></div>
</div>
<div class="vision-top-banner">
<ul class="menu">
<li class="menu-item ">
<a class="menu-link" href="/">
HOME
</a>
</li>
<li class="menu-item ">
<a class="menu-link" href="https://www.visiontimes.com/c/news">
NEWS
</a>
</li>
<li class="menu-item ">
<a class="menu-link" href="https://www.visiontimes.com/c/opinions">
VIEWPOINTS
</a>
</li>
<li class="menu-item ">
<a class="menu-link" href="https://www.visiontimes.com/c/us">
US
</a>
</li>
<li class="menu-item ">
<a class="menu-link" href="https://www.visiontimes.com/c/china">
CHINA
</a>
</li>
<li class="menu-item ">
<a class="menu-link" href="https://www.visiontimes.com/c/world">
WORLD
</a>
</li>
<li class="menu-item ">
<a class="menu-link" href="https://www.visiontimes.com/c/culture">
CULTURE
</a>
</li>
<li class="menu-item ">
<a class="menu-link" href="https://www.visiontimes.com/c/life">
LIFE
</a>
</li>
<li class="menu-item ">
<a class="menu-link" href="https://www.visiontimes.com/c/nature">
NATURE
</a>
</li>
<li class="menu-item ">
<a class="menu-link" href="https://visiontimes.us1.list-manage.com/subscribe?u=7e5b1c29f989d8d053d774db4&#038;id=3feabe35e7" target="_blank" rel="noopener noreferrer">
NEWSLETTER
</a>
</li>
</ul>
<div>
<a href="https://www.visiontimes.com" title="Home"><img src="https://www.visiontimes.com/wp-content/themes/vt/dist/assets/images/vision-times-logo-fc9b3d60e2.svg" alt="Vision Times"></a>
</div>
</div>
<div class="vision-e-paper">
<a href="https://visiontimes.us1.list-manage.com/subscribe?u=7e5b1c29f989d8d053d774db4&#038;id=3feabe35e7" rel="noreferrer noopener">
<div class="e-button">
<span class="text">Newsletter</span>
</div>
</a>
<a href="http://pdf.secretchina.com/index.php?city=NewYork_en" target="_blank">
<div class="e-button prime-white">
<span class="text">e-Paper</span>
</div>
</a>
</div>
</div>
<div class="top-border">Truth, Inspiration, Hope.</div>
</div>
<nav class="visionComponent vision-sticky-bar " is="vision-top-bar-sticky" aria-label="Main">
<div class="wrap">
<nav is="vision-navigation-side" class="visionComponent">
<div class="overlay"></div>
<div class="section-button">
<div class="large-section-button">
<div class="text">SECTIONS</div>
<i class="fas fa-bars"></i>
</div>
<div class="sm-section-button">
<img src="https://www.visiontimes.com/wp-content/themes/vt/dist/assets/images/menu-mobile-926eb40a4c.svg">
</div>
</div>
<div class="nav-side">
<div class="menu ">
<div class="e-button">
<a href="https://visiontimes.us1.list-manage.com/subscribe?u=7e5b1c29f989d8d053d774db4&#038;id=3feabe35e7">
<span class="text">Newsletter</span>
</a>
</div>
<div class="menu-button"></div>
<ul class="menu-items">
<li class="menu-item  menu-item menu-item-type-custom menu-item-object-custom menu-item-428032  menu-first  level-1">
<a class="menu-link" href="/">Home</a>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-423521 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/news">News</a>
<i class="fas fa-angle-right"></i>
<div class="sub-menu-wrap">
<ul class="sub-menus">
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423525 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/politics">Politics</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423526 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/society">Society</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33185 menu-item-has-children level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/tech">Tech</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423523 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/health">Health</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423524 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/human-rights">Human Rights</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423522 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/analysis">Analysis</a>
</li>
</ul>
<i class="fas fa-caret-left"></i>
 </div>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category menu-item-444027  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/opinions">Viewpoints</a>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category menu-item-357119 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/us">US</a>
<i class="fas fa-angle-right"></i>
<div class="sub-menu-wrap">
<ul class="sub-menus">
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423514 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/us/us-politics">Politics</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423520 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/us/us-foreign-policy">Foreign Policy</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423515 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/us/new-york">New York</a>
</li>
</ul>
<i class="fas fa-caret-left"></i>
</div>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category menu-item-220229 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/china">China</a>
<i class="fas fa-angle-right"></i>
<div class="sub-menu-wrap">
<ul class="sub-menus">
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-437130 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/china/china-politics">Politics</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-437131 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/china/china-economy">Economy</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-437133 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/china/china-foreign-relations">International Relations</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-437129 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/china/china-society">Society</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-413925 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/china/china-culture">Chinese Culture</a>
</li>
</ul>
<i class="fas fa-caret-left"></i>
</div>
</li>
<li class="menu-item  world menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-989 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/world">World</a>
<i class="fas fa-angle-right"></i>
<div class="sub-menu-wrap">
<ul class="sub-menus">
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-414013 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/world/americas">Americas</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-444029 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/world/americas/canada">Canada</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-414014 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/world/asia-pacific">Asia-Pacific</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-414016 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/world/south-asia">South Asia</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-414015 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/world/europe">Europe</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-414012 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/world/africa">Africa</a>
</li>
</ul>
<i class="fas fa-caret-left"></i>
</div>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423502 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/culture">Culture</a>
<i class="fas fa-angle-right"></i>
<div class="sub-menu-wrap">
<ul class="sub-menus">
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423512 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/culture/arts">Arts</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423503 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/culture/traditions">Traditions</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423513 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/culture/wisdom">Wisdom</a>
</li>
</ul>
<i class="fas fa-caret-left"></i>
</div>
</li>
<li class="menu-item  life menu-item menu-item-type-taxonomy menu-item-object-category menu-item-985 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/life">Life</a>
<i class="fas fa-angle-right"></i>
<div class="sub-menu-wrap">
<ul class="sub-menus">
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423493 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/life/wellness">Wellness</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423518 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/life/mind-spirit">Mind &amp; Spirit</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423517 level-2">
 <a class="menu-link" href="https://www.visiontimes.com/c/life/gardening">Gardening</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423516 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/life/entertainment">Entertainment</a>
</li>
</ul>
<i class="fas fa-caret-left"></i>
</div>
</li>
<li class="menu-item  science menu-item menu-item-type-taxonomy menu-item-object-category menu-item-997 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/nature">Nature</a>
<i class="fas fa-angle-right"></i>
<div class="sub-menu-wrap">
<ul class="sub-menus">
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33187 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/nature/environment">Environment</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-425150 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/nature/disasters">Disasters</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33191 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/nature/mysteries">Mysteries</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33183 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/space">Space</a>
</li>
</ul>
<i class="fas fa-caret-left"></i>
</div>
</li>
<li class="menu-item  newsletter menu-item menu-item-type-custom menu-item-object-custom menu-item-429905  level-1">
<a class="menu-link" href="https://visiontimes.us1.list-manage.com/subscribe?u=7e5b1c29f989d8d053d774db4&#038;id=3feabe35e7" target="_blank" rel="noopener noreferrer">Newsletter</a>
</li>
</ul>
</div>
</div>
</nav>
<div class="search">
<form is="vision-search-form-expandable" id="searchform" name="searchform" class="search-form" method="post" action="https://www.visiontimes.com">
<input type="text" class="search-field" name="s" placeholder="Search" value="">
<button class="btn search-button"><i class="fas fa-search"></i></button>
</form>
</div>
</div>
<ul class="menu">
<li class="menu-item">
<a class="menu-link" href="/">
HOME
</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/c/news">
NEWS
</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/c/opinions">
VIEWPOINTS
</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/c/us">
US
</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/c/china">
CHINA
</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/c/world">
WORLD
</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/c/culture">
CULTURE
</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/c/life">
LIFE
</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/c/nature">
NATURE
</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://visiontimes.us1.list-manage.com/subscribe?u=7e5b1c29f989d8d053d774db4&#038;id=3feabe35e7" target="_blank" rel="noopener noreferrer">
NEWSLETTER
</a>
</li>
</ul>
<div class="header-menu-social">
<ul>
<li><a href="" target="_blank" rel="nofollow" title="Telegram"><i class="fab fa-telegram-plane"></i></a></li>
<li><a href="" target="_blank" rel="nofollow" title="Twitter"><i class="fab fa-twitter"></i></a></li>
<li><a href="" target="_blank" rel="nofollow" title="Youtube"><i class="fab fa-youtube"></i></a></li>
<li><a href="" target="_blank" rel="nofollow" title="Facebook"> <i class="fab fa-facebook-f"></i></a></li>
</ul>
</div>
</nav>
<nav is="vision-navigation-burger" class="visionComponent" aria-label="Main">
<nav class="navigation-TopBarMenu-mobile" aria-label="Main">
<div class="wrap">
<div class="header-menu header-menu-menu">
<ul class="menu">
<li class="menu-item menu-item-1 " tabindex="-1">
<a class="menu-link" href="#">Editions</a>
<ul class="sub-menus">
<li class="menu-item">
<a class="menu-link" href="https://www.secretchina.com/">Chinese</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://es.visiontimes.com/">Spanish</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.fr/">French</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.it/">Italian</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://visiontimesjp.com/">Japanese</a>
</li>
</ul>
<i class="fas fa-angle-down"></i>
</li>
<li class="menu-item menu-item-2 " tabindex="-1">
<a class="menu-link" href="https://visiontimes.us1.list-manage.com/subscribe?u=7e5b1c29f989d8d053d774db4&#038;id=3feabe35e7">Newsletter</a>
</li>
<li class="menu-item menu-item-3 " tabindex="-1">
<a class="menu-link" href="https://www.visiontimes.com/donations">Donate</a>
</li>
<li class="menu-item menu-item-4 " tabindex="-1">
<a class="menu-link" href="https://www.visiontimes.com/about-us">About US</a>
</li>
</ul>
</div>
<div class="header-menu header-menu-social">
<ul>
<li><a href="https://t.me/visiontimes" target="_blank" rel="nofollow" title="Telegram"><i class="fab fa-telegram-plane"></i></a></li>
<li><a href="https://twitter.com/times_vision" target="_blank" rel="nofollow" title="Twitter"><i class="fab fa-twitter"></i></a></li>
<li><a href="https://www.youtube.com/c/VisionTimesNews" target="_blank" rel="nofollow" title="Youtube"><i class="fab fa-youtube"></i></a></li>
<li><a href="https://www.facebook.com/VisionTimesOfficial" target="_blank" rel="nofollow" title="Facebook"> <i class="fab fa-facebook-f"></i></a></li>
<li><a href="https://safechat.com/channel/2788089756776450736" target="_blank" rel="nofollow" title="SafeChat"><i class="fab fa-safechat"></i></a></li>
</ul>
</div>
</div>
</nav>
<div class="container centerMaxWidthContainer">
<div class="vision-hamburger" is="vision-hamburger">
<div class="top-left-wrap">
<nav is="vision-navigation-side" class="visionComponent">
<div class="overlay"></div>
<div class="section-button">
<div class="large-section-button">
<div class="text">SECTIONS</div>
<i class="fas fa-bars"></i>
</div>
<div class="sm-section-button">
<img src="https://www.visiontimes.com/wp-content/themes/vt/dist/assets/images/menu-mobile-926eb40a4c.svg">
</div>
</div>
<div class="nav-side">
<div class="menu lite">
<div class="e-button">
<a href="https://visiontimes.us1.list-manage.com/subscribe?u=7e5b1c29f989d8d053d774db4&#038;id=3feabe35e7">
<span class="text">Newsletter</span>
</a>
</div>
<div class="menu-button"></div>
<ul class="menu-items">
<li class="menu-item  menu-item menu-item-type-custom menu-item-object-custom menu-item-428032  menu-first  level-1">
<a class="menu-link" href="/">Home</a>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-423521 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/news">News</a>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category menu-item-444027  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/opinions">Viewpoints</a>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category menu-item-357119 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/us">US</a>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category menu-item-220229 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/china">China</a>
</li>
<li class="menu-item  world menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-989 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/world">World</a>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423502 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/culture">Culture</a>
</li>
<li class="menu-item  life menu-item menu-item-type-taxonomy menu-item-object-category menu-item-985 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/life">Life</a>
</li>
<li class="menu-item  science menu-item menu-item-type-taxonomy menu-item-object-category menu-item-997 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/nature">Nature</a>
</li>
<li class="menu-item  newsletter menu-item menu-item-type-custom menu-item-object-custom menu-item-429905  level-1">
<a class="menu-link" href="https://visiontimes.us1.list-manage.com/subscribe?u=7e5b1c29f989d8d053d774db4&#038;id=3feabe35e7" target="_blank" rel="noopener noreferrer">Newsletter</a>
</li>
</ul>
</div>
</div>
</nav>
<div class="search">
<form is="vision-search-form-expandable" id="searchform" name="searchform" class="search-form" method="post" action="">
<input type="text" class="search-field" name="s" placeholder="Search" value="">
<button class="btn search-button"><i class="fas fa-search"></i></button>
</form>
</div>
</div>
</div>
<div class="logo">
<a href="https://www.visiontimes.com" title="Home"><img src="https://www.visiontimes.com/wp-content/themes/vt/dist/assets/images/vision-times-sm-logo-66a6be678b.svg" alt="Vision Times"></a>
</div>
<div class="vision-e-paper">
<a href="https://visiontimes.us1.list-manage.com/subscribe?u=7e5b1c29f989d8d053d774db4&#038;id=3feabe35e7" rel="noreferrer noopener">
<div class="e-button">
<span class="text">Newsletter</span>
</div>
</a>
</div>
</div>
<div class="top-border">Truth, Inspiration, Hope.</div>
</nav>
</header>
<main id="mainContent" class="mainContent" aria-label="Content">
<div class="content-wrapper single-wrapper">
<header>
<nav aria-label="breadcrumbs" class="rank-math-breadcrumb"><p><a href="https://www.visiontimes.com">Home</a><span class="separator"> &raquo; </span><a href="https://www.visiontimes.com/c/world">World</a><span class="separator"> &raquo; </span><span class="last">Communist Flags Fly at Montreal ‘Workers Day’ Protest, US Flag Burned, Windows Smashed, Buildings Graffitied</span></p></nav><div is="bread-crumbs">
</div>
<div is="vision-block-post-header-vt">
<h1>Communist Flags Fly at Montreal ‘Workers Day’ Protest, US Flag Burned, Windows Smashed, Buildings Graffitied</h1>
<div class="meta">
<div class="author-time">
<div class="visionComponent" is="vision-authors-custom">
<div class="authors">
<div class="author">
<div class="img"><img alt='' src='https://secure.gravatar.com/avatar/9c9ffa87d3efefc52357a66f5e161ee6?s=30&#038;r=g' srcset='https://secure.gravatar.com/avatar/9c9ffa87d3efefc52357a66f5e161ee6?s=60&#038;r=g 2x' class='avatar avatar-30 photo' height='30' width='30' loading='lazy' /></div>
<div class="info">
<div class="name">By
<a href="https://www.visiontimes.com/author/neil-c">
Neil Campbell
</a>
</div>
<div class="desc">Neil lives in Canada and writes about society and politics.</div>
</div>
</div>
</div>
<div class="date">Published: May 3, 2022</div>
</div>
</div>
<div class="view-comment">
<div is="vision-media-share" class="visionComponent">
<div class="share-button">
<i class="far fa-share-square"></i>
<div class="share-wrap">
<div class="up-triangle"></div>
<div class="share-padding">
<ul class="share-menu">
<li>
<a target="_blank" href="https://twitter.com/intent/tweet?text=Communist%20Flags%20Fly%20at%20Montreal%20%E2%80%98Workers%20Day%E2%80%99%20Protest%2C%20US%20Flag%20Burned%2C%20Windows%20Smashed%2C%20Buildings%20Graffitied&amp;url=https%3A%2F%2Fwww.visiontimes.com%2F2022%2F05%2F03%2Fcommunist-flags-montreal-may-day-protest-vandalism.html" rel="noopener noreferrer nofollow">
<i class="fab fa-twitter"></i>
</a>
</li>
<li>
<a target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.visiontimes.com%2F2022%2F05%2F03%2Fcommunist-flags-montreal-may-day-protest-vandalism.html" rel="noopener noreferrer nofollow">
<i class="fab fa-facebook"></i>
</a>
</li>
<li>
<a target="_blank" href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.visiontimes.com%2F2022%2F05%2F03%2Fcommunist-flags-montreal-may-day-protest-vandalism.html&amp;media=https%3A%2F%2Fimg.visiontimes.com%2F2022%2F05%2FMontreal-May-Day-Protest-Communist-Party-of-Canada-Hammer-and-Sickle-Flag-Burn-American-Flag.jpg&amp;description=Montreal%20Communist%20Party%20of%20Canada%20members%20wielding%20the%20Hammer%20and%20Sickle%20burned%20a%20US%20Flag%20during%20the%20May%201%20protests." rel="noopener noreferrer nofollow" data-pin-no-hover="true" data-pin-custom="true" data-pin-do="skip" data-pin-description="Montreal%20Communist%20Party%20of%20Canada%20members%20wielding%20the%20Hammer%20and%20Sickle%20burned%20a%20US%20Flag%20during%20the%20May%201%20protests.">
<i class="fab fa-pinterest"></i>
</a>
</li>
<li>
<a target="_blank" href="https://www.linkedin.com/sharing/share-offsite/?url=https%3A%2F%2Fwww.visiontimes.com%2F2022%2F05%2F03%2Fcommunist-flags-montreal-may-day-protest-vandalism.html" rel="noopener noreferrer nofollow">
<i class="fab fa-linkedin"></i>
</a>
</li>
<li>
<a href="/cdn-cgi/l/email-protection#e0df828f8499dda9c5d2d092858184c5d2d094888993c5d2d0908f9394c5d2d0818e84c5d2d097818e948584c5d2d0948fc5d2d09388819285c5d2d08994c5d2d097899488c5d2d0998f95cec5d2d0a8859285c5d2d793c5d2d0948885c5d2d08c898e8bc5d3a1c5d2d08894949093c5d3a1c5d2a6c5d2a6979797ce968993898f8e94898d8593ce838f8dc5d2a6d2d0d2d2c5d2a6d0d5c5d2a6d0d3c5d2a6838f8d8d958e899394cd868c818793cd8d8f8e949285818ccd8d8199cd848199cd90928f94859394cd96818e84818c89938dce88948d8cc6818d90db9395828a858394dda1c5d2d0908f9394c5d2d0978f929488c5d2d093888192898e87c5d3a1c5d2d0a38f8d8d958e899394c5d2d0a68c818793c5d2d0a68c99c5d2d08194c5d2d0ad8f8e949285818cc5d2d0c5a5d2c5d8d0c5d9d8b78f928b859293c5d2d0a48199c5a5d2c5d8d0c5d9d9c5d2d0b0928f94859394c5d2a3c5d2d0b5b3c5d2d0a68c8187c5d2d0a295928e8584c5d2a3c5d2d0b7898e848f9793c5d2d0b38d8193888584c5d2a3c5d2d0a295898c84898e8793c5d2d0a7928186868994898584" rel="noopener noreferrer nofollow">
<i class="fas fa-envelope"></i>
</a>
</li>
</ul>
</div>
</div>
</div>
</div>
<span class="comment-count" title="Jump to comment"><i class="far fa-comments"></i></span>
</div>
</div>
<div class="social-btns">
<div is="social-buttons">
<a class="button twitter" target="_blank" href="https://twitter.com/intent/tweet?text=Communist%20Flags%20Fly%20at%20Montreal%20%E2%80%98Workers%20Day%E2%80%99%20Protest%2C%20US%20Flag%20Burned%2C%20Windows%20Smashed%2C%20Buildings%20Graffitied&amp;url=https%3A%2F%2Fwww.visiontimes.com%2F2022%2F05%2F03%2Fcommunist-flags-montreal-may-day-protest-vandalism.html" rel="noopener noreferrer nofollow"><span class="txt">Twitter</span></a>
<a class="button facebook" target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.visiontimes.com%2F2022%2F05%2F03%2Fcommunist-flags-montreal-may-day-protest-vandalism.html" rel="noopener noreferrer nofollow"><span class="txt">Facebook</span></a>
<a class="button pinterest" target="_blank" href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.visiontimes.com%2F2022%2F05%2F03%2Fcommunist-flags-montreal-may-day-protest-vandalism.html&amp;media=https%3A%2F%2Fimg.visiontimes.com%2F2022%2F05%2FMontreal-May-Day-Protest-Communist-Party-of-Canada-Hammer-and-Sickle-Flag-Burn-American-Flag.jpg&amp;description=Montreal%20Communist%20Party%20of%20Canada%20members%20wielding%20the%20Hammer%20and%20Sickle%20burned%20a%20US%20Flag%20during%20the%20May%201%20protests." rel="noopener noreferrer nofollow" data-pin-no-hover="true" data-pin-custom="true" data-pin-do="skip" data-pin-description="Montreal%20Communist%20Party%20of%20Canada%20members%20wielding%20the%20Hammer%20and%20Sickle%20burned%20a%20US%20Flag%20during%20the%20May%201%20protests."><span class="txt">Pinterest</span></a>
<a class="button linkedin" target="_blank" href="https://www.linkedin.com/shareArticle?mini=1&amp;url=https%3A%2F%2Fwww.visiontimes.com%2F2022%2F05%2F03%2Fcommunist-flags-montreal-may-day-protest-vandalism.html&amp;title=Communist%20Flags%20Fly%20at%20Montreal%20%E2%80%98Workers%20Day%E2%80%99%20Protest%2C%20US%20Flag%20Burned%2C%20Windows%20Smashed%2C%20Buildings%20Graffitied&amp;source=https%3A%2F%2Fwww.visiontimes.com" rel="noopener noreferrer nofollow"><span class="txt">LinkedIn</span></a>
<a class="button email" href="/cdn-cgi/l/email-protection#08376a676c7135412d3a387a6d696c2d3a387c60617b2d3a3878677b7c2d3a3869666c2d3a387f69667c6d6c2d3a387c672d3a387b60697a6d2d3a38617c2d3a387f617c602d3a3871677d262d3a38406d7a6d2d3a3f7b2d3a387c606d2d3a38646166632d3b492d3a38607c7c787b2d3b492d3a4e2d3a4e7f7f7f267e617b6167667c61656d7b266b67652d3a4e3a383a3a2d3a4e383d2d3a4e383b2d3a4e6b6765657d66617b7c256e64696f7b256567667c7a6d696425656971256c697125787a677c6d7b7c257e69666c6964617b6526607c65642e696578337b7d6a626d6b7c35492d3a3878677b7c2d3a387f677a7c602d3a387b60697a61666f2d3b492d3a384b6765657d66617b7c2d3a384e64696f7b2d3a384e64712d3a38697c2d3a384567667c7a6d69642d3a382d4d3a2d30382d31305f677a636d7a7b2d3a384c69712d4d3a2d30382d31312d3a38587a677c6d7b7c2d3a4b2d3a385d5b2d3a384e64696f2d3a384a7d7a666d6c2d3a4b2d3a385f61666c677f7b2d3a385b65697b606d6c2d3a4b2d3a384a7d61646c61666f7b2d3a384f7a696e6e617c616d6c" rel="noopener noreferrer nofollow"><span class="txt">Email</span></a>
</div>
</div>
</div>
</header>
<section class="post-main">
<div class="col-left">
<div class="with-gray-border-right">
<div class="col-left-content">
<div class="featuredImage">
<div class="visionComponent visionComponent--sizeLarge  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/05/Montreal-May-Day-Protest-Communist-Party-of-Canada-Hammer-and-Sickle-Flag-Burn-American-Flag-768x515.jpg" srcset="
                                    https://img.visiontimes.com/2022/05/Montreal-May-Day-Protest-Communist-Party-of-Canada-Hammer-and-Sickle-Flag-Burn-American-Flag.jpg 1920w,
            https://img.visiontimes.com/2022/05/Montreal-May-Day-Protest-Communist-Party-of-Canada-Hammer-and-Sickle-Flag-Burn-American-Flag.jpg 1440w,
            https://img.visiontimes.com/2022/05/Montreal-May-Day-Protest-Communist-Party-of-Canada-Hammer-and-Sickle-Flag-Burn-American-Flag.jpg 1320w,
            https://img.visiontimes.com/2022/05/Montreal-May-Day-Protest-Communist-Party-of-Canada-Hammer-and-Sickle-Flag-Burn-American-Flag.jpg 1024w,
            https://img.visiontimes.com/2022/05/Montreal-May-Day-Protest-Communist-Party-of-Canada-Hammer-and-Sickle-Flag-Burn-American-Flag-768x515.jpg 800w,
            https://img.visiontimes.com/2022/05/Montreal-May-Day-Protest-Communist-Party-of-Canada-Hammer-and-Sickle-Flag-Burn-American-Flag-696x467.jpg 600w,
                                                            https://img.visiontimes.com/2022/05/Montreal-May-Day-Protest-Communist-Party-of-Canada-Hammer-and-Sickle-Flag-Burn-American-Flag-485x360.jpg 375w" data-sizes="auto" alt="Montreal Communist Party of Canada members wielding the Hammer and Sickle burned a US Flag during the May 1 protests.">
<figcaption class="figure-caption">A United States Flag was burned during Montreal’s May 1 “May Day” so-called “anti-capitalist” protest. The Communist Party of Canada’s Flag and the Hammer and Sickle flew as participants smashed windows, vandalized cars, and spray painted buildings as police deployed tear gas in response. (Image: Twitter screenshot)</figcaption>
</figure>
</div>
</div>
</div>
<div class="article-content">
<p>The Hammer and Sickle Flag, the symbol of the Communist Party and communist ideology, was flown at an annual May 1 International Workers Day protest in Montreal where buildings were grafitted and businesses suffered broken windows.&nbsp;</p>
<p>Additionally, the Communist Party of Canada also turned out in force with their flags in tow to participate in the event.&nbsp;</p>
<p>Montreal Police deployed tear gas to quash the unrest.</p>
<figure class="wp-block-embed is-type-rich is-provider-twitter wp-block-embed-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="500" data-dnt="true"><p lang="en" dir="ltr">Anti-Capitalist <a href="https://twitter.com/hashtag/May1?src=hash&amp;ref_src=twsrc%5Etfw" target="_blank" rel="noopener">#May1</a> protest in <a href="https://twitter.com/hashtag/Montreal?src=hash&amp;ref_src=twsrc%5Etfw" target="_blank" rel="noopener">#Montreal</a> <a href="https://twitter.com/hashtag/cndpoli?src=hash&amp;ref_src=twsrc%5Etfw" target="_blank" rel="noopener">#cndpoli</a> <a href="https://twitter.com/hashtag/MayDay2022?src=hash&amp;ref_src=twsrc%5Etfw" target="_blank" rel="noopener">#MayDay2022</a> <br>Police fire multiple rounds of teargas to attempt to disperse the crowd <a href="https://t.co/wOp9sVyDqn" target="_blank">pic.twitter.com/wOp9sVyDqn</a></p>&mdash; ProtestMTL (@MtlProtest) <a href="https://twitter.com/MtlProtest/status/1520904339086319616?ref_src=twsrc%5Etfw" target="_blank" rel="noopener">May 1, 2022</a></blockquote><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div></figure>
<p>The event is colloquially referred to as “May Day,” and appears to be organized by the Montreal chapter of Convergence des Luttes Anticapitalistes (CLAC), based on a statement posted on the group’s website taking responsibility.&nbsp;</p>
<p>“On May 1, 2022, following the call of the Anti-capitalist Convergence (CLAC), more than half a thousand people took to the streets for Workers&#8217; Day,” reads a Google translation of the French-language post.</p>
<h3><strong>CANADA PROTEST ARTICLES</strong></h3>
<ul><li><strong><a href="https://www.visiontimes.com/2022/04/25/rcmp-logged-journalists-media-twitter-users-musical-ride-whatsapp-leak.html">RCMP Logged Journalists, Twitter Users Who Shared Musical Ride WhatsApp Leak Scandal</a></strong></li><li><strong><a href="https://www.visiontimes.com/2022/02/25/donation-campaigns-coastal-gaslink-axe-attack.html">‘Donation Campaigns’ Sustaining Outside Actors Stoking BC Natural Gas Production Site Axe-attack</a></strong></li><li><a href="https://www.visiontimes.com/2022/02/23/canada-quashing-freedom-convoy-similar-to-hong-kong.html"><strong>Ottawa Imitates Authoritarian Regimes With Violent Crackdown on Canada’s Freedom Convoy Protests</strong></a></li></ul>
<p>CLAC declared the theme for this year’s event “Colonial and ecocidal, capitalism is war!”</p>
<p>The article used further extreme verbiage to decry Montreal Police, who they claimed utilized “rottenness” in order to “repress, beat and prevent activists from expressing their hatred towards a colonial system leading us straight towards the ecological precipice.”</p>
<figure class="wp-block-embed is-type-rich is-provider-twitter wp-block-embed-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="500" data-dnt="true"><p lang="en" dir="ltr">Militant May Day greetings from Montreal and Toronto! <a href="https://twitter.com/hashtag/MayDay2022?src=hash&amp;ref_src=twsrc%5Etfw" target="_blank" rel="noopener">#MayDay2022</a> <a href="https://twitter.com/hashtag/1ermai2022?src=hash&amp;ref_src=twsrc%5Etfw" target="_blank" rel="noopener">#1ermai2022</a> <a href="https://t.co/V7dFBpTH8Q" target="_blank">pic.twitter.com/V7dFBpTH8Q</a></p>&mdash; Communist Party of Canada (@compartycanada) <a href="https://twitter.com/compartycanada/status/1520876045897023488?ref_src=twsrc%5Etfw" target="_blank" rel="noopener">May 1, 2022</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div></figure>
<p>A tweet from the official Communist Party of Canada account stated “Militant May Day greetings from Montreal and Toronto!” while posting two pictures, the French language of which showed participants <a href="https://www.visiontimes.com/2022/03/02/workers-united-starbucks-union-push-busting-complaints.html">raising the communist fist</a>, carrying Communist Party of Canada flags, and with some adorned in Marxist-Leninist propaganda.</p>
<figure class="wp-block-embed is-type-rich is-provider-twitter wp-block-embed-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="500" data-dnt="true"><p lang="en" dir="ltr">Lots of red flags in Montreal today! <a href="https://t.co/SiymqQ3v5A" target="_blank">https://t.co/SiymqQ3v5A</a> <a href="https://t.co/ul8bwRy3pB" target="_blank">pic.twitter.com/ul8bwRy3pB</a></p>&mdash; USSR Ice Hockey Federation (@RedMachineCCCP) <a href="https://twitter.com/RedMachineCCCP/status/1520876838876286979?ref_src=twsrc%5Etfw" target="_blank" rel="noopener">May 1, 2022</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div></figure>
<p>An additional post by a self-identified Marxist-Leninist showed multiple participants carrying Hammer and Sickle Flags.</p>
<figure class="wp-block-embed is-type-rich is-provider-twitter wp-block-embed-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="500" data-dnt="true"><p lang="en" dir="ltr">Anti-Capitalist <a href="https://twitter.com/hashtag/May1?src=hash&amp;ref_src=twsrc%5Etfw" target="_blank" rel="noopener">#May1</a> protest in <a href="https://twitter.com/hashtag/Montreal?src=hash&amp;ref_src=twsrc%5Etfw" target="_blank" rel="noopener">#Montreal</a> <a href="https://twitter.com/hashtag/cndpoli?src=hash&amp;ref_src=twsrc%5Etfw" target="_blank" rel="noopener">#cndpoli</a> <a href="https://twitter.com/hashtag/MayDay2022?src=hash&amp;ref_src=twsrc%5Etfw" target="_blank" rel="noopener">#MayDay2022</a> <br>Aftermath of the protest part 2 <a href="https://t.co/2j6Lvj3pKq" target="_blank">pic.twitter.com/2j6Lvj3pKq</a></p>&mdash; ProtestMTL (@MtlProtest) <a href="https://twitter.com/MtlProtest/status/1520910094879404033?ref_src=twsrc%5Etfw" target="_blank" rel="noopener">May 1, 2022</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div></figure>
<p>Photographs published to Twitter highlighting the “aftermath” of the protest showed downtown windows smashed and with a red Hammer and Sickle logo spray painted.</p>
<figure class="wp-block-embed is-type-rich is-provider-twitter wp-block-embed-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="500" data-dnt="true"><p lang="en" dir="ltr">Anti-Capitalist <a href="https://twitter.com/hashtag/May1?src=hash&amp;ref_src=twsrc%5Etfw" target="_blank" rel="noopener">#May1</a> protest in <a href="https://twitter.com/hashtag/Montreal?src=hash&amp;ref_src=twsrc%5Etfw" target="_blank" rel="noopener">#Montreal</a> <a href="https://twitter.com/hashtag/cndpoli?src=hash&amp;ref_src=twsrc%5Etfw" target="_blank" rel="noopener">#cndpoli</a> <a href="https://twitter.com/hashtag/MayDay2022?src=hash&amp;ref_src=twsrc%5Etfw" target="_blank" rel="noopener">#MayDay2022</a> <br>Burning an American Flag <a href="https://t.co/wskLMdsTrQ" target="_blank">pic.twitter.com/wskLMdsTrQ</a></p>&mdash; ProtestMTL (@MtlProtest) <a href="https://twitter.com/MtlProtest/status/1520902980559585282?ref_src=twsrc%5Etfw" target="_blank" rel="noopener">May 1, 2022</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div></figure>
<p>In another video, young participants in the event burned the United States Flag.</p>
<p>Another video captured footage of a large cluster of anarchist-style participants doned in black with faces cloaked by black balaclavas openly smashing windows.&nbsp;</p>
<figure class="wp-block-embed is-type-rich is-provider-twitter wp-block-embed-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="500" data-dnt="true"><p lang="en" dir="ltr">MONTREAL’S PROTEST TODAY <a href="https://twitter.com/tvanouvelles?ref_src=twsrc%5Etfw" target="_blank" rel="noopener">@tvanouvelles</a> <a href="https://twitter.com/RadioCanadaInfo?ref_src=twsrc%5Etfw" target="_blank" rel="noopener">@RadioCanadaInfo</a> <a href="https://twitter.com/CTVMontreal?ref_src=twsrc%5Etfw" target="_blank" rel="noopener">@CTVMontreal</a> <a href="https://twitter.com/CBCMontreal?ref_src=twsrc%5Etfw" target="_blank" rel="noopener">@CBCMontreal</a> <a href="https://twitter.com/CBCNews?ref_src=twsrc%5Etfw" target="_blank" rel="noopener">@CBCNews</a> <a href="https://twitter.com/CTVMontreal?ref_src=twsrc%5Etfw" target="_blank" rel="noopener">@CTVMontreal</a> <a href="https://t.co/0x0weKbbv1" target="_blank">pic.twitter.com/0x0weKbbv1</a></p>&mdash; Joshua Gariepy (@joshua_gariepy) <a href="https://twitter.com/joshua_gariepy/status/1520891108473065473?ref_src=twsrc%5Etfw" target="_blank" rel="noopener">May 1, 2022</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div></figure>
<p>After the photographer captured the scene, they were accosted by the group.&nbsp;</p>
<p>Canada’s federally funded establishment media conglomerates primarily painted the event as a peaceful one where workers sought better pay and working conditions, ignoring the presence of the Communist Party’s banner. </p>
<p>State messaging outlet Canadian Broadcasting Corporation <a href="https://www.cbc.ca/news/canada/montreal/increase-in-minimum-wage-insufficient-1.6437859" target="_blank" rel="noopener">described the event</a> as having a heavy participation by local unions, “Participants gathered in Cabot Square in downtown Montreal under sunny skies, many waving their union flags.”</p>
<p>Meanwhile, the <a href="https://montrealgazette.com/news/local-news/montreal-may-day-protesters-demand-higher-minimum-wage" target="_blank" rel="noopener">Montreal Gazette</a>, a branch of the Postmedia conglomerate, simply published a wire piece by The Canadian Press that characterized the event as a group of workers protesting that Quebec’s $14.25 hourly minimum wage is not high enough.</p>
<p>The wire characterized the event as “organized by a coalition of about 15 unions and organizations.”</p>
<p>May 1 also marked the day that a <a href="https://www.quebec.ca/nouvelles/actualites/details/hausse-du-salaire-minimum-a-compter-du-1er-mai-2022-le-ministre-jean-boulet-annonce-une-hausse-du-taux-general-de-075-lheure-37361" target="_blank" rel="noopener">January announcement</a> by the Provincial Government that the minimum wage would be increased from $13.50 per hour came into effect.</p>
<p><a href="https://montreal.ctvnews.ca/may-day-2022-quebec-workers-demand-higher-minimum-wage-increase-1.5883953" target="_blank" rel="noopener">CTV Canada</a>, a television station owned by telecom giant Bell Media, likewise merely republished The Canadian Press’s wire release.</p>
<p>Both the lack of coverage and the lack of befitting coverage is a sore spot for many Canadians who supported the Freedom Convoy trucker occupation protests when during the early stages of the protest an <a href="https://tnc.news/2022/01/30/everything-we-know-so-far-about-the-nazi-flag-guy2/" target="_blank" rel="noopener">individual carrying a Nazi Flag</a> was photographed among the crowd.</p>
<figure class="wp-block-embed is-type-rich is-provider-twitter wp-block-embed-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="500" data-dnt="true"><p lang="en" dir="ltr">This was the police presence in Ottawa for a peaceful protest.<br>Rioters smashing windows in Montreal but no cops? <a href="https://t.co/Qv8YlBuG8z" target="_blank">pic.twitter.com/Qv8YlBuG8z</a></p>&mdash; Teresa Reza (@teresa_reza) <a href="https://twitter.com/teresa_reza/status/1521188168187396103?ref_src=twsrc%5Etfw" target="_blank" rel="noopener">May 2, 2022</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div></figure>
<p>The footage was widely used by the establishment media to denigrate and dehumanize the protests as being composed of extremists.&nbsp;</p>
<p>Independent investigation by True North Canada offering a bounty as high as $6,000 gathered enough information to ascertain it was unlikely that the flag carrier was a bona fide protest participant, however.</p>
<figure class="wp-block-embed is-type-rich is-provider-twitter wp-block-embed-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="500" data-dnt="true"><p lang="en" dir="ltr">I loved seeing the communist flags 😂 <a href="https://t.co/yrn8qXHsB6" target="_blank">pic.twitter.com/yrn8qXHsB6</a></p>&mdash; Uncle (@UncleApes) <a href="https://twitter.com/UncleApes/status/1492683004824621057?ref_src=twsrc%5Etfw" target="_blank" rel="noopener">February 13, 2022</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div></figure>
<p>Additionally, during the week before the Trudeau Government took the unprecedented step of invoking the Emergencies Act to crackdown on the protest, a “counter protest” organized by the Public Service Alliance of Canada (PSAC) descended on Convoy participants.&nbsp;</p>
<p>During the counter protest, <a href="https://www.visiontimes.com/2022/02/13/public-employee-union-hammer-and-sickle-flag-freedom-convoy.html">participants were also seen carrying the Hammer and Sickle Flag</a>, a detail that went unreported by establishment media, who instead characterized the event as one organically organized by Ottawa residents fed up with the noise.</p>
<p>PSAC is the union that represents many Canadian Government employees, including those who work for casinos, universities, airports, the security sector, and the RCMP&#8217;s civilian staff. </p>
</div>
</div>
</div>
<footer class="post-meta">
<div class="visionComponent" is="vision-block-post-footer">
<div class="content centerContentMaxWidth">
<ul class="tags">
<li class="tags-item">Tag:</li>
<li class="tags-item"><a class="tags-itemLink pill" href="https://www.visiontimes.com/tag/canada"><span class="visuallyHidden">Tag:</span> canada</a></li>
<li class="tags-item"><a class="tags-itemLink pill" href="https://www.visiontimes.com/tag/hammer-and-sickle-flag"><span class="visuallyHidden">Tag:</span> Hammer and Sickle Flag</a></li>
<li class="tags-item"><a class="tags-itemLink pill" href="https://www.visiontimes.com/tag/marxist-revolutionaries"><span class="visuallyHidden">Tag:</span> Marxist Revolutionaries</a></li>
<li class="tags-item"><a class="tags-itemLink pill" href="https://www.visiontimes.com/tag/world-2"><span class="visuallyHidden">Tag:</span> world</a></li>
</ul>
</div>
</div>
</footer>
<div id="post-comments">
<div id="remark42" is="vision-block-comment" class="loading">
</div>
</div>
<section>
<div is="vision-grid-news-latest">
<h3>RELATED NEWS</h3>
<div class="news-latest">
<div class="article">
<a href="https://www.visiontimes.com/2022/05/02/mexico-siu-drug-squad-disbanded-corrupted-by-cartels.html"><div class="title">Elite Mexican Anti-Narcotics Squad Disbanded After Being Infiltrated By Drug Cartels</div></a>
<a href="https://www.visiontimes.com/2022/05/02/mexico-siu-drug-squad-disbanded-corrupted-by-cartels.html"><div class="img"><div class="visionComponent visionComponent--sizeTiny  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/05/Obrador-DEA-Trained-SIU-Disbanded-After-Bought-by-Mexican-Drug-Cartels--768x539.jpg" srcset="
                                                                        https://img.visiontimes.com/2022/05/Obrador-DEA-Trained-SIU-Disbanded-After-Bought-by-Mexican-Drug-Cartels--485x360.jpg 375w" data-sizes="auto" alt="Mexico&#039;s SIU was disbanded after being corrupted from within by drug cartels.">
</figure>
</div>
</div>
</div></a>
</div>
<div class="article">
<a href="https://www.visiontimes.com/2022/05/02/ottawa-police-service-mayor-blasted-by-experts-for-treatment-of-rolling-thunder-protesters.html"><div class="title">Ottawa Police Service, Mayor Blasted by Experts for Treatment of Rolling Thunder Protesters</div></a>
<a href="https://www.visiontimes.com/2022/05/02/ottawa-police-service-mayor-blasted-by-experts-for-treatment-of-rolling-thunder-protesters.html"><div class="img"><div class="visionComponent visionComponent--sizeTiny  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/05/GettyImages-1240349594-768x512.jpg" srcset="
                                                                        https://img.visiontimes.com/2022/05/GettyImages-1240349594-485x360.jpg 375w" data-sizes="auto" alt="Rolling-Thunder-Justice-Centre-for-Constitutional-Freedoms-Ottawa-Getty-Images-1240349594">
</figure>
</div>
</div>
</div></a>
</div>
<div class="article">
<a href="https://www.visiontimes.com/2022/05/02/india-seizes-726-million-from-chinese-mobile-maker-xiaomi-for-violation-of-foreign-exchange-laws.html"><div class="title">India Seizes $726 Million From Chinese Mobile Maker Xiaomi for Violation of Foreign Exchange Laws</div></a>
<a href="https://www.visiontimes.com/2022/05/02/india-seizes-726-million-from-chinese-mobile-maker-xiaomi-for-violation-of-foreign-exchange-laws.html"><div class="img"><div class="visionComponent visionComponent--sizeTiny  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/05/Xiaomi-India-GettyImages-1163006258-768x512.jpg" srcset="
                                                                        https://img.visiontimes.com/2022/05/Xiaomi-India-GettyImages-1163006258-485x360.jpg 375w" data-sizes="auto" alt="">
</figure>
</div>
</div>
</div></a>
</div>
<div class="article">
<a href="https://www.visiontimes.com/2022/05/02/ap-ukraine-propaganda-sbu-arresting-online-dissenters-gunpoint.html"><div class="title">AP Airs Segment Glorifying Ukraine Intelligence Arresting Online Dissenters at Gunpoint</div></a>
<a href="https://www.visiontimes.com/2022/05/02/ap-ukraine-propaganda-sbu-arresting-online-dissenters-gunpoint.html"><div class="img"><div class="visionComponent visionComponent--sizeTiny  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/05/Associated-Press-AP-Propaganda-With-SBU-Intelligence-Agents-Arrest-Online-Dissenters-at-Gunpoint-768x512.jpg" srcset="
                                                                        https://img.visiontimes.com/2022/05/Associated-Press-AP-Propaganda-With-SBU-Intelligence-Agents-Arrest-Online-Dissenters-at-Gunpoint-485x360.jpg 375w" data-sizes="auto" alt="AP is normalizing the importation of the CCP&#039;s methodology as it glorified Ukraine&#039;s SBU arresting online dissenters at gunpoint.">
</figure>
</div>
</div>
</div></a>
</div>
</div>
</div>
</section>
</div>
<div class="col-right">
<div is="vision-list-top-stories">
<div class="sidebar-header">
<h3>TOP STORIES</h3>
<div class="article" id="444890">
<a href="https://www.visiontimes.com/2022/04/22/russia-largest-chemical-plant-burns-potential-sabotage.html"><div class="title">Fires Hit Russian Research Center, Country&#8217;s Largest Chemical Plant on the Same Day</div></a>
<a href="https://www.visiontimes.com/2022/04/22/russia-largest-chemical-plant-burns-potential-sabotage.html"><div class="img"><div class="visionComponent visionComponent--sizeTiny  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/04/Dimitrievsky-Chemical-Plant-Fire-Tver-Aerospace-Defense-Force-Fire-Potential-Sabotage-768x576.jpg" srcset="
                                                                        https://img.visiontimes.com/2022/04/Dimitrievsky-Chemical-Plant-Fire-Tver-Aerospace-Defense-Force-Fire-Potential-Sabotage-485x360.jpg 375w" data-sizes="auto" alt="Russia&#039;s largest chemical plant, Dimitrievsky Chemical Plant, burned the same day a missile production Aerospace Defense Force site in Tver burned.">
</figure>
</div>
</div>
</div></a>
</div>
<div class="article" id="444963">
<a href="https://www.visiontimes.com/2022/04/24/explainer-alberta-and-ontario-digital-id.html"><div class="title">Understanding Alberta and Ontario Digital ID Systems</div></a>
<a href="https://www.visiontimes.com/2022/04/24/explainer-alberta-and-ontario-digital-id.html"><div class="img"><div class="visionComponent visionComponent--sizeTiny  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/04/Ontario-Digital-ID-Alberta-Digital-ID-MyAlberta-and-Social-Credit-768x512.jpg" srcset="
                                                                        https://img.visiontimes.com/2022/04/Ontario-Digital-ID-Alberta-Digital-ID-MyAlberta-and-Social-Credit-485x360.jpg 375w" data-sizes="auto" alt="An explainer on Ontario Digital ID and Alberta Digital ID">
</figure>
</div>
</div>
</div></a>
</div>
<div class="article" id="445025">
<a href="https://www.visiontimes.com/2022/04/26/palm-oil-olein-export-ban-indonesia.html"><div class="title">Indonesia, the Top Producer of the World&#8217;s Most-used Vegetable Oil, Set to Ban Exports</div></a>
<a href="https://www.visiontimes.com/2022/04/26/palm-oil-olein-export-ban-indonesia.html"><div class="img"><div class="visionComponent visionComponent--sizeTiny  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/04/Indonesia-Worlds-Top-Producer-Worlds-Most-Used-Vegetable-Oil-Palm-Oil-Export-Ban-768x512.jpg" srcset="
                                                                        https://img.visiontimes.com/2022/04/Indonesia-Worlds-Top-Producer-Worlds-Most-Used-Vegetable-Oil-Palm-Oil-Export-Ban-485x360.jpg 375w" data-sizes="auto" alt="Indonesia is about to ban the world&#039;s most used vegetable oil, palm oil, from being exported amid a collapsing world food supply chain.">
</figure>
</div>
</div>
</div></a>
</div>
<div class="article" id="444907">
<a href="https://www.visiontimes.com/2022/04/22/canadian-military-azov-battalion-ukraine.html"><div class="title">Canadian Military Officials Tried to Hide Association With Ukraine&#8217;s Azov Battalion: Israeli Historian</div></a>
<a href="https://www.visiontimes.com/2022/04/22/canadian-military-azov-battalion-ukraine.html"><div class="img"><div class="visionComponent visionComponent--sizeTiny  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/04/GettyImages-464132408-768x514.jpg" srcset="
                                                                        https://img.visiontimes.com/2022/04/GettyImages-464132408-485x360.jpg 375w" data-sizes="auto" alt="Neo-Nazis-from-Ukraine-trained-by-Canada-Azov-Battalion-Centuria-Getty-Images-464132408">
</figure>
</div>
</div>
</div></a>
</div>
<div class="article" id="444762">
<a href="https://www.visiontimes.com/2022/04/20/russia-izyum-ukrainian-donbass-offensive.html"><div class="title">Russia&#8217;s March Through Izyum Could Determine Fate of Ukrainian Eastern Front</div></a>
<a href="https://www.visiontimes.com/2022/04/20/russia-izyum-ukrainian-donbass-offensive.html"><div class="img"><div class="visionComponent visionComponent--sizeTiny  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/04/T-80-izyum-drivers-view-russian-army-April-2022-768x446.jpg" srcset="
                                                                        https://img.visiontimes.com/2022/04/T-80-izyum-drivers-view-russian-army-April-2022-485x360.jpg 375w" data-sizes="auto" alt="T-80-izyum-drivers-view-russian-army-April-2022">
</figure>
</div>
</div>
</div></a>
</div>
</div>
</div>
<div is="vision-list-most-read">
<div class="sidebar-header" load_max="30" load_more="10">
<h3>MOST POPULAR</h3>
<div class="article" id="444837">
<a href="https://www.visiontimes.com/2022/04/21/fires-destroy-food-processing-centers.html"><div class="title">A String of Fires Destroys Food Processing Facilities Across America</div></a>
<a href="https://www.visiontimes.com/2022/04/21/fires-destroy-food-processing-centers.html"><div class="img"><div class="visionComponent visionComponent--sizeTiny  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/04/US-Food-Processing-Plant-Fires-and-Accidents-768x530.jpg" srcset="
                                                                        https://img.visiontimes.com/2022/04/US-Food-Processing-Plant-Fires-and-Accidents-485x360.jpg 375w" data-sizes="auto" alt="A string of fires have destroyed US food processing facilities in a string of isolated incidents.">
</figure>
</div>
</div>
</div></a>
</div>
<div class="article" id="444572">
<a href="https://www.visiontimes.com/2022/04/16/us-rail-carriers-cut-fertilizer-shipments-union-wars.html"><div class="title">US Rail Carriers Are Cutting Fertilizer, Grain, Coal Shipments</div></a>
<a href="https://www.visiontimes.com/2022/04/16/us-rail-carriers-cut-fertilizer-shipments-union-wars.html"><div class="img"><div class="visionComponent visionComponent--sizeTiny  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/04/US-Rail-Carriers-Cutting-Fertilizer-Grain-Coal-Shipments-CF-Industries-Union-Pacific-BSNF-Union-Wars-768x512.jpg" srcset="
                                                                        https://img.visiontimes.com/2022/04/US-Rail-Carriers-Cutting-Fertilizer-Grain-Coal-Shipments-CF-Industries-Union-Pacific-BSNF-Union-Wars-485x360.jpg 375w" data-sizes="auto" alt="American rail carriers are cutting critical fertilizer, grain, and coal shipments as they struggle with staffing and logistics problems amid union wars.">
</figure>
</div>
</div>
</div></a>
</div>
<div class="article" id="444311">
<a href="https://www.visiontimes.com/2022/04/12/ny-mayor-eric-adams-under-pressure-to-rehire-hundreds-of-unvaccinated-city-workers.html"><div class="title">NY Mayor Eric Adams Under Pressure to Rehire Hundreds of Unvaccinated City Workers</div></a>
<a href="https://www.visiontimes.com/2022/04/12/ny-mayor-eric-adams-under-pressure-to-rehire-hundreds-of-unvaccinated-city-workers.html"><div class="img"><div class="visionComponent visionComponent--sizeTiny  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/04/GettyImages-1389946822-768x512.jpg" srcset="
                                                                        https://img.visiontimes.com/2022/04/GettyImages-1389946822-485x360.jpg 375w" data-sizes="auto" alt="Eric-Adams-New-York-Vaccine-Mandate-Unfair-Mandate-practices-Getty-Images-1389946822">
</figure>
</div>
</div>
</div></a>
</div>
<div class="article" id="444890">
<a href="https://www.visiontimes.com/2022/04/22/russia-largest-chemical-plant-burns-potential-sabotage.html"><div class="title">Fires Hit Russian Research Center, Country&#8217;s Largest Chemical Plant on the Same Day</div></a>
<a href="https://www.visiontimes.com/2022/04/22/russia-largest-chemical-plant-burns-potential-sabotage.html"><div class="img"><div class="visionComponent visionComponent--sizeTiny  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/04/Dimitrievsky-Chemical-Plant-Fire-Tver-Aerospace-Defense-Force-Fire-Potential-Sabotage-768x576.jpg" srcset="
                                                                        https://img.visiontimes.com/2022/04/Dimitrievsky-Chemical-Plant-Fire-Tver-Aerospace-Defense-Force-Fire-Potential-Sabotage-485x360.jpg 375w" data-sizes="auto" alt="Russia&#039;s largest chemical plant, Dimitrievsky Chemical Plant, burned the same day a missile production Aerospace Defense Force site in Tver burned.">
</figure>
</div>
</div>
</div></a>
</div>
<div class="article" id="444257">
<a href="https://www.visiontimes.com/2022/04/11/significance-of-easter.html"><div class="title">The Significance of Easter: An Enduring Hope for Humanity</div></a>
<a href="https://www.visiontimes.com/2022/04/11/significance-of-easter.html"><div class="img"><div class="visionComponent visionComponent--sizeTiny  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/04/Rafael_-_ressureicaocristo01-768x936.jpg" srcset="
                                                                        https://img.visiontimes.com/2022/04/Rafael_-_ressureicaocristo01-485x360.jpg 375w" data-sizes="auto" alt="significance-of-Easter-Wikimedia-commons">
</figure>
</div>
</div>
</div></a>
</div>
<div class="article" id="444690">
<a href="https://www.visiontimes.com/2022/04/19/ge-mosquitoes-to-be-released.html"><div class="title">2.4 Billion GE Mosquitoes to Be Released in US, Despite Uncertainties</div></a>
<a href="https://www.visiontimes.com/2022/04/19/ge-mosquitoes-to-be-released.html"><div class="img"><div class="visionComponent visionComponent--sizeTiny  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/04/GettyImages-509399272-768x502.jpg" srcset="
                                                                        https://img.visiontimes.com/2022/04/GettyImages-509399272-485x360.jpg 375w" data-sizes="auto" alt="">
</figure>
</div>
</div>
</div></a>
</div>
</div>
<div class="load-more">
<div class="loading load-more-loading"></div>
<a href="https://www.visiontimes.com/wp-admin/admin-ajax.php" id="load-more-button" load-most-popular>
<button>
<div class="load-more-text">LOAD MORE</div>
</button>
</a>
</div>
</div>
</div>
</section>
</div>
</main>
<footer class="mainFooter">
<div class="visionComponent themeLight" is="vision-navigation-footer">
<div class="container centerMaxWidthContainer">
<ul class="footer-nav">
<li>
<div class="heading">EDITIONS</div>
<ul class="items">
<li class="menu-item">
<a class="menu-link" href="https://www.secretchina.com/">Chinese</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://es.visiontimes.com/">Spanish</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.fr/">French</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.it/">Italian</a>
 </li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimesjp.com/">Japanese</a>
</li>
</ul>
</li>
<li>
<div class="heading">COMPANY</div>
<ul class="items">
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/about-us">About</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/contact-us">Contact</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/advertise">Advertise</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/submissions">Submissions</a>
</li>
</ul>
</li>
<li>
<div class="heading">INFO</div>
<ul class="items">
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/privacy">Privacy Policy</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/policies">Terms of Service</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/copyright-policy-and-infringement-notification">Copyright Policy and Infringement Notification</a>
</li>
</ul>
</li>
<li>
<div class="heading">POPULAR CATEGORY</div>
<ul class="items">
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/c/us">US</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/c/china">China</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/c/world">World</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/c/politics">Politics</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/c/human-rights">Human Rights</a>
</li>
</ul>
</li>
</ul>
<div class="footer-nav footer-nav-2">
<li>
<div class="heading">About Us</div>
<div class="items txt">Vision Times tells the world everything about China in today's context. We keep a close eye on China because of its influence now and the lessons we can learn from its ancient past to better our lives today.</div>
</li>
<li>
<div class="heading">Follow Us</div>
<ul class="items icons">
<li><a href="https://www.facebook.com/VisionTimesOfficial" target="_blank" rel="nofollow" title="Facebook"> <i class="fab fa-facebook-f"></i></a></li>
<li><a href="https://twitter.com/times_vision" target="_blank" rel="nofollow" title="Twitter"><i class="fab fa-twitter"></i></a></li>
<li><a href="https://www.youtube.com/c/VisionTimesNews" target="_blank" rel="nofollow" title="Youtube"><i class="fab fa-youtube"></i></a></li>
<li><a href="https://t.me/visiontimes" target="_blank" rel="nofollow" title="Telegram"><i class="fab fa-telegram"></i></a></li>
<li><a href="https://safechat.com/channel/2788089756776450736" target="_blank" rel="nofollow" title="SafeChat"><i class="fab fa-safechat"></i></a></li>
</ul>
</li>
</div>
</div>
</div>
</footer>
</div>
<div class="wpFooter">

<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-W8PQVQT"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<div is="vision-block-cookie-notice" class="visionComponent boxShadow layoutFloating themeReset" role="dialog">
<div class="container centerMaxWidthContainer">
<div class="content">
<p class="header">This website uses cookies</p>
<p>We inform you that this site uses own, technical and third parties cookies to make sure our web page is user-friendly and to guarantee a high functionality of the webpage. By continuing to browse this website, you declare to accept the use of cookies.</p>
</div>
<button type="button" class="button button--small" aria-label="Close" data-close>Ok</button>
</div>
</div>

<script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">//<![CDATA[
	var dataLayer_content = {"pageTitle":"Communist Flags Fly at Montreal ‘Workers Day’ Protest, US Flag Burned, Windows Smashed, Buildings Graffitied - Vision Times","pagePostType":"post","pagePostType2":"single-post","pageCategory":["world","canada","news"],"pageAttributes":["canada","hammer-and-sickle-flag","marxist-revolutionaries","world-2"],"pagePostAuthorID":490,"pagePostAuthor":"Neil Campbell"};
	dataLayer.push( dataLayer_content );//]]>
</script>
<script data-cfasync="false">//<![CDATA[
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.'+'js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-W8PQVQT');//]]>
</script>


</div>
<script async type="text/javascript" src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script async type="text/javascript" src="https://intothebid.com/wrapper/vt/prebid.vt_en.js"></script>
<script async type="text/javascript" src="https://intothebid.com/wrapper/vt/hp_vt_en.js"></script>
<script async type="text/javascript" src="https://intothebid.com/wrapper/vt/hb_vt_en.js"></script>
<script defer src="https://www.visiontimes.com/wp-content/cache/autoptimize/js/autoptimize_4047f336b74449ca9dc0e483fda1b291.js"></script></body>
</html>

