<!DOCTYPE html>
<html class="html post-template-default single single-post postid-449554 single-format-standard" lang="en-US" ontouchmove>
<head>
<meta charset="utf-8">
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta name="viewport" content="width=device-width, initial-scale=1">
<meta name="facebook-domain-verification" content="sk3rnqnkzv6l3wofm6ex6k4t60vodw" />
<link rel="alternate" type="application/rss+xml" title="Vision Times Feed" href="https://www.visiontimes.com/feed">
<link rel="preconnect" href="https://intothebid.com/">
<link rel="preconnect" href="https://securepubads.g.doubleclick.net/">

<script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">
	var gtm4wp_datalayer_name = "dataLayer";
	var dataLayer = dataLayer || [];
</script>


<link media="all" href="https://www.visiontimes.com/wp-content/cache/autoptimize/css/autoptimize_30504b26d1b6338c10f62a416f1796e1.css" rel="stylesheet" /><title>Xiong Yan Endorsed to Represent New York’s 10th Congressional District by Key Member of Brooklyn Democrats - Vision Times</title>
<meta name="description" content="On August 4, at the Marine Park Golf Course in Brooklyn, the Democratic Party of Brooklyn held a nomination meeting for Brooklyn High Court judges. Among the" />
<meta name="robots" content="follow, index, max-snippet:-1, max-video-preview:-1, max-image-preview:large" />
<link rel="canonical" href="https://www.visiontimes.com/2022/08/10/xiong-yan-endorsed-to-represent-new-yorks-10th-congressional-district-by-key-member-of-the-brooklyn-democratic-party.html" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Xiong Yan Endorsed to Represent New York’s 10th Congressional District by Key Member of Brooklyn Democrats - Vision Times" />
<meta property="og:description" content="On August 4, at the Marine Park Golf Course in Brooklyn, the Democratic Party of Brooklyn held a nomination meeting for Brooklyn High Court judges. Among the" />
<meta property="og:url" content="https://www.visiontimes.com/2022/08/10/xiong-yan-endorsed-to-represent-new-yorks-10th-congressional-district-by-key-member-of-the-brooklyn-democratic-party.html" />
<meta property="og:site_name" content="Vision Times" />
<meta property="article:tag" content="59th Assembly District" />
<meta property="article:tag" content="Brooklyn" />
<meta property="article:tag" content="Erik Frankel" />
<meta property="article:tag" content="Frank Seddio" />
<meta property="article:tag" content="Marine Park Golf Course" />
<meta property="article:tag" content="Queens" />
<meta property="article:tag" content="Xiong Yan" />
<meta property="article:section" content="New York" />
<meta property="og:updated_time" content="2022-08-10T18:17:13-04:00" />
<meta property="og:image" content="https://img.visiontimes.com/2022/08/signal-2022-08-09-234211.jpeg" />
<meta property="og:image:secure_url" content="https://img.visiontimes.com/2022/08/signal-2022-08-09-234211.jpeg" />
<meta property="og:image:width" content="1600" />
<meta property="og:image:height" content="1200" />
<meta property="og:image:alt" content="Xiong-Yan-10th-congressional-district-candidate-and-Frank-Seddio" />
<meta property="og:image:type" content="image/jpeg" />
<meta property="article:published_time" content="2022-08-10T18:09:37-04:00" />
<meta property="article:modified_time" content="2022-08-10T18:17:13-04:00" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:title" content="Xiong Yan Endorsed to Represent New York’s 10th Congressional District by Key Member of Brooklyn Democrats - Vision Times" />
<meta name="twitter:description" content="On August 4, at the Marine Park Golf Course in Brooklyn, the Democratic Party of Brooklyn held a nomination meeting for Brooklyn High Court judges. Among the" />
<meta name="twitter:image" content="https://img.visiontimes.com/2022/08/signal-2022-08-09-234211.jpeg" />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="Todd Crawford" />
<meta name="twitter:label2" content="Time to read" />
<meta name="twitter:data2" content="3 minutes" />
<script type="application/ld+json" class="rank-math-schema">{"@context":"https://schema.org","@graph":[{"@type":["NGO","Organization"],"@id":"https://www.visiontimes.com/#organization","name":"Vision Times","url":"https://www.visiontimes.com"},{"@type":"WebSite","@id":"https://www.visiontimes.com/#website","url":"https://www.visiontimes.com","name":"Vision Times","publisher":{"@id":"https://www.visiontimes.com/#organization"},"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://img.visiontimes.com/2022/08/signal-2022-08-09-234211.jpeg","url":"https://img.visiontimes.com/2022/08/signal-2022-08-09-234211.jpeg","width":"1600","height":"1200","caption":"Xiong-Yan-10th-congressional-district-candidate-and-Frank-Seddio","inLanguage":"en-US"},{"@type":"BreadcrumbList","@id":"https://www.visiontimes.com/2022/08/10/xiong-yan-endorsed-to-represent-new-yorks-10th-congressional-district-by-key-member-of-the-brooklyn-democratic-party.html#breadcrumb","itemListElement":[{"@type":"ListItem","position":"1","item":{"@id":"https://www.visiontimes.com","name":"Home"}},{"@type":"ListItem","position":"2","item":{"@id":"https://www.visiontimes.com/c/us","name":"US"}},{"@type":"ListItem","position":"3","item":{"@id":"https://www.visiontimes.com/c/us/new-york","name":"New York"}},{"@type":"ListItem","position":"4","item":{"@id":"https://www.visiontimes.com/2022/08/10/xiong-yan-endorsed-to-represent-new-yorks-10th-congressional-district-by-key-member-of-the-brooklyn-democratic-party.html","name":"Xiong Yan Endorsed to Represent New York\u2019s 10th Congressional District by Key Member of Brooklyn Democrats"}}]},{"@type":"Person","@id":"https://www.visiontimes.com/author/todd-crawford","name":"Todd Crawford","url":"https://www.visiontimes.com/author/todd-crawford","image":{"@type":"ImageObject","@id":"https://secure.gravatar.com/avatar/182dd511dd531fcb21ce7dfb5eb6d732?s=96&amp;r=g","url":"https://secure.gravatar.com/avatar/182dd511dd531fcb21ce7dfb5eb6d732?s=96&amp;r=g","caption":"Todd Crawford","inLanguage":"en-US"},"worksFor":{"@id":"https://www.visiontimes.com/#organization"}},{"@type":"WebPage","@id":"https://www.visiontimes.com/2022/08/10/xiong-yan-endorsed-to-represent-new-yorks-10th-congressional-district-by-key-member-of-the-brooklyn-democratic-party.html#webpage","url":"https://www.visiontimes.com/2022/08/10/xiong-yan-endorsed-to-represent-new-yorks-10th-congressional-district-by-key-member-of-the-brooklyn-democratic-party.html","name":"Xiong Yan Endorsed to Represent New York\u2019s 10th Congressional District by Key Member of Brooklyn Democrats - Vision Times","datePublished":"2022-08-10T18:09:37-04:00","dateModified":"2022-08-10T18:17:13-04:00","author":{"@id":"https://www.visiontimes.com/author/todd-crawford"},"isPartOf":{"@id":"https://www.visiontimes.com/#website"},"primaryImageOfPage":{"@id":"https://img.visiontimes.com/2022/08/signal-2022-08-09-234211.jpeg"},"inLanguage":"en-US","breadcrumb":{"@id":"https://www.visiontimes.com/2022/08/10/xiong-yan-endorsed-to-represent-new-yorks-10th-congressional-district-by-key-member-of-the-brooklyn-democratic-party.html#breadcrumb"}},{"@type":"NewsArticle","headline":"Xiong Yan Endorsed to Represent New York\u2019s 10th Congressional District by Key Member of Brooklyn Democrats -","keywords":"Xiong Yan","datePublished":"2022-08-10T18:09:37-04:00","dateModified":"2022-08-10T18:17:13-04:00","author":{"@id":"https://www.visiontimes.com/author/todd-crawford"},"publisher":{"@id":"https://www.visiontimes.com/#organization"},"description":"On August 4, at the Marine Park Golf Course in Brooklyn, the Democratic Party of Brooklyn held a nomination meeting for Brooklyn High Court judges. Among the","name":"Xiong Yan Endorsed to Represent New York\u2019s 10th Congressional District by Key Member of Brooklyn Democrats -","@id":"https://www.visiontimes.com/2022/08/10/xiong-yan-endorsed-to-represent-new-yorks-10th-congressional-district-by-key-member-of-the-brooklyn-democratic-party.html#richSnippet","isPartOf":{"@id":"https://www.visiontimes.com/2022/08/10/xiong-yan-endorsed-to-represent-new-yorks-10th-congressional-district-by-key-member-of-the-brooklyn-democratic-party.html#webpage"},"image":{"@id":"https://img.visiontimes.com/2022/08/signal-2022-08-09-234211.jpeg"},"inLanguage":"en-US","mainEntityOfPage":{"@id":"https://www.visiontimes.com/2022/08/10/xiong-yan-endorsed-to-represent-new-yorks-10th-congressional-district-by-key-member-of-the-brooklyn-democratic-party.html#webpage"}}]}</script>

<script id='Vision/assets-js-extra'>
var VisionData = {"templateDirectoryUri":"https:\/\/www.visiontimes.com\/wp-content\/themes\/vt","locale":"en_US","admin_ajax_url":"https:\/\/www.visiontimes.com\/wp-admin\/admin-ajax.php","post_id":"449554"};
var VisionDataComment = {"comment":"1","site":"https:\/\/www.visiontimes.com","article_link":"https:\/\/www.visiontimes.com\/2022\/08\/10\/xiong-yan-endorsed-to-represent-new-yorks-10th-congressional-district-by-key-member-of-the-brooklyn-democratic-party.html"};
</script>
<script type="application/javascript" src="https://sdki.truepush.com/sdk/v2.0.3/app.js" async></script>
<script>
    var truepush = window.Truepush || [];
        truepush.push( function() {
        truepush.Init({
            id : "620c00246daffbb98a21b770",
fromWordpress : true,
local : false,
wordpresspath : "https://www.visiontimes.com/wp-content/plugins/truepush-free-web-push-notifications/",
        },function(error){
          if(error) console.error(error);
        })
    });
    </script>
<link rel="icon" href="https://img.visiontimes.com/2021/04/cropped-favicon-512x512-1-1-32x32.png" sizes="32x32" />
<link rel="icon" href="https://img.visiontimes.com/2021/04/cropped-favicon-512x512-1-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://img.visiontimes.com/2021/04/cropped-favicon-512x512-1-1-180x180.png" />
<meta name="msapplication-TileImage" content="https://img.visiontimes.com/2021/04/cropped-favicon-512x512-1-1-270x270.png" />
</head>
<body>
<a href="#mainContent" class="skipLink">
Skip to main content
</a>
<div class="pageWrapper">
<header class="mainHeader">
<div is="vision-top-header">
<nav class="visionComponent  navigation-TopBarMenu" aria-label="Main">
<div class="wrap">
<div class="header-menu header-menu-menu">
<ul class="menu">
<li class="menu-item " tabindex="-1">
<a class="menu-link" href="#" tabindex="-1">Editions</a>
<ul class="sub-menus">
<li class="menu-item">
<a class="menu-link" href="https://www.secretchina.com/">Chinese</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://es.visiontimes.com/">Spanish</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.fr/">French</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.it/">Italian</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://visiontimesjp.com/">Japanese</a>
</li>
</ul>
<i class="fas fa-angle-down"></i>
</li>
<li class="menu-item " tabindex="-1">
<a class="menu-link" href="https://visiontimes.us1.list-manage.com/subscribe?u=7e5b1c29f989d8d053d774db4&#038;id=3feabe35e7" tabindex="-1">Newsletter</a>
</li>
<li class="menu-item " tabindex="-1">
<a class="menu-link" href="https://www.visiontimes.com/donations" tabindex="-1">Donate</a>
</li>
<li class="menu-item " tabindex="-1">
<a class="menu-link" href="https://www.visiontimes.com/about-us" tabindex="-1">About US</a>
</li>
</ul>
</div>
<div class="header-menu header-menu-user">
<nav is="vision-user-side-bar" class="visionComponent vision-user-side-bar">
<div class="overlay"></div>
<div class="section-button">
<div class="large-section-button">
<a href="https://myaccount.visiontimes.com/subscribe/print.php" target="_blank">
<div class="text">Subscribe</div>
</a>
</div>
<div class="large-section-button user-login login-btn">
<div class="text">Sign in</div>
<i class="fas fa-user"></i>
</div>
</div>
<div class="user-side">
<div class="user-menu ">
<div class="user-menu-button"></div>
<div class="user-block">
<div class="user-name"></div>
<a href="https://myaccount.visiontimes.com/subscribe/print.php" target="_blank">
<div class="e-button">
<span class="text">Subscribe</span>
</div>
</a>
<div class="user-sign-out logout-btn">Sign out</div>
</div>
<ul class="user-menu-items">
<li class="user-menu-item  menu-item menu-item-type-custom menu-item-object-custom menu-item-446748  user-menu-first  level-1">
<a class="user-menu-link" href="https://myaccount.visiontimes.com/accountprofile.php">Account Settings</a>
</li>
<li class="user-menu-item  menu-item menu-item-type-custom menu-item-object-custom menu-item-446749  level-1">
<a class="user-menu-link" href="https://myaccount.visiontimes.com/newsletter.php?code=en">Newsletters</a>
</li>
<li class="user-menu-item  menu-item menu-item-type-custom menu-item-object-custom menu-item-446750  level-1">
<a class="user-menu-link" href="https://myaccount.visiontimes.com/subscribe.php?code=en">Subscriptions</a>
</li>
</ul>
</div>
</div>
</nav>
</div>
</div>
</nav>
<div class="header-top-middle">
<div class="vision-weather-widget" is="vision-weather-widget">
<div class="top-left-wrap">
<nav is="vision-navigation-side" class="visionComponent">
<div class="overlay"></div>
<div class="section-button">
<div class="large-section-button">
<div class="text">SECTIONS</div>
<i class="fas fa-bars"></i>
</div>
<div class="sm-section-button">
<img src="https://www.visiontimes.com/wp-content/themes/vt/dist/assets/images/menu-mobile-926eb40a4c.svg">
</div>
</div>
<div class="nav-side">
<div class="menu ">
<div class="e-button">
<a href="https://visiontimes.us1.list-manage.com/subscribe?u=7e5b1c29f989d8d053d774db4&#038;id=3feabe35e7">
<span class="text">Newsletter</span>
</a>
</div>
<div class="menu-button"></div>
<ul class="menu-items">
<li class="menu-item  menu-item menu-item-type-custom menu-item-object-custom menu-item-428032  menu-first  level-1">
<a class="menu-link" href="/">Home</a>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-423521 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/news">News</a>
<i class="fas fa-angle-right"></i>
<div class="sub-menu-wrap">
<ul class="sub-menus">
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-423525 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/politics">Politics</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423526 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/society">Society</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33185 menu-item-has-children level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/tech">Tech</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423523 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/health">Health</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423524 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/human-rights">Human Rights</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423522 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/analysis">Analysis</a>
</li>
</ul>
<i class="fas fa-caret-left"></i>
</div>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category menu-item-444027  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/opinions">Viewpoints</a>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-357119 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/us">US</a>
<i class="fas fa-angle-right"></i>
<div class="sub-menu-wrap">
<ul class="sub-menus">
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-423514 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/us/us-politics">Politics</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423520 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/us/us-foreign-policy">Foreign Policy</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-423515 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/us/new-york">New York</a>
</li>
</ul>
<i class="fas fa-caret-left"></i>
</div>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category menu-item-220229 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/china">China</a>
<i class="fas fa-angle-right"></i>
<div class="sub-menu-wrap">
<ul class="sub-menus">
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-437130 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/china/china-politics">Politics</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-437131 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/china/china-economy">Economy</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-437133 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/china/china-foreign-relations">International Relations</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-437129 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/china/china-society">Society</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-413925 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/china/china-culture">Chinese Culture</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-448624 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/china/china-insights">China Insights</a>
</li>
</ul>
<i class="fas fa-caret-left"></i>
</div>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category menu-item-447634  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/world/americas/canada">Canada</a>
</li>
<li class="menu-item  world menu-item menu-item-type-taxonomy menu-item-object-category menu-item-989 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/world">World</a>
<i class="fas fa-angle-right"></i>
<div class="sub-menu-wrap">
<ul class="sub-menus">
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-414013 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/world/americas">Americas</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-414014 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/world/asia-pacific">Asia-Pacific</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-414015 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/world/europe">Europe</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-447637 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/world/europe/uk">UK</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-414016 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/world/south-asia">South Asia</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-414012 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/world/africa">Africa</a>
</li>
</ul>
<i class="fas fa-caret-left"></i>
</div>
</li>
<li class="menu-item  life menu-item menu-item-type-taxonomy menu-item-object-category menu-item-985 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/life">Life</a>
<i class="fas fa-angle-right"></i>
<div class="sub-menu-wrap">
 <ul class="sub-menus">
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-447636 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/culture">Culture</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423493 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/life/wellness">Wellness</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423518 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/life/mind-spirit">Mind &amp; Spirit</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423517 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/life/gardening">Gardening</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423516 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/life/entertainment">Entertainment</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-447635 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/china/china-culture">Chinese Culture</a>
</li>
</ul>
<i class="fas fa-caret-left"></i>
</div>
</li>
<li class="menu-item  science menu-item menu-item-type-taxonomy menu-item-object-category menu-item-997 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/nature">Nature</a>
<i class="fas fa-angle-right"></i>
<div class="sub-menu-wrap">
<ul class="sub-menus">
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33187 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/nature/environment">Environment</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-425150 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/nature/disasters">Disasters</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33191 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/nature/mysteries">Mysteries</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33183 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/space">Space</a>
</li>
</ul>
<i class="fas fa-caret-left"></i>
</div>
</li>
</ul>
</div>
</div>
</nav>
<div class="search">
<form is="vision-search-form-expandable" id="searchform" name="searchform" class="search-form" method="post" action="https://www.visiontimes.com">
<input type="text" class="search-field" name="s" placeholder="Search" value="">
<button class="btn search-button"><i class="fas fa-search"></i></button>
</form>
</div>
</div>
<div class="vision-current-date-widget" is="vision-current-date-widget"></div>
</div>
<div class="vision-top-banner">
<ul class="menu">
<li class="menu-item ">
<a class="menu-link" href="/">
HOME
 </a>
</li>
<li class="menu-item ">
<a class="menu-link" href="https://www.visiontimes.com/c/news">
NEWS
</a>
</li>
<li class="menu-item ">
<a class="menu-link" href="https://www.visiontimes.com/c/opinions">
VIEWPOINTS
</a>
</li>
<li class="menu-item ">
<a class="menu-link" href="https://www.visiontimes.com/c/us">
US
</a>
</li>
<li class="menu-item ">
<a class="menu-link" href="https://www.visiontimes.com/c/china">
CHINA
</a>
</li>
<li class="menu-item ">
<a class="menu-link" href="https://www.visiontimes.com/c/world/americas/canada">
CANADA
</a>
</li>
<li class="menu-item ">
<a class="menu-link" href="https://www.visiontimes.com/c/world">
WORLD
</a>
</li>
<li class="menu-item ">
<a class="menu-link" href="https://www.visiontimes.com/c/life">
LIFE
</a>
</li>
<li class="menu-item ">
<a class="menu-link" href="https://www.visiontimes.com/c/nature">
NATURE
</a>
</li>
</ul>
<div>
<a href="https://www.visiontimes.com" title="Home"><img src="https://www.visiontimes.com/wp-content/themes/vt/dist/assets/images/vision-times-logo-fc9b3d60e2.svg" alt="Vision Times"></a>
</div>
</div>
<div class="vision-e-paper">
<a href="https://visiontimes.us1.list-manage.com/subscribe?u=7e5b1c29f989d8d053d774db4&#038;id=3feabe35e7" rel="noreferrer noopener">
<div class="e-button">
<span class="text">Newsletter</span>
</div>
</a>
<a href="https://e-paper.visiontimes.com/" target="_blank">
<div class="e-button prime-white">
<span class="text">e-Paper</span>
</div>
</a>
</div>
</div>
<div class="top-border">Truth, Inspiration, Hope.</div>
</div>
<nav class="visionComponent vision-sticky-bar " is="vision-top-bar-sticky" aria-label="Main">
<div class="wrap">
<nav is="vision-navigation-side" class="visionComponent">
<div class="overlay"></div>
<div class="section-button">
<div class="large-section-button">
<div class="text">SECTIONS</div>
<i class="fas fa-bars"></i>
</div>
<div class="sm-section-button">
<img src="https://www.visiontimes.com/wp-content/themes/vt/dist/assets/images/menu-mobile-926eb40a4c.svg">
</div>
</div>
<div class="nav-side">
<div class="menu ">
<div class="e-button">
<a href="https://visiontimes.us1.list-manage.com/subscribe?u=7e5b1c29f989d8d053d774db4&#038;id=3feabe35e7">
<span class="text">Newsletter</span>
</a>
</div>
<div class="menu-button"></div>
<ul class="menu-items">
<li class="menu-item  menu-item menu-item-type-custom menu-item-object-custom menu-item-428032  menu-first  level-1">
<a class="menu-link" href="/">Home</a>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-423521 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/news">News</a>
<i class="fas fa-angle-right"></i>
<div class="sub-menu-wrap">
<ul class="sub-menus">
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-423525 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/politics">Politics</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423526 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/society">Society</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33185 menu-item-has-children level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/tech">Tech</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423523 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/health">Health</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423524 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/human-rights">Human Rights</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423522 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/analysis">Analysis</a>
</li>
</ul>
<i class="fas fa-caret-left"></i>
</div>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category menu-item-444027  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/opinions">Viewpoints</a>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-357119 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/us">US</a>
<i class="fas fa-angle-right"></i>
<div class="sub-menu-wrap">
<ul class="sub-menus">
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-423514 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/us/us-politics">Politics</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423520 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/us/us-foreign-policy">Foreign Policy</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-423515 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/us/new-york">New York</a>
</li>
</ul>
<i class="fas fa-caret-left"></i>
</div>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category menu-item-220229 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/china">China</a>
<i class="fas fa-angle-right"></i>
<div class="sub-menu-wrap">
<ul class="sub-menus">
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-437130 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/china/china-politics">Politics</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-437131 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/china/china-economy">Economy</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-437133 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/china/china-foreign-relations">International Relations</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-437129 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/china/china-society">Society</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-413925 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/china/china-culture">Chinese Culture</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-448624 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/china/china-insights">China Insights</a>
</li>
</ul>
<i class="fas fa-caret-left"></i>
</div>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category menu-item-447634  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/world/americas/canada">Canada</a>
</li>
<li class="menu-item  world menu-item menu-item-type-taxonomy menu-item-object-category menu-item-989 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/world">World</a>
<i class="fas fa-angle-right"></i>
<div class="sub-menu-wrap">
<ul class="sub-menus">
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-414013 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/world/americas">Americas</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-414014 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/world/asia-pacific">Asia-Pacific</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-414015 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/world/europe">Europe</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-447637 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/world/europe/uk">UK</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-414016 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/world/south-asia">South Asia</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-414012 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/world/africa">Africa</a>
</li>
</ul>
<i class="fas fa-caret-left"></i>
</div>
</li>
<li class="menu-item  life menu-item menu-item-type-taxonomy menu-item-object-category menu-item-985 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/life">Life</a>
<i class="fas fa-angle-right"></i>
<div class="sub-menu-wrap">
<ul class="sub-menus">
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-447636 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/culture">Culture</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423493 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/life/wellness">Wellness</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423518 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/life/mind-spirit">Mind &amp; Spirit</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423517 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/life/gardening">Gardening</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423516 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/life/entertainment">Entertainment</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-447635 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/china/china-culture">Chinese Culture</a>
</li>
</ul>
<i class="fas fa-caret-left"></i>
</div>
</li>
<li class="menu-item  science menu-item menu-item-type-taxonomy menu-item-object-category menu-item-997 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/nature">Nature</a>
<i class="fas fa-angle-right"></i>
<div class="sub-menu-wrap">
<ul class="sub-menus">
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33187 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/nature/environment">Environment</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-425150 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/nature/disasters">Disasters</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33191 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/nature/mysteries">Mysteries</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33183 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/space">Space</a>
</li>
</ul>
<i class="fas fa-caret-left"></i>
</div>
</li>
</ul>
</div>
</div>
</nav>
<div class="search">
<form is="vision-search-form-expandable" id="searchform" name="searchform" class="search-form" method="post" action="https://www.visiontimes.com">
<input type="text" class="search-field" name="s" placeholder="Search" value="">
<button class="btn search-button"><i class="fas fa-search"></i></button>
</form>
</div>
</div>
<ul class="menu">
<li class="menu-item">
<a class="menu-link" href="/">
HOME
</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/c/news">
NEWS
</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/c/opinions">
VIEWPOINTS
</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/c/us">
US
</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/c/china">
CHINA
</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/c/world/americas/canada">
CANADA
</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/c/world">
WORLD
</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/c/life">
LIFE
</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/c/nature">
NATURE
</a>
</li>
</ul>
<div class="header-menu-social">
<ul>
<li><a href="" target="_blank" rel="nofollow" title="Telegram"><i class="fab fa-telegram-plane"></i></a></li>
<li><a href="" target="_blank" rel="nofollow" title="Twitter"><i class="fab fa-twitter"></i></a></li>
<li><a href="" target="_blank" rel="nofollow" title="Youtube"><i class="fab fa-youtube"></i></a></li>
<li><a href="" target="_blank" rel="nofollow" title="Facebook"> <i class="fab fa-facebook-f"></i></a></li>
</ul>
</div>
</nav>
<nav is="vision-navigation-burger" class="visionComponent" aria-label="Main">
<nav class="navigation-TopBarMenu-mobile" aria-label="Main">
<div class="wrap">
<div class="header-menu header-menu-menu">
<ul class="menu">
<li class="menu-item menu-item-1 " tabindex="-1">
<a class="menu-link" href="#">Editions</a>
<ul class="sub-menus">
<li class="menu-item">
<a class="menu-link" href="https://www.secretchina.com/">Chinese</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://es.visiontimes.com/">Spanish</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.fr/">French</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.it/">Italian</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://visiontimesjp.com/">Japanese</a>
</li>
</ul>
<i class="fas fa-angle-down"></i>
</li>
<li class="menu-item menu-item-2 " tabindex="-1">
<a class="menu-link" href="https://visiontimes.us1.list-manage.com/subscribe?u=7e5b1c29f989d8d053d774db4&#038;id=3feabe35e7">Newsletter</a>
</li>
<li class="menu-item menu-item-3 " tabindex="-1">
<a class="menu-link" href="https://www.visiontimes.com/donations">Donate</a>
</li>
<li class="menu-item menu-item-4 " tabindex="-1">
<a class="menu-link" href="https://www.visiontimes.com/about-us">About US</a>
</li>
</ul>
</div>
<div class="header-menu header-menu-user">
<nav is="vision-user-side-bar" class="visionComponent vision-user-side-bar">
<div class="overlay"></div>
<div class="section-button">
<div class="large-section-button">
<a href="https://myaccount.visiontimes.com/subscribe/print.php" target="_blank">
<div class="text">Subscribe</div>
</a>
</div>
<div class="large-section-button user-login login-btn">
<div class="text">Sign in</div>
<i class="fas fa-user"></i>
</div>
</div>
<div class="user-side">
<div class="user-menu ">
<div class="user-menu-button"></div>
<div class="user-block">
<div class="user-name"></div>
<a href="https://myaccount.visiontimes.com/subscribe/print.php" target="_blank">
<div class="e-button">
<span class="text">Subscribe</span>
</div>
</a>
<div class="user-sign-out logout-btn">Sign out</div>
</div>
<ul class="user-menu-items">
<li class="user-menu-item  menu-item menu-item-type-custom menu-item-object-custom menu-item-446748  user-menu-first  level-1">
<a class="user-menu-link" href="https://myaccount.visiontimes.com/accountprofile.php">Account Settings</a>
</li>
<li class="user-menu-item  menu-item menu-item-type-custom menu-item-object-custom menu-item-446749  level-1">
<a class="user-menu-link" href="https://myaccount.visiontimes.com/newsletter.php?code=en">Newsletters</a>
</li>
<li class="user-menu-item  menu-item menu-item-type-custom menu-item-object-custom menu-item-446750  level-1">
<a class="user-menu-link" href="https://myaccount.visiontimes.com/subscribe.php?code=en">Subscriptions</a>
</li>
</ul>
</div>
</div>
</nav>
</div>
</div>
</nav>
<div class="container centerMaxWidthContainer">
<div class="vision-hamburger" is="vision-hamburger">
<div class="top-left-wrap">
<nav is="vision-navigation-side" class="visionComponent">
<div class="overlay"></div>
<div class="section-button">
<div class="large-section-button">
<div class="text">SECTIONS</div>
<i class="fas fa-bars"></i>
</div>
<div class="sm-section-button">
<img src="https://www.visiontimes.com/wp-content/themes/vt/dist/assets/images/menu-mobile-926eb40a4c.svg">
</div>
</div>
<div class="nav-side">
<div class="menu lite">
<div class="e-button">
<a href="https://visiontimes.us1.list-manage.com/subscribe?u=7e5b1c29f989d8d053d774db4&#038;id=3feabe35e7">
<span class="text">Newsletter</span>
</a>
</div>
<div class="menu-button"></div>
<ul class="menu-items">
<li class="menu-item  menu-item menu-item-type-custom menu-item-object-custom menu-item-428032  menu-first  level-1">
<a class="menu-link" href="/">Home</a>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-423521 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/news">News</a>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category menu-item-444027  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/opinions">Viewpoints</a>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-357119 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/us">US</a>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category menu-item-220229 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/china">China</a>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category menu-item-447634  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/world/americas/canada">Canada</a>
</li>
<li class="menu-item  world menu-item menu-item-type-taxonomy menu-item-object-category menu-item-989 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/world">World</a>
</li>
<li class="menu-item  life menu-item menu-item-type-taxonomy menu-item-object-category menu-item-985 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/life">Life</a>
</li>
<li class="menu-item  science menu-item menu-item-type-taxonomy menu-item-object-category menu-item-997 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/nature">Nature</a>
</li>
</ul>
</div>
</div>
</nav>
<div class="search">
<form is="vision-search-form-expandable" id="searchform" name="searchform" class="search-form" method="post" action="">
<input type="text" class="search-field" name="s" placeholder="Search" value="">
<button class="btn search-button"><i class="fas fa-search"></i></button>
</form>
</div>
</div>
</div>
<div class="logo">
<a href="https://www.visiontimes.com" title="Home"><img src="https://www.visiontimes.com/wp-content/themes/vt/dist/assets/images/vision-times-sm-logo-66a6be678b.svg" alt="Vision Times"></a>
</div>
<div class="vision-e-paper">
<a href="https://visiontimes.us1.list-manage.com/subscribe?u=7e5b1c29f989d8d053d774db4&#038;id=3feabe35e7" rel="noreferrer noopener">
<div class="e-button">
<span class="text">Newsletter</span>
</div>
</a>
</div>
</div>
<div class="top-border">Truth, Inspiration, Hope.</div>
</nav>
</header>
<main id="mainContent" class="mainContent" aria-label="Content">
<div class="content-wrapper single-wrapper">
<header>
<nav aria-label="breadcrumbs" class="rank-math-breadcrumb"><p><a href="https://www.visiontimes.com">Home</a><span class="separator"> &raquo; </span><a href="https://www.visiontimes.com/c/us">US</a><span class="separator"> &raquo; </span><a href="https://www.visiontimes.com/c/us/new-york">New York</a><span class="separator"> &raquo; </span><span class="last">Xiong Yan Endorsed to Represent New York’s 10th Congressional District by Key Member of Brooklyn Democrats</span></p></nav><div is="bread-crumbs">
</div>
<div is="vision-block-post-header-vt">
<h1>Xiong Yan Endorsed to Represent New York’s 10th Congressional District by Key Member of Brooklyn Democrats</h1>
<div class="meta">
<div class="author-time">
<div class="visionComponent" is="vision-authors-custom">
<div class="authors">
<div class="author">
<div class="img"><img alt='' src='https://secure.gravatar.com/avatar/182dd511dd531fcb21ce7dfb5eb6d732?s=30&#038;r=g' srcset='https://secure.gravatar.com/avatar/182dd511dd531fcb21ce7dfb5eb6d732?s=60&#038;r=g 2x' class='avatar avatar-30 photo' height='30' width='30' loading='lazy' /></div>
<div class="info">
<div class="name">By
<a href="https://www.visiontimes.com/author/todd-crawford">
Todd Crawford
</a>
</div>
<div class="desc"></div>
</div>
</div>
</div>
<div class="date">Published: August 10, 2022</div>
</div>
</div>
<div class="view-comment">
<div is="vision-media-share" class="visionComponent">
<div class="share-button">
<i class="far fa-share-square"></i>
<div class="share-wrap">
<div class="up-triangle"></div>
<div class="share-padding">
<ul class="share-menu">
<li>
<a target="_blank" href="https://twitter.com/intent/tweet?text=Xiong%20Yan%20Endorsed%20to%20Represent%20New%20York%E2%80%99s%2010th%20Congressional%20District%20by%20Key%20Member%20of%20Brooklyn%20Democrats&amp;url=https%3A%2F%2Fwww.visiontimes.com%2F2022%2F08%2F10%2Fxiong-yan-endorsed-to-represent-new-yorks-10th-congressional-district-by-key-member-of-the-brooklyn-democratic-party.html" rel="noopener noreferrer nofollow">
<i class="fab fa-twitter"></i>
 </a>
</li>
<li>
<a target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.visiontimes.com%2F2022%2F08%2F10%2Fxiong-yan-endorsed-to-represent-new-yorks-10th-congressional-district-by-key-member-of-the-brooklyn-democratic-party.html" rel="noopener noreferrer nofollow">
<i class="fab fa-facebook"></i>
</a>
</li>
<li>
<a target="_blank" href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.visiontimes.com%2F2022%2F08%2F10%2Fxiong-yan-endorsed-to-represent-new-yorks-10th-congressional-district-by-key-member-of-the-brooklyn-democratic-party.html&amp;media=https%3A%2F%2Fimg.visiontimes.com%2F2022%2F08%2Fsignal-2022-08-09-234211.jpeg&amp;description=Xiong-Yan-10th-congressional-district-candidate-and-Frank-Seddio" rel="noopener noreferrer nofollow" data-pin-no-hover="true" data-pin-custom="true" data-pin-do="skip" data-pin-description="Xiong-Yan-10th-congressional-district-candidate-and-Frank-Seddio">
<i class="fab fa-pinterest"></i>
</a>
</li>
<li>
<a target="_blank" href="https://www.linkedin.com/sharing/share-offsite/?url=https%3A%2F%2Fwww.visiontimes.com%2F2022%2F08%2F10%2Fxiong-yan-endorsed-to-represent-new-yorks-10th-congressional-district-by-key-member-of-the-brooklyn-democratic-party.html" rel="noopener noreferrer nofollow">
<i class="fab fa-linkedin"></i>
</a>
</li>
<li>
<a href="/cdn-cgi/l/email-protection#17287578736e2a5e32252765727673322527637f7e64322527677864633225277679733225276076796372733225276378322527647f7665723225277e63322527607e637f3225276e7862393225275f72657232252064322527637f723225277b7e797c3224563225277f6363676432245632255132255160606039617e647e7879637e7a72643974787a32255125272525322551272f32255126273225516f7e7879703a6e76793a72797378656472733a63783a6572676572647279633a7972603a6e78657c643a2627637f3a74787970657264647e7879767b3a737e6463657e74633a756e3a7c726e3a7a727a7572653a78713a637f723a756578787c7b6e793a73727a78746576637e743a677665636e397f637a7b31767a672c6462757d7274632a5632252767786463322527607865637f322527647f76657e79703224563225274f7e7879703225274e7679322527527973786564727332252763783225274572676572647279633225275972603225274e78657c325225322f27322e2e643225272627637f32252754787970657264647e7879767b322527537e6463657e7463322527756e3225275c726e3225275a727a7572653225277871322527556578787c7b6e7932252753727a787465766364" rel="noopener noreferrer nofollow">
<i class="fas fa-envelope"></i>
</a>
</li>
</ul>
</div>
</div>
</div>
</div>
<span class="comment-count" title="Jump to comment"><i class="far fa-comments"></i></span>
</div>
</div>
<div class="social-btns">
<div is="social-buttons">
<a class="button twitter" target="_blank" href="https://twitter.com/intent/tweet?text=Xiong%20Yan%20Endorsed%20to%20Represent%20New%20York%E2%80%99s%2010th%20Congressional%20District%20by%20Key%20Member%20of%20Brooklyn%20Democrats&amp;url=https%3A%2F%2Fwww.visiontimes.com%2F2022%2F08%2F10%2Fxiong-yan-endorsed-to-represent-new-yorks-10th-congressional-district-by-key-member-of-the-brooklyn-democratic-party.html" rel="noopener noreferrer nofollow"><span class="txt">Twitter</span></a>
<a class="button facebook" target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.visiontimes.com%2F2022%2F08%2F10%2Fxiong-yan-endorsed-to-represent-new-yorks-10th-congressional-district-by-key-member-of-the-brooklyn-democratic-party.html" rel="noopener noreferrer nofollow"><span class="txt">Facebook</span></a>
<a class="button pinterest" target="_blank" href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.visiontimes.com%2F2022%2F08%2F10%2Fxiong-yan-endorsed-to-represent-new-yorks-10th-congressional-district-by-key-member-of-the-brooklyn-democratic-party.html&amp;media=https%3A%2F%2Fimg.visiontimes.com%2F2022%2F08%2Fsignal-2022-08-09-234211.jpeg&amp;description=Xiong-Yan-10th-congressional-district-candidate-and-Frank-Seddio" rel="noopener noreferrer nofollow" data-pin-no-hover="true" data-pin-custom="true" data-pin-do="skip" data-pin-description="Xiong-Yan-10th-congressional-district-candidate-and-Frank-Seddio"><span class="txt">Pinterest</span></a>
<a class="button linkedin" target="_blank" href="https://www.linkedin.com/shareArticle?mini=1&amp;url=https%3A%2F%2Fwww.visiontimes.com%2F2022%2F08%2F10%2Fxiong-yan-endorsed-to-represent-new-yorks-10th-congressional-district-by-key-member-of-the-brooklyn-democratic-party.html&amp;title=Xiong%20Yan%20Endorsed%20to%20Represent%20New%20York%E2%80%99s%2010th%20Congressional%20District%20by%20Key%20Member%20of%20Brooklyn%20Democrats&amp;source=https%3A%2F%2Fwww.visiontimes.com" rel="noopener noreferrer nofollow"><span class="txt">LinkedIn</span></a>
<a class="button email" href="/cdn-cgi/l/email-protection#300f525f54490d791502004255515415020044585943150200405f4344150200515e5415020047515e445554150200445f1502004358514255150200594415020047594458150200495f451e15020078554255150207431502004458551502005c595e5b15037115020058444440431503711502761502764747471e465943595f5e44595d55431e535f5d150276020002021502760008150276010015027648595f5e571d49515e1d555e545f424355541d445f1d425540425543555e441d5e55471d495f425b431d010044581d535f5e5742554343595f5e515c1d54594344425953441d52491d5b55491d5d555d5255421d5f561d4458551d52425f5f5b5c495e1d54555d5f5342514459531d40514244491e58445d5c16515d400b4345525a5553440d71150200405f4344150200475f42445815020043585142595e5715037115020068595f5e5715020069515e150200755e545f42435554150200445f150200625540425543555e441502007e5547150200695f425b1575021508001509094315020001004458150200735f5e5742554343595f5e515c150200745943444259534415020052491502007b55491502007d555d5255421502005f5615020072425f5f5b5c495e15020074555d5f5342514443" rel="noopener noreferrer nofollow"><span class="txt">Email</span></a>
</div>
</div>
</div>
</header>
<section class="post-main">
<div class="col-left">
<div class="with-gray-border-right">
<div class="col-left-content">
<div class="featuredImage">
<div class="visionComponent visionComponent--sizeLarge  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/08/signal-2022-08-09-234211-768x576.jpeg" srcset="
                                    https://img.visiontimes.com/2022/08/signal-2022-08-09-234211.jpeg 1920w,
            https://img.visiontimes.com/2022/08/signal-2022-08-09-234211-1068x801.jpeg 1440w,
            https://img.visiontimes.com/2022/08/signal-2022-08-09-234211-1068x801.jpeg 1320w,
            https://img.visiontimes.com/2022/08/signal-2022-08-09-234211-1068x801.jpeg 1024w,
            https://img.visiontimes.com/2022/08/signal-2022-08-09-234211-768x576.jpeg 800w,
            https://img.visiontimes.com/2022/08/signal-2022-08-09-234211-696x522.jpeg 600w,
                                                            https://img.visiontimes.com/2022/08/signal-2022-08-09-234211-485x360.jpeg 375w" data-sizes="auto" alt="Xiong-Yan-10th-congressional-district-candidate-and-Frank-Seddio">
<figcaption class="figure-caption">Party Chairman, Frank Seddio (second from left) and Xiong Yan (second from right), and Xiong’s campaign team meet at the Marine Park Golf Course for a meeting called to nominate Brooklyn High Court judges on Aug. 4 in Brooklyn, New York. (Image: Vision Times/Eva Zhang)</figcaption>
</figure>
</div>
</div>
</div>
<div class="article-content">
<p>On August 4, at the Marine Park Golf Course in Brooklyn, the Democratic Party of Brooklyn held a nomination meeting for Brooklyn High Court judges. Among the attendees was Xiong Yan, candidate to represent New York’s 10th congressional district and Frank Seddio, a former Kings County Surrogate Court judge.</p>
<p>Seddio is considered a political strongman in the Brooklyn Democratic Party. He served as a state representative in southeastern Brooklyn from 1999 to 2005 and as an acting Brooklyn court judge from 2006 to 2007. Seddio served as the chairman of the Brooklyn Democratic Party from 2012 until 2020 and currently is a district leader for the 59th Assembly District, a volunteer position he has served in since 2010.&nbsp;</p>
<p>Speaking with Vision Times, Seddio provided a glowing endorsement for Xiong Yan. </p>
<p>“I think that he is one of the finest men that are in this race, one of the most genuine … and probably someone whose enthusiasm represents all of the people in that district.” He added that, “He will be fabulous and we only need to remember that when we start voting, looking at all the other candidates, this is the candidate that makes the difference to all of our communities, and he’s a Brooklyn guy, and that’s what matters.”</p>
<h2><strong>From &#8216;freedom fighter&#8217; to &#8216;freedom defender&#8217;</strong></h2>
<p>Xiong Yan, a veteran of the Iraq War, and human rights activist was a student leader during the 1989 Tiananmen Square protests in China, and has drawn the ire of the Chinese Communist Party. </p>
<p>In May, Xiong told the NY Post, “In China, I was a freedom fighter. I joined the Army when I came to America because I wanted to be a freedom defender.”</p>
<p>Xiong studied law at the prestigious Peking University in China from 1986 to 1989. He immigrated to the United States as a political refugee in 1992 and later served as a chaplain in the U.S. Army. He is running for Congress on Aug. 23 to represent New York’s 10th congressional district.&nbsp;&nbsp;</p>
<p>One of the pair&#8217;s first encounters was at a birthday party in November 2020, when Seddio first learned of Xiong’s ambitions. &#8220;At the birthday party, they were very happy when they learned that I was running for Congress. Everyone exchanged business cards and took pictures,” Xiong said, as reported by the Epoch Times. </p>
<p>Another prominent New York political figure, Erik Frankel, has openly backed Xiong’s bid for Congress said, “I like his political views …, I think he can represent our community. We don&#8217;t need politicians, I hope Xiong Yan can represent us,” The Epoch Times reported. </p>
<p>According to The Epoch Times, Frankel believes that the 10th congressional district needs politicians with traditional ideas, not radicals, asserting that extreme views hurt the community. He wants the right people to be elected who will keep small businesses in mind, &#8220;You know, when we vote, we tend to choose not for the people, but for the people against the people …people need to be elected to support small business, not to fight against small business,” Frankel told the Epoch Times. </p>
<p>On June 28, Frankel, running as a conservative candidate, lost to Democrat incumbent Marcela Mitaynes in the Democratic primary for New York State Assembly District 51.</p>
<p>Xiong, a pastor, says he is sympathetic to the weak, and is full of love and justice, who firmly defends human rights and the U.S. Constitution. His personal philosophy favors tradition, safeguarding the interests of small businesses, supporting the police, fighting crime and maintaining law and order.&nbsp;</p>
<p>The 10th congressional district covers two major Chinese communities, Chinatown and Sunset Park in Brooklyn. Xiong hopes that Chinese voters will come out to vote for him and elect a legislator who speaks for the Chinese.</p>
</div>
</div>
</div>
<footer class="post-meta">
<div class="visionComponent" is="vision-block-post-footer">
<div class="content centerContentMaxWidth">
<ul class="tags">
<li class="tags-item">Tag:</li>
<li class="tags-item"><a class="tags-itemLink pill" href="https://www.visiontimes.com/tag/59th-assembly-district"><span class="visuallyHidden">Tag:</span> 59th Assembly District</a></li>
<li class="tags-item"><a class="tags-itemLink pill" href="https://www.visiontimes.com/tag/brooklyn"><span class="visuallyHidden">Tag:</span> Brooklyn</a></li>
<li class="tags-item"><a class="tags-itemLink pill" href="https://www.visiontimes.com/tag/erik-frankel"><span class="visuallyHidden">Tag:</span> Erik Frankel</a></li>
<li class="tags-item"><a class="tags-itemLink pill" href="https://www.visiontimes.com/tag/frank-seddio"><span class="visuallyHidden">Tag:</span> Frank Seddio</a></li>
<li class="tags-item"><a class="tags-itemLink pill" href="https://www.visiontimes.com/tag/marine-park-golf-course"><span class="visuallyHidden">Tag:</span> Marine Park Golf Course</a></li>
<li class="tags-item"><a class="tags-itemLink pill" href="https://www.visiontimes.com/tag/queens"><span class="visuallyHidden">Tag:</span> Queens</a></li>
 <li class="tags-item"><a class="tags-itemLink pill" href="https://www.visiontimes.com/tag/xiong-yan"><span class="visuallyHidden">Tag:</span> Xiong Yan</a></li>
</ul>
</div>
</div>
</footer>
<div id="post-comments">
<div id="remark42" is="vision-block-comment" class="loading">
</div>
</div>
<section>
<div is="vision-grid-news-latest">
<h3>RELATED NEWS</h3>
<div class="news-latest">
<div class="article">
<a href="https://www.visiontimes.com/2022/08/10/law-firm-founded-and-managed-by-super-lawyers-offers-super-services.html"><div class="title">Davidoff Law, Founded and Managed by Super Lawyers®, Offers Super Services</div></a>
<a href="https://www.visiontimes.com/2022/08/10/law-firm-founded-and-managed-by-super-lawyers-offers-super-services.html"><div class="img"><div class="visionComponent visionComponent--sizeTiny  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/08/MainstageV10-mainstage-v10-img-768x830.jpg" srcset="
                                                                        https://img.visiontimes.com/2022/08/MainstageV10-mainstage-v10-img-485x360.jpg 375w" data-sizes="auto" alt="Davidoff-Law-Queens-New-York">
</figure>
</div>
</div>
</div></a>
</div>
<div class="article">
<a href="https://www.visiontimes.com/2022/08/09/its-got-to-stop-robert-speranza-wants-to-tackle-surging-crime-as-rep-for-nys-26th-congressional-district.html"><div class="title">‘It’s Got to Stop,’ Robert Speranza Wants to Tackle Surging Crime as Rep for NY’s 26th Congressional District</div></a>
<a href="https://www.visiontimes.com/2022/08/09/its-got-to-stop-robert-speranza-wants-to-tackle-surging-crime-as-rep-for-nys-26th-congressional-district.html"><div class="img"><div class="visionComponent visionComponent--sizeTiny  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/08/Speranza.jpg" srcset="
                                                                        https://img.visiontimes.com/2022/08/Speranza-485x360.jpg 375w" data-sizes="auto" alt="Robert-Speranza-Candidate-for-New-York&#039;s-26th-Congressional-District">
</figure>
</div>
</div>
</div></a>
</div>
<div class="article">
<a href="https://www.visiontimes.com/2022/08/08/nyc-care-holds-successful-healthcare-week-of-action-holding-events-in-all-five-boroughs.html"><div class="title">NYC Care Holds Successful Healthcare ‘Week of Action,’ Holding Events in All Five Boroughs</div></a>
<a href="https://www.visiontimes.com/2022/08/08/nyc-care-holds-successful-healthcare-week-of-action-holding-events-in-all-five-boroughs.html"><div class="img"><div class="visionComponent visionComponent--sizeTiny  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/08/IMG_1384-resized-768x512.jpg" srcset="
                                                                        https://img.visiontimes.com/2022/08/IMG_1384-resized-485x360.jpg 375w" data-sizes="auto" alt="NYC-care-holds-week-of-action-holds-events-in-all-five-boroughs">
</figure>
</div>
</div>
</div></a>
</div>
<div class="article">
<a href="https://www.visiontimes.com/2022/08/03/candidate-for-nys-10th-congressional-district-xiong-yan-meets-with-local-jewish-community-leader.html"><div class="title">Candidate for NY’s 10th Congressional District Xiong Yan Meets with Local Jewish Community Leader</div></a>
<a href="https://www.visiontimes.com/2022/08/03/candidate-for-nys-10th-congressional-district-xiong-yan-meets-with-local-jewish-community-leader.html"><div class="img"><div class="visionComponent visionComponent--sizeTiny  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/08/IMG_3443-768x576.jpg" srcset="
                                                                        https://img.visiontimes.com/2022/08/IMG_3443-485x360.jpg 375w" data-sizes="auto" alt="Xiong-Yan-running-to-represent-10th-congressional-district-in-New-York">
</figure>
</div>
</div>
</div></a>
</div>
</div>
</div>
</section>
</div>
<div class="col-right">
<div is="vision-list-top-stories">
<div class="sidebar-header">
<h3>TOP STORIES</h3>
<div class="article" id="448438">
<a href="https://www.visiontimes.com/2022/07/14/in-new-york-health-care-is-available-regardless-of-immigration-status-through-nyc-care.html"><div class="title">In New York, Health Coverage Now Available Regardless of Immigration Status Through NYC Care</div></a>
<a href="https://www.visiontimes.com/2022/07/14/in-new-york-health-care-is-available-regardless-of-immigration-status-through-nyc-care.html"><div class="img"><div class="visionComponent visionComponent--sizeTiny  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/07/jamirez-768x576.jpeg" srcset="
                                                                        https://img.visiontimes.com/2022/07/jamirez-485x360.jpeg 375w" data-sizes="auto" alt="NYC Care Executive Chairman Dr. Jonathan Jimenez">
</figure>
</div>
</div>
</div></a>
</div>
<div class="article" id="448680">
<a href="https://www.visiontimes.com/2022/07/19/im-all-in-republican-joe-pinion-seeks-to-unseat-senate-majority-leader-chuck-schumer.html"><div class="title">‘I’m all in’: Republican Joe Pinion Seeks to Unseat Senate Majority Leader Chuck Schumer</div></a>
<a href="https://www.visiontimes.com/2022/07/19/im-all-in-republican-joe-pinion-seeks-to-unseat-senate-majority-leader-chuck-schumer.html"><div class="img"><div class="visionComponent visionComponent--sizeTiny  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/07/JoePinion-768x576.jpg" srcset="
                                                                        https://img.visiontimes.com/2022/07/JoePinion-485x360.jpg 375w" data-sizes="auto" alt="Joe-Pinion-2024-elections-US-Senate-Race-Chuck-Schumer">
</figure>
</div>
</div>
</div></a>
</div>
<div class="article" id="448348">
<a href="https://www.visiontimes.com/2022/07/12/the-race-is-on-between-lee-zeldin-and-kathy-hochul-for-governor-of-new-york.html"><div class="title">The Race Is on Between Lee Zeldin and Kathy Hochul for Governor of New York</div></a>
<a href="https://www.visiontimes.com/2022/07/12/the-race-is-on-between-lee-zeldin-and-kathy-hochul-for-governor-of-new-york.html"><div class="img"><div class="visionComponent visionComponent--sizeTiny  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/07/lee-zeldin_eva_kzg_p3175981a421414792-ss.jpeg" srcset="
                                                                        https://img.visiontimes.com/2022/07/lee-zeldin_eva_kzg_p3175981a421414792-ss-485x360.jpeg 375w" data-sizes="auto" alt="">
</figure>
</div>
</div>
</div></a>
</div>
<div class="article" id="448996">
<a href="https://www.visiontimes.com/2022/07/27/what-nyc-health-officials-want-you-to-know-about-covid-19-this-summer.html"><div class="title">What NYC Health Officials Want You to Know About COVID-19 This Summer</div></a>
<a href="https://www.visiontimes.com/2022/07/27/what-nyc-health-officials-want-you-to-know-about-covid-19-this-summer.html"><div class="img"><div class="visionComponent visionComponent--sizeTiny  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/07/signal-2022-07-26-131121_001-768x576.jpeg" srcset="
                                                                        https://img.visiontimes.com/2022/07/signal-2022-07-26-131121_001-485x360.jpeg 375w" data-sizes="auto" alt="New-York-COVID-19-NYC-Department-of-Health">
</figure>
</div>
</div>
</div></a>
</div>
<div class="article" id="448685">
<a href="https://www.visiontimes.com/2022/07/19/contenders-for-nys-offices-speak-about-their-campaign-goals-at-popular-gop-club.html"><div class="title">Contenders for NYS Offices Speak About Their Campaign Goals at Popular GOP Club</div></a>
<a href="https://www.visiontimes.com/2022/07/19/contenders-for-nys-offices-speak-about-their-campaign-goals-at-popular-gop-club.html"><div class="img"><div class="visionComponent visionComponent--sizeTiny  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/07/IMG_7554-768x576.jpg" srcset="
                                                                        https://img.visiontimes.com/2022/07/IMG_7554-485x360.jpg 375w" data-sizes="auto" alt="Republican-candidates-for-several-state-and-federal-offices-address-a-crowed-room">
</figure>
</div>
</div>
</div></a>
</div>
</div>
</div>
<div is="vision-list-most-read">
<div class="sidebar-header" load_max="30" load_more="10">
<h3>MOST POPULAR</h3>
<div class="article" id="449447">
<a href="https://www.visiontimes.com/2022/08/08/10000-millionaires-with-48-billion-expected-to-leave-china-this-year-report.html"><div class="title">10,000 Millionaires Expected to Leave China This Year–And Take $48 Billion With Them: Report</div></a>
<a href="https://www.visiontimes.com/2022/08/08/10000-millionaires-with-48-billion-expected-to-leave-china-this-year-report.html"><div class="img"><div class="visionComponent visionComponent--sizeTiny  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/08/China-Economy-decline-GettyImages-675021470-768x497.jpg" srcset="
                                                                        https://img.visiontimes.com/2022/08/China-Economy-decline-GettyImages-675021470-485x360.jpg 375w" data-sizes="auto" alt="">
</figure>
</div>
</div>
</div></a>
</div>
<div class="article" id="448737">
<a href="https://www.visiontimes.com/2022/07/20/chinese-reporter-in-japan-driven-to-attempt-suicide-after-being-heaped-with-online-abuse-for-shedding-tears-at-abes-death.html"><div class="title">Chinese Reporter in Japan Attempts Suicide After Being Heaped With Online Abuse for Shedding Tears at</div></a>
<a href="https://www.visiontimes.com/2022/07/20/chinese-reporter-in-japan-driven-to-attempt-suicide-after-being-heaped-with-online-abuse-for-shedding-tears-at-abes-death.html"><div class="img"><div class="visionComponent visionComponent--sizeTiny  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/07/Zeng-Ying-Chinese-Reporter-Weibo.jpg" srcset="
                                                                        https://img.visiontimes.com/2022/07/Zeng-Ying-Chinese-Reporter-Weibo-485x360.jpg 375w" data-sizes="auto" alt="Zeng-Ying-Chinese-Reporter-Weibo">
</figure>
</div>
</div>
</div></a>
</div>
<div class="article" id="448931">
<a href="https://www.visiontimes.com/2022/07/25/sri-lanka-social-credit-fuel-rationing.html"><div class="title">Sri Lanka Introduces Social Credit QR Code Fuel Rationing Amid Economic Collapse</div></a>
<a href="https://www.visiontimes.com/2022/07/25/sri-lanka-social-credit-fuel-rationing.html"><div class="img"><div class="visionComponent visionComponent--sizeTiny  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/07/Sri-Lanka-Social-Credit-QR-Code-Fuel-Rationing-No-Oil-Imports-768x512.jpg" srcset="
                                                                        https://img.visiontimes.com/2022/07/Sri-Lanka-Social-Credit-QR-Code-Fuel-Rationing-No-Oil-Imports-485x360.jpg 375w" data-sizes="auto" alt="Sri Lanka has deployed social credit QR code fuel rationing linked to national ID.">
</figure>
</div>
</div>
</div></a>
</div>
<div class="article" id="448550">
<a href="https://www.visiontimes.com/2022/07/15/us-railway-strike-biden-intervenes.html"><div class="title">A US Railway Strike Is Two Days Away, Unless Biden Intervenes</div></a>
<a href="https://www.visiontimes.com/2022/07/15/us-railway-strike-biden-intervenes.html"><div class="img"><div class="visionComponent visionComponent--sizeTiny  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/07/US-Railway-Strike-Biden-Administration-Intervention-October-Primaries-768x503.jpg" srcset="
                                                                        https://img.visiontimes.com/2022/07/US-Railway-Strike-Biden-Administration-Intervention-October-Primaries-485x360.jpg 375w" data-sizes="auto" alt="A US railway strike may launch on July 18 unless Joe Biden intervenes, which would put him at odds with the unions ahead of the October primaries.">
</figure>
</div>
</div>
</div></a>
</div>
<div class="article" id="448615">
<a href="https://www.visiontimes.com/2022/07/18/canadian-casket-manufacturer-sees-a-surge-in-demand-for-youth-caskets.html"><div class="title">Canadian Casket Manufacturer Sees a Surge in Demand for Youth Caskets</div></a>
<a href="https://www.visiontimes.com/2022/07/18/canadian-casket-manufacturer-sees-a-surge-in-demand-for-youth-caskets.html"><div class="img"><div class="visionComponent visionComponent--sizeTiny  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/07/GettyImages-1230986760-768x509.jpg" srcset="
                                                                        https://img.visiontimes.com/2022/07/GettyImages-1230986760-485x360.jpg 375w" data-sizes="auto" alt="Casket-sales-youth-surge-following-vaccine-rollout-Getty-Images-1230986760">
</figure>
</div>
</div>
</div></a>
</div>
<div class="article" id="448218">
<a href="https://www.visiontimes.com/2022/07/11/panama-protests-fuel-food-medicine.html"><div class="title">Panama Faces National Protests, Strikes Over Gas and Food Prices</div></a>
<a href="https://www.visiontimes.com/2022/07/11/panama-protests-fuel-food-medicine.html"><div class="img"><div class="visionComponent visionComponent--sizeTiny  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/07/Panama-National-Protests-Food-Gasoline-Medicine-Costs-768x512.jpg" srcset="
                                                                        https://img.visiontimes.com/2022/07/Panama-National-Protests-Food-Gasoline-Medicine-Costs-485x360.jpg 375w" data-sizes="auto" alt="Protests are also hitting Panama over the cost of food, fuel, and medicine, but the uprisings seem driven by the unions">
</figure>
</div>
</div>
</div></a>
</div>
</div>
<div class="load-more">
<div class="loading load-more-loading"></div>
<a href="https://www.visiontimes.com/wp-admin/admin-ajax.php" id="load-more-button" load-most-popular>
<button>
<div class="load-more-text">LOAD MORE</div>
</button>
</a>
</div>
</div>
</div>
</section>
</div>
</main>
<footer class="mainFooter">
<div class="visionComponent themeLight" is="vision-navigation-footer">
<div class="container centerMaxWidthContainer">
<ul class="footer-nav">
<li>
<div class="heading">EDITIONS</div>
<ul class="items">
<li class="menu-item">
<a class="menu-link" href="https://www.secretchina.com/">Chinese</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://es.visiontimes.com/">Spanish</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.fr/">French</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.it/">Italian</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimesjp.com/">Japanese</a>
</li>
</ul>
</li>
<li>
<div class="heading">COMPANY</div>
<ul class="items">
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/about-us">About</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/contact-us">Contact</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/advertise">Advertise</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/submissions">Submissions</a>
</li>
</ul>
</li>
<li>
<div class="heading">INFO</div>
<ul class="items">
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/privacy">Privacy Policy</a>
</li>
 <li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/policies">Terms of Service</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/copyright-policy-and-infringement-notification">Copyright Policy and Infringement Notification</a>
</li>
</ul>
</li>
<li>
<div class="heading">POPULAR CATEGORY</div>
<ul class="items">
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/c/us">US</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/c/china">China</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/c/world">World</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/c/politics">Politics</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/c/human-rights">Human Rights</a>
</li>
</ul>
</li>
</ul>
<div class="footer-nav footer-nav-2">
<li>
<div class="heading">About Us</div>
<div class="items txt">Vision Times tells the world everything about China in today's context. We keep a close eye on China because of its influence now and the lessons we can learn from its ancient past to better our lives today.</div>
</li>
<li>
<div class="heading">Follow Us</div>
<ul class="items icons">
<li><a href="https://www.facebook.com/VisionTimesOfficial" target="_blank" rel="nofollow" title="Facebook"> <i class="fab fa-facebook-f"></i></a></li>
<li><a href="https://twitter.com/times_vision" target="_blank" rel="nofollow" title="Twitter"><i class="fab fa-twitter"></i></a></li>
<li><a href="https://www.youtube.com/c/VisionTimesNews" target="_blank" rel="nofollow" title="Youtube"><i class="fab fa-youtube"></i></a></li>
<li><a href="https://t.me/visiontimes" target="_blank" rel="nofollow" title="Telegram"><i class="fab fa-telegram"></i></a></li>
<li><a href="https://safechat.com/channel/2788089756776450736" target="_blank" rel="nofollow" title="SafeChat"><i class="fab fa-safechat"></i></a></li>
</ul>
</li>
</div>
</div>
</div>
</footer>
</div>
<div class="wpFooter">


<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-W8PQVQT"
height="0" width="0" style="display:none;visibility:hidden" aria-hidden="true"></iframe></noscript>
<div is="vision-block-cookie-notice" class="visionComponent boxShadow layoutFloating themeReset" role="dialog">
<div class="container centerMaxWidthContainer">
<div class="content">
<p class="header">This website uses cookies</p>
<p>We inform you that this site uses own, technical and third parties cookies to make sure our web page is user-friendly and to guarantee a high functionality of the webpage. By continuing to browse this website, you declare to accept the use of cookies.</p>
</div>
<button type="button" class="button button--small" aria-label="Close" data-close>Ok</button>
</div>
</div>

<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
  var _paq = window._paq = window._paq || [];
  /* tracker methods like "setCustomDimension" should be called before "trackPageView" */
  _paq.push(['trackPageView']);
  _paq.push(['enableLinkTracking']);
  (function() {
    var u="https://kreativreason.matomo.cloud/";
    _paq.push(['setTrackerUrl', u+'matomo.php']);
    _paq.push(['setSiteId', '1']);
    var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];
    g.async=true; g.src='//cdn.matomo.cloud/kreativreason.matomo.cloud/matomo.js'; s.parentNode.insertBefore(g,s);
  })();
</script>



<script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">
	var dataLayer_content = {"pageTitle":"Xiong Yan Endorsed to Represent New York’s 10th Congressional District by Key Member of Brooklyn Democrats - Vision Times","pagePostType":"post","pagePostType2":"single-post","pageCategory":["new-york","news","politics","us","us-politics"],"pageAttributes":["59th-assembly-district","brooklyn","erik-frankel","frank-seddio","marine-park-golf-course","queens","xiong-yan"],"pagePostAuthorID":526,"pagePostAuthor":"Todd Crawford"};
	dataLayer.push( dataLayer_content );
</script>
<script data-cfasync="false">
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.'+'js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-W8PQVQT');
</script>


</div>
<script async type="text/javascript" src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script async type="text/javascript" src="https://intothebid.com/wrapper/vt/prebid.vt_en.js"></script>
<script async type="text/javascript" src="https://intothebid.com/wrapper/vt/hp_vt_en.js"></script>
<script async type="text/javascript" src="https://intothebid.com/wrapper/vt/hb_vt_en.js"></script>
<script defer src="https://www.visiontimes.com/wp-content/cache/autoptimize/js/autoptimize_6d5b05acf688e50291fd02da8c9c051d.js"></script></body>
</html>

