<!DOCTYPE html>
<html class="html post-template-default single single-post postid-455381 single-format-standard" lang="en-US" ontouchmove>
<head>
<meta charset="utf-8">
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta name="viewport" content="width=device-width, initial-scale=1">
<meta name="facebook-domain-verification" content="sk3rnqnkzv6l3wofm6ex6k4t60vodw" />
<link rel="alternate" type="application/rss+xml" title="Vision Times Feed" href="https://www.visiontimes.com/feed">
<link rel="preconnect" href="https://intothebid.com/">
<link rel="preconnect" href="https://securepubads.g.doubleclick.net/">

<script data-cfasync="false" data-pagespeed-no-defer>
	var gtm4wp_datalayer_name = "dataLayer";
	var dataLayer = dataLayer || [];
</script>


<link media="all" href="https://www.visiontimes.com/wp-content/cache/autoptimize/css/autoptimize_b13c8ef189839bdb1df91ecfc7b8dbcd.css" rel="stylesheet" /><title>Biden’s Griner Deal Sparks Controversy, Calls to Secure the Release of Other Russian Prisoners - Vision Times</title>
<meta name="description" content="On Dec. 8 U.S. President Joe Biden announced that his administration had reached a deal with Russian authorities to secure the release of Brittney Griner, via" />
<meta name="robots" content="follow, index, max-snippet:-1, max-video-preview:-1, max-image-preview:large" />
<link rel="canonical" href="https://www.visiontimes.com/2022/12/08/bidens-griner-deal-sparks-controversy-calls-for-other-russian-prisoners-release.html" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Biden’s Griner Deal Sparks Controversy, Calls to Secure the Release of Other Russian Prisoners - Vision Times" />
<meta property="og:description" content="On Dec. 8 U.S. President Joe Biden announced that his administration had reached a deal with Russian authorities to secure the release of Brittney Griner, via" />
<meta property="og:url" content="https://www.visiontimes.com/2022/12/08/bidens-griner-deal-sparks-controversy-calls-for-other-russian-prisoners-release.html" />
<meta property="og:site_name" content="Vision Times" />
<meta property="article:tag" content="biden administration" />
<meta property="article:tag" content="Brittney Griner" />
<meta property="article:tag" content="Lord of War" />
<meta property="article:tag" content="Marine Paul Whelan" />
<meta property="article:tag" content="Merchant of Death" />
<meta property="article:tag" content="Viktor Bout" />
<meta property="article:section" content="US" />
<meta property="og:updated_time" content="2022-12-08T13:21:47-05:00" />
<meta property="og:image" content="https://img.visiontimes.com/2022/12/GettyImages-1242297908-600x400.jpg" />
<meta property="og:image:secure_url" content="https://img.visiontimes.com/2022/12/GettyImages-1242297908-600x400.jpg" />
<meta property="og:image:width" content="600" />
<meta property="og:image:height" content="400" />
<meta property="og:image:alt" content="Griner-Brittany-Paul-Wehlan-Getty-Images-1242297908" />
<meta property="og:image:type" content="image/jpeg" />
<meta property="article:published_time" content="2022-12-08T13:17:43-05:00" />
<meta property="article:modified_time" content="2022-12-08T13:21:47-05:00" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:title" content="Biden’s Griner Deal Sparks Controversy, Calls to Secure the Release of Other Russian Prisoners - Vision Times" />
<meta name="twitter:description" content="On Dec. 8 U.S. President Joe Biden announced that his administration had reached a deal with Russian authorities to secure the release of Brittney Griner, via" />
<meta name="twitter:image" content="https://img.visiontimes.com/2022/12/GettyImages-1242297908-600x400.jpg" />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="Todd Crawford" />
<meta name="twitter:label2" content="Time to read" />
<meta name="twitter:data2" content="4 minutes" />
<script type="application/ld+json" class="rank-math-schema">{"@context":"https://schema.org","@graph":[{"@type":["NGO","Organization"],"@id":"https://www.visiontimes.com/#organization","name":"Vision Times","url":"https://www.visiontimes.com"},{"@type":"WebSite","@id":"https://www.visiontimes.com/#website","url":"https://www.visiontimes.com","name":"Vision Times","publisher":{"@id":"https://www.visiontimes.com/#organization"},"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://img.visiontimes.com/2022/12/GettyImages-1242297908.jpg","url":"https://img.visiontimes.com/2022/12/GettyImages-1242297908.jpg","width":"5400","height":"3600","caption":"Griner-Brittany-Paul-Wehlan-Getty-Images-1242297908","inLanguage":"en-US"},{"@type":"BreadcrumbList","@id":"https://www.visiontimes.com/2022/12/08/bidens-griner-deal-sparks-controversy-calls-for-other-russian-prisoners-release.html#breadcrumb","itemListElement":[{"@type":"ListItem","position":"1","item":{"@id":"https://www.visiontimes.com","name":"Home"}},{"@type":"ListItem","position":"2","item":{"@id":"https://www.visiontimes.com/c/us","name":"US"}},{"@type":"ListItem","position":"3","item":{"@id":"https://www.visiontimes.com/2022/12/08/bidens-griner-deal-sparks-controversy-calls-for-other-russian-prisoners-release.html","name":"Biden\u2019s Griner Deal Sparks Controversy, Calls to Secure the Release of Other Russian Prisoners"}}]},{"@type":"WebPage","@id":"https://www.visiontimes.com/2022/12/08/bidens-griner-deal-sparks-controversy-calls-for-other-russian-prisoners-release.html#webpage","url":"https://www.visiontimes.com/2022/12/08/bidens-griner-deal-sparks-controversy-calls-for-other-russian-prisoners-release.html","name":"Biden\u2019s Griner Deal Sparks Controversy, Calls to Secure the Release of Other Russian Prisoners - Vision Times","datePublished":"2022-12-08T13:17:43-05:00","dateModified":"2022-12-08T13:21:47-05:00","isPartOf":{"@id":"https://www.visiontimes.com/#website"},"primaryImageOfPage":{"@id":"https://img.visiontimes.com/2022/12/GettyImages-1242297908.jpg"},"inLanguage":"en-US","breadcrumb":{"@id":"https://www.visiontimes.com/2022/12/08/bidens-griner-deal-sparks-controversy-calls-for-other-russian-prisoners-release.html#breadcrumb"}},{"@type":"Person","@id":"https://www.visiontimes.com/author/todd-crawford","name":"Todd Crawford","url":"https://www.visiontimes.com/author/todd-crawford","image":{"@type":"ImageObject","@id":"https://secure.gravatar.com/avatar/182dd511dd531fcb21ce7dfb5eb6d732?s=96&amp;r=g","url":"https://secure.gravatar.com/avatar/182dd511dd531fcb21ce7dfb5eb6d732?s=96&amp;r=g","caption":"Todd Crawford","inLanguage":"en-US"},"worksFor":{"@id":"https://www.visiontimes.com/#organization"}},{"@type":"NewsArticle","headline":"Biden\u2019s Griner Deal Sparks Controversy, Calls to Secure the Release of Other Russian Prisoners - Vision Times","keywords":"Griner","datePublished":"2022-12-08T13:17:43-05:00","dateModified":"2022-12-08T13:21:47-05:00","articleSection":"News, US","author":{"@id":"https://www.visiontimes.com/author/todd-crawford"},"publisher":{"@id":"https://www.visiontimes.com/#organization"},"description":"On Dec. 8 U.S. President Joe Biden announced that his administration had reached a deal with Russian authorities to secure the release of Brittney Griner, via","name":"Biden\u2019s Griner Deal Sparks Controversy, Calls to Secure the Release of Other Russian Prisoners - Vision Times","@id":"https://www.visiontimes.com/2022/12/08/bidens-griner-deal-sparks-controversy-calls-for-other-russian-prisoners-release.html#richSnippet","isPartOf":{"@id":"https://www.visiontimes.com/2022/12/08/bidens-griner-deal-sparks-controversy-calls-for-other-russian-prisoners-release.html#webpage"},"image":{"@id":"https://img.visiontimes.com/2022/12/GettyImages-1242297908.jpg"},"inLanguage":"en-US","mainEntityOfPage":{"@id":"https://www.visiontimes.com/2022/12/08/bidens-griner-deal-sparks-controversy-calls-for-other-russian-prisoners-release.html#webpage"}}]}</script>

<script id='Vision/assets-js-extra'>
var VisionData = {"templateDirectoryUri":"https:\/\/www.visiontimes.com\/wp-content\/themes\/vt","locale":"en_US","admin_ajax_url":"https:\/\/www.visiontimes.com\/wp-admin\/admin-ajax.php","post_id":"455381"};
var VisionDataComment = {"comment":"1","site":"https:\/\/www.visiontimes.com","article_link":"https:\/\/www.visiontimes.com\/2022\/12\/08\/bidens-griner-deal-sparks-controversy-calls-for-other-russian-prisoners-release.html"};
</script>
<script type="application/javascript" src="https://sdki.truepush.com/sdk/v2.0.3/app.js" async></script>
<script>
    var truepush = window.Truepush || [];
        truepush.push( function() {
        truepush.Init({
            id : "620c00246daffbb98a21b770",
fromWordpress : true,
local : false,
wordpresspath : "https://www.visiontimes.com/wp-content/plugins/truepush-free-web-push-notifications/",
        },function(error){
          if(error) console.error(error);
        })
    });
    </script>

<script>
  var _paq = window._paq = window._paq || [];
  /* tracker methods like "setCustomDimension" should be called before "trackPageView" */
  _paq.push(['trackPageView']);
  _paq.push(['enableLinkTracking']);
  (function() {
    var u="https://kreativreason.matomo.cloud/";
    _paq.push(['setTrackerUrl', u+'matomo.php']);
    _paq.push(['setSiteId', '5']);
    var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];
    g.async=true; g.src='//cdn.matomo.cloud/kreativreason.matomo.cloud/matomo.js'; s.parentNode.insertBefore(g,s);
  })();
</script>
<link rel="icon" href="https://img.visiontimes.com/2021/04/cropped-favicon-512x512-1-1-32x32.png" sizes="32x32" />
<link rel="icon" href="https://img.visiontimes.com/2021/04/cropped-favicon-512x512-1-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://img.visiontimes.com/2021/04/cropped-favicon-512x512-1-1-180x180.png" />
<meta name="msapplication-TileImage" content="https://img.visiontimes.com/2021/04/cropped-favicon-512x512-1-1-270x270.png" />
</head>
<body>
<a href="#mainContent" class="skipLink">
Skip to main content
</a>
<div class="pageWrapper">
<header class="mainHeader">
<div is="vision-top-header">
<nav class="visionComponent  navigation-TopBarMenu" aria-label="Main">
<div class="wrap">
<div class="header-menu header-menu-menu">
<ul class="menu">
<li class="menu-item " tabindex="-1">
<a class="menu-link" href="#" tabindex="-1">Editions</a>
<ul class="sub-menus">
<li class="menu-item">
<a class="menu-link" href="https://www.secretchina.com/">Chinese</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://es.visiontimes.com/">Spanish</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.fr/">French</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.it/">Italian</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://visiontimesjp.com/">Japanese</a>
</li>
</ul>
<i class="fas fa-angle-down"></i>
</li>
<li class="menu-item " tabindex="-1">
<a class="menu-link" href="https://visiontimes.us1.list-manage.com/subscribe?u=7e5b1c29f989d8d053d774db4&#038;id=3feabe35e7" tabindex="-1">Newsletter</a>
</li>
<li class="menu-item " tabindex="-1">
<a class="menu-link" href="https://www.visiontimes.com/donations" tabindex="-1">Donate</a>
</li>
<li class="menu-item " tabindex="-1">
<a class="menu-link" href="https://e-paper.visiontimes.com/" target="_blank" rel="noopener noreferrer" tabindex="-1">e-Paper</a>
</li>
<li class="menu-item " tabindex="-1">
<a class="menu-link" href="https://www.visiontimes.com/about-us" tabindex="-1">About US</a>
</li>
</ul>
</div>
<div class="header-menu header-menu-user">
<nav is="vision-user-side-bar" class="visionComponent vision-user-side-bar">
<div class="overlay"></div>
<div class="section-button">
<div class="large-section-button">
<a href="https://myaccount.visiontimes.com/subscribe/print.php" target="_blank">
<div class="text">Subscribe</div>
</a>
</div>
<div class="large-section-button user-login login-btn">
<div class="text">Sign in</div>
<i class="fas fa-user"></i>
</div>
</div>
<div class="user-side">
<div class="user-menu ">
<div class="user-menu-button"></div>
<div class="user-block">
<div class="user-name"></div>
<a href="https://myaccount.visiontimes.com/subscribe/print.php" target="_blank">
<div class="e-button">
<span class="text">Subscribe</span>
</div>
</a>
<div class="user-sign-out logout-btn">Sign out</div>
</div>
<ul class="user-menu-items">
<li class="user-menu-item  menu-item menu-item-type-custom menu-item-object-custom menu-item-446748  user-menu-first  level-1">
<a class="user-menu-link" href="https://myaccount.visiontimes.com/accountprofile.php">Account Settings</a>
</li>
<li class="user-menu-item  menu-item menu-item-type-custom menu-item-object-custom menu-item-446749  level-1">
<a class="user-menu-link" href="https://myaccount.visiontimes.com/newsletter.php?code=en">Newsletters</a>
</li>
<li class="user-menu-item  menu-item menu-item-type-custom menu-item-object-custom menu-item-446750  level-1">
<a class="user-menu-link" href="https://myaccount.visiontimes.com/subscribe.php?code=en">Subscriptions</a>
</li>
</ul>
</div>
</div>
</nav>
</div>
</div>
</nav>
<div class="header-top-middle">
<div class="vision-weather-widget" is="vision-weather-widget">
<div class="top-left-wrap">
<nav is="vision-navigation-side" class="visionComponent">
<div class="overlay"></div>
<div class="section-button">
<div class="large-section-button">
<div class="text">SECTIONS</div>
<i class="fas fa-bars"></i>
</div>
<div class="sm-section-button">
<img src="https://www.visiontimes.com/wp-content/themes/vt/dist/assets/images/menu-mobile-926eb40a4c.svg">
</div>
</div>
<div class="nav-side">
<div class="menu ">
<div class="e-button">
<a href="https://myaccount.visiontimes.com/subscribe/print.php">
<span class="text">Subscribe</span>
</a>
</div>
<div class="menu-button"></div>
<ul class="menu-items">
<li class="menu-item  menu-item menu-item-type-custom menu-item-object-custom menu-item-428032  menu-first  level-1">
<a class="menu-link" href="/">Home</a>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-423521 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/news">News</a>
<i class="fas fa-angle-right"></i>
<div class="sub-menu-wrap">
<ul class="sub-menus">
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423525 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/politics">Politics</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423526 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/society">Society</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33185 menu-item-has-children level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/tech">Tech</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423524 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/human-rights">Human Rights</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423522 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/analysis">Analysis</a>
</li>
</ul>
<i class="fas fa-caret-left"></i>
</div>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category menu-item-444027  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/opinions">Viewpoints</a>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-357119 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/us">US</a>
<i class="fas fa-angle-right"></i>
<div class="sub-menu-wrap">
<ul class="sub-menus">
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423514 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/us/us-politics">Politics</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423520 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/us/us-foreign-policy">Foreign Policy</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423515 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/us/new-york">New York</a>
</li>
</ul>
<i class="fas fa-caret-left"></i>
</div>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category menu-item-220229 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/china">China</a>
<i class="fas fa-angle-right"></i>
<div class="sub-menu-wrap">
<ul class="sub-menus">
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-437130 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/china/china-politics">Politics</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-437131 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/china/china-economy">Economy</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-437133 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/china/china-foreign-relations">International Relations</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-437129 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/china/china-society">Society</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-413925 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/china/china-culture">Chinese Culture</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-448624 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/china/china-insights">China Insights</a>
</li>
</ul>
<i class="fas fa-caret-left"></i>
</div>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category menu-item-447634  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/world/americas/canada">Canada</a>
</li>
<li class="menu-item  world menu-item menu-item-type-taxonomy menu-item-object-category menu-item-989 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/world">World</a>
<i class="fas fa-angle-right"></i>
<div class="sub-menu-wrap">
<ul class="sub-menus">
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-414013 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/world/americas">Americas</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-414014 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/world/asia-pacific">Asia-Pacific</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-414015 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/world/europe">Europe</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-447637 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/world/europe/uk">UK</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-414016 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/world/south-asia">South Asia</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-414012 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/world/africa">Africa</a>
</li>
</ul>
<i class="fas fa-caret-left"></i>
</div>
</li>
<li class="menu-item  life menu-item menu-item-type-taxonomy menu-item-object-category menu-item-985 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/life">Life</a>
<i class="fas fa-angle-right"></i>
<div class="sub-menu-wrap">
<ul class="sub-menus">
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-447636 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/culture">Culture</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423493 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/life/wellness">Wellness</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423518 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/life/mind-spirit">Mind &amp; Spirit</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423517 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/life/gardening">Gardening</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423516 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/life/entertainment">Entertainment</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-447635 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/china/china-culture">Chinese Culture</a>
</li>
</ul>
<i class="fas fa-caret-left"></i>
</div>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423523  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/health">Health</a>
</li>
<li class="menu-item  menu-item menu-item-type-custom menu-item-object-custom menu-item-449787  level-1">
<a class="menu-link" href="https://e-paper.visiontimes.com/" target="_blank" rel="noopener noreferrer">e-Paper</a>
</li>
</ul>
</div>
</div>
</nav>
<div class="search">
<form is="vision-search-form-expandable" id="searchform" name="searchform" class="search-form" method="post" action="https://www.visiontimes.com">
<input type="text" class="search-field" name="s" placeholder="Search" value="">
<button class="btn search-button"><i class="fas fa-search"></i></button>
</form>
</div>
</div>
<div class="vision-current-date-widget" is="vision-current-date-widget"></div>
</div>
<div class="vision-top-banner">
<ul class="menu">
<li class="menu-item ">
<a class="menu-link" href="/">
HOME
</a>
</li>
<li class="menu-item ">
<a class="menu-link" href="https://www.visiontimes.com/c/news">
NEWS
</a>
</li>
<li class="menu-item ">
<a class="menu-link" href="https://www.visiontimes.com/c/opinions">
VIEWPOINTS
</a>
</li>
<li class="menu-item ">
<a class="menu-link" href="https://www.visiontimes.com/c/us">
US
</a>
</li>
<li class="menu-item ">
<a class="menu-link" href="https://www.visiontimes.com/c/china">
CHINA
</a>
</li>
<li class="menu-item ">
<a class="menu-link" href="https://www.visiontimes.com/c/world/americas/canada">
CANADA
</a>
</li>
<li class="menu-item ">
<a class="menu-link" href="https://www.visiontimes.com/c/world">
WORLD
</a>
</li>
<li class="menu-item ">
<a class="menu-link" href="https://www.visiontimes.com/c/life">
LIFE
</a>
</li>
<li class="menu-item ">
<a class="menu-link" href="https://www.visiontimes.com/c/health">
HEALTH
</a>
</li>
<li class="menu-item ">
<a class="menu-link" href="https://e-paper.visiontimes.com/" target="_blank" rel="noopener noreferrer">
E-PAPER
</a>
</li>
</ul>
<div>
<a href="https://www.visiontimes.com" title="Home"><img src="https://www.visiontimes.com/wp-content/themes/vt/dist/assets/images/vision-times-logo-fc9b3d60e2.svg" alt="Vision Times"></a>
</div>
</div>
<div class="vision-e-paper">
<a href="https://myaccount.visiontimes.com/subscribe/print.php">
<div class="e-button">
<span class="text">Subscribe</span>
</div>
</a>
<a href="https://visiontimes.us1.list-manage.com/subscribe?u=7e5b1c29f989d8d053d774db4&#038;id=3feabe35e7" rel="noreferrer noopener">
<div class="e-button prime-white">
<span class="text">Newsletter</span>
</div>
</a>
</div>
</div>
<div class="top-border">Truth, Inspiration, Hope.</div>
</div>
<nav class="visionComponent vision-sticky-bar " is="vision-top-bar-sticky" aria-label="Main">
<div class="wrap">
<nav is="vision-navigation-side" class="visionComponent">
<div class="overlay"></div>
<div class="section-button">
<div class="large-section-button">
<div class="text">SECTIONS</div>
<i class="fas fa-bars"></i>
</div>
<div class="sm-section-button">
<img src="https://www.visiontimes.com/wp-content/themes/vt/dist/assets/images/menu-mobile-926eb40a4c.svg">
</div>
</div>
<div class="nav-side">
<div class="menu ">
<div class="e-button">
<a href="https://myaccount.visiontimes.com/subscribe/print.php">
<span class="text">Subscribe</span>
</a>
</div>
<div class="menu-button"></div>
<ul class="menu-items">
<li class="menu-item  menu-item menu-item-type-custom menu-item-object-custom menu-item-428032  menu-first  level-1">
<a class="menu-link" href="/">Home</a>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-423521 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/news">News</a>
<i class="fas fa-angle-right"></i>
<div class="sub-menu-wrap">
<ul class="sub-menus">
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423525 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/politics">Politics</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423526 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/society">Society</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33185 menu-item-has-children level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/tech">Tech</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423524 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/human-rights">Human Rights</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423522 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/analysis">Analysis</a>
</li>
</ul>
<i class="fas fa-caret-left"></i>
</div>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category menu-item-444027  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/opinions">Viewpoints</a>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-357119 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/us">US</a>
<i class="fas fa-angle-right"></i>
<div class="sub-menu-wrap">
<ul class="sub-menus">
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423514 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/us/us-politics">Politics</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423520 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/us/us-foreign-policy">Foreign Policy</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423515 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/us/new-york">New York</a>
</li>
</ul>
<i class="fas fa-caret-left"></i>
</div>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category menu-item-220229 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/china">China</a>
<i class="fas fa-angle-right"></i>
<div class="sub-menu-wrap">
<ul class="sub-menus">
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-437130 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/china/china-politics">Politics</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-437131 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/china/china-economy">Economy</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-437133 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/china/china-foreign-relations">International Relations</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-437129 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/china/china-society">Society</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-413925 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/china/china-culture">Chinese Culture</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-448624 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/china/china-insights">China Insights</a>
</li>
</ul>
<i class="fas fa-caret-left"></i>
</div>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category menu-item-447634  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/world/americas/canada">Canada</a>
</li>
<li class="menu-item  world menu-item menu-item-type-taxonomy menu-item-object-category menu-item-989 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/world">World</a>
<i class="fas fa-angle-right"></i>
<div class="sub-menu-wrap">
<ul class="sub-menus">
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-414013 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/world/americas">Americas</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-414014 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/world/asia-pacific">Asia-Pacific</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-414015 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/world/europe">Europe</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-447637 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/world/europe/uk">UK</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-414016 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/world/south-asia">South Asia</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-414012 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/world/africa">Africa</a>
</li>
</ul>
<i class="fas fa-caret-left"></i>
</div>
</li>
<li class="menu-item  life menu-item menu-item-type-taxonomy menu-item-object-category menu-item-985 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/life">Life</a>
<i class="fas fa-angle-right"></i>
<div class="sub-menu-wrap">
<ul class="sub-menus">
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-447636 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/culture">Culture</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423493 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/life/wellness">Wellness</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423518 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/life/mind-spirit">Mind &amp; Spirit</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423517 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/life/gardening">Gardening</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423516 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/life/entertainment">Entertainment</a>
</li>
<li class="menu-item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-447635 level-2">
<a class="menu-link" href="https://www.visiontimes.com/c/china/china-culture">Chinese Culture</a>
</li>
</ul>
<i class="fas fa-caret-left"></i>
</div>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423523  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/health">Health</a>
</li>
<li class="menu-item  menu-item menu-item-type-custom menu-item-object-custom menu-item-449787  level-1">
<a class="menu-link" href="https://e-paper.visiontimes.com/" target="_blank" rel="noopener noreferrer">e-Paper</a>
</li>
</ul>
</div>
</div>
</nav>
<div class="search">
<form is="vision-search-form-expandable" id="searchform" name="searchform" class="search-form" method="post" action="https://www.visiontimes.com">
<input type="text" class="search-field" name="s" placeholder="Search" value="">
<button class="btn search-button"><i class="fas fa-search"></i></button>
</form>
</div>
</div>
<ul class="menu">
<li class="menu-item">
<a class="menu-link" href="/">
HOME
</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/c/news">
NEWS
</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/c/opinions">
VIEWPOINTS
</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/c/us">
US
</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/c/china">
CHINA
</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/c/world/americas/canada">
CANADA
</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/c/world">
WORLD
</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/c/life">
LIFE
</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/c/health">
HEALTH
</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://e-paper.visiontimes.com/" target="_blank" rel="noopener noreferrer">
E-PAPER
</a>
</li>
</ul>
<div class="header-menu-social">
<ul>
<li><a href="" target="_blank" rel="nofollow" title="Telegram"><i class="fab fa-telegram-plane"></i></a></li>
<li><a href="" target="_blank" rel="nofollow" title="Twitter"><i class="fab fa-twitter"></i></a></li>
<li><a href="" target="_blank" rel="nofollow" title="Youtube"><i class="fab fa-youtube"></i></a></li>
<li><a href="" target="_blank" rel="nofollow" title="Facebook"> <i class="fab fa-facebook-f"></i></a></li>
</ul>
</div>
</nav>
<nav is="vision-navigation-burger" class="visionComponent" aria-label="Main">
<nav class="navigation-TopBarMenu-mobile" aria-label="Main">
<div class="wrap">
<div class="header-menu header-menu-menu">
<ul class="menu">
<li class="menu-item menu-item-1 " tabindex="-1">
<a class="menu-link" href="#">Editions</a>
<ul class="sub-menus">
<li class="menu-item">
<a class="menu-link" href="https://www.secretchina.com/">Chinese</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://es.visiontimes.com/">Spanish</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.fr/">French</a>
</li>
<li class="menu-item">
 <a class="menu-link" href="https://www.visiontimes.it/">Italian</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://visiontimesjp.com/">Japanese</a>
</li>
</ul>
<i class="fas fa-angle-down"></i>
</li>
<li class="menu-item menu-item-2 " tabindex="-1">
<a class="menu-link" href="https://visiontimes.us1.list-manage.com/subscribe?u=7e5b1c29f989d8d053d774db4&#038;id=3feabe35e7">Newsletter</a>
</li>
<li class="menu-item menu-item-3 " tabindex="-1">
<a class="menu-link" href="https://www.visiontimes.com/donations">Donate</a>
</li>
<li class="menu-item menu-item-4 " tabindex="-1">
<a class="menu-link" href="https://e-paper.visiontimes.com/" target="_blank" rel="noopener noreferrer">e-Paper</a>
</li>
<li class="menu-item menu-item-5 " tabindex="-1">
<a class="menu-link" href="https://www.visiontimes.com/about-us">About US</a>
</li>
</ul>
</div>
<div class="header-menu header-menu-user">
<nav is="vision-user-side-bar" class="visionComponent vision-user-side-bar">
<div class="overlay"></div>
<div class="section-button">
<div class="large-section-button">
<a href="https://myaccount.visiontimes.com/subscribe/print.php" target="_blank">
<div class="text">Subscribe</div>
</a>
</div>
<div class="large-section-button user-login login-btn">
<div class="text">Sign in</div>
<i class="fas fa-user"></i>
</div>
</div>
<div class="user-side">
<div class="user-menu ">
<div class="user-menu-button"></div>
<div class="user-block">
<div class="user-name"></div>
<a href="https://myaccount.visiontimes.com/subscribe/print.php" target="_blank">
<div class="e-button">
<span class="text">Subscribe</span>
</div>
</a>
<div class="user-sign-out logout-btn">Sign out</div>
</div>
<ul class="user-menu-items">
<li class="user-menu-item  menu-item menu-item-type-custom menu-item-object-custom menu-item-446748  user-menu-first  level-1">
<a class="user-menu-link" href="https://myaccount.visiontimes.com/accountprofile.php">Account Settings</a>
</li>
<li class="user-menu-item  menu-item menu-item-type-custom menu-item-object-custom menu-item-446749  level-1">
<a class="user-menu-link" href="https://myaccount.visiontimes.com/newsletter.php?code=en">Newsletters</a>
</li>
<li class="user-menu-item  menu-item menu-item-type-custom menu-item-object-custom menu-item-446750  level-1">
<a class="user-menu-link" href="https://myaccount.visiontimes.com/subscribe.php?code=en">Subscriptions</a>
</li>
</ul>
</div>
</div>
</nav>
</div>
</div>
</nav>
<div class="container centerMaxWidthContainer">
<div class="vision-hamburger" is="vision-hamburger">
<div class="top-left-wrap">
<nav is="vision-navigation-side" class="visionComponent">
<div class="overlay"></div>
<div class="section-button">
<div class="large-section-button">
<div class="text">SECTIONS</div>
<i class="fas fa-bars"></i>
</div>
<div class="sm-section-button">
<img src="https://www.visiontimes.com/wp-content/themes/vt/dist/assets/images/menu-mobile-926eb40a4c.svg">
</div>
</div>
<div class="nav-side">
<div class="menu lite">
<div class="e-button">
<a href="https://myaccount.visiontimes.com/subscribe/print.php">
<span class="text">Subscribe</span>
</a>
</div>
<div class="menu-button"></div>
<ul class="menu-items">
<li class="menu-item  menu-item menu-item-type-custom menu-item-object-custom menu-item-428032  menu-first  level-1">
<a class="menu-link" href="/">Home</a>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-423521 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/news">News</a>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category menu-item-444027  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/opinions">Viewpoints</a>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-357119 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/us">US</a>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category menu-item-220229 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/china">China</a>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category menu-item-447634  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/world/americas/canada">Canada</a>
</li>
<li class="menu-item  world menu-item menu-item-type-taxonomy menu-item-object-category menu-item-989 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/world">World</a>
</li>
<li class="menu-item  life menu-item menu-item-type-taxonomy menu-item-object-category menu-item-985 menu-item-has-children  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/life">Life</a>
</li>
<li class="menu-item  menu-item menu-item-type-taxonomy menu-item-object-category menu-item-423523  level-1">
<a class="menu-link" href="https://www.visiontimes.com/c/health">Health</a>
</li>
<li class="menu-item  menu-item menu-item-type-custom menu-item-object-custom menu-item-449787  level-1">
<a class="menu-link" href="https://e-paper.visiontimes.com/" target="_blank" rel="noopener noreferrer">e-Paper</a>
</li>
</ul>
</div>
</div>
</nav>
<div class="search">
<form is="vision-search-form-expandable" id="searchform" name="searchform" class="search-form" method="post" action="">
<input type="text" class="search-field" name="s" placeholder="Search" value="">
<button class="btn search-button"><i class="fas fa-search"></i></button>
</form>
</div>
</div>
</div>
<div class="logo">
<a href="https://www.visiontimes.com" title="Home"><img src="https://www.visiontimes.com/wp-content/themes/vt/dist/assets/images/vision-times-sm-logo-66a6be678b.svg" alt="Vision Times"></a>
</div>
<div class="vision-subscribe">
<a href="https://myaccount.visiontimes.com/subscribe/print.php">
<div class="e-button">
<span class="text">Subscribe</span>
</div>
</a>
</div>
</div>
<div class="top-border">Truth, Inspiration, Hope.</div>
</nav>
</header>
<main id="mainContent" class="mainContent" aria-label="Content">
<div class="content-wrapper single-wrapper">
<header>
<nav aria-label="breadcrumbs" class="rank-math-breadcrumb"><p><a href="https://www.visiontimes.com">Home</a><span class="separator"> &raquo; </span><a href="https://www.visiontimes.com/c/us">US</a><span class="separator"> &raquo; </span><span class="last">Biden’s Griner Deal Sparks Controversy, Calls to Secure the Release of Other Russian Prisoners</span></p></nav><div is="bread-crumbs">
</div>
<div is="vision-block-post-header-vt">
<h1>Biden’s Griner Deal Sparks Controversy, Calls to Secure the Release of Other Russian Prisoners</h1>
<div class="meta">
<div class="author-time">
<div class="visionComponent" is="vision-authors-custom">
<div class="authors">
<div class="author">
<div class="img"><img alt='Todd Crawford' src='https://secure.gravatar.com/avatar/182dd511dd531fcb21ce7dfb5eb6d732?s=30&#038;r=g' srcset='https://secure.gravatar.com/avatar/182dd511dd531fcb21ce7dfb5eb6d732?s=60&#038;r=g 2x' class='avatar avatar-30 photo' height='30' width='30' loading='lazy' /></div>
<div class="info">
<div class="name">By
<a href="https://www.visiontimes.com/author/todd-crawford">
Todd Crawford
</a>
</div>
<div class="desc"></div>
</div>
</div>
</div>
<div class="date">Published: December 8, 2022</div>
</div>
</div>
<div class="view-comment">
<div is="vision-media-share" class="visionComponent">
<div class="share-button">
<i class="far fa-share-square"></i>
<div class="share-wrap">
<div class="up-triangle"></div>
<div class="share-padding">
<ul class="share-menu">
<li>
<a target="_blank" href="https://twitter.com/intent/tweet?text=Biden%E2%80%99s%20Griner%20Deal%20Sparks%20Controversy%2C%20Calls%20to%20Secure%20the%20Release%20of%20Other%20Russian%20Prisoners&amp;url=https%3A%2F%2Fwww.visiontimes.com%2F2022%2F12%2F08%2Fbidens-griner-deal-sparks-controversy-calls-for-other-russian-prisoners-release.html" rel="noopener noreferrer nofollow">
<i class="fab fa-twitter"></i>
</a>
</li>
<li>
<a target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.visiontimes.com%2F2022%2F12%2F08%2Fbidens-griner-deal-sparks-controversy-calls-for-other-russian-prisoners-release.html" rel="noopener noreferrer nofollow">
<i class="fab fa-facebook"></i>
</a>
</li>
<li>
<a target="_blank" href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.visiontimes.com%2F2022%2F12%2F08%2Fbidens-griner-deal-sparks-controversy-calls-for-other-russian-prisoners-release.html&amp;media=https%3A%2F%2Fimg.visiontimes.com%2F2022%2F12%2FGettyImages-1242297908.jpg&amp;description=Griner-Brittany-Paul-Wehlan-Getty-Images-1242297908" rel="noopener noreferrer nofollow" data-pin-no-hover="true" data-pin-custom="true" data-pin-do="skip" data-pin-description="Griner-Brittany-Paul-Wehlan-Getty-Images-1242297908">
<i class="fab fa-pinterest"></i>
</a>
</li>
<li>
<a target="_blank" href="https://www.linkedin.com/sharing/share-offsite/?url=https%3A%2F%2Fwww.visiontimes.com%2F2022%2F12%2F08%2Fbidens-griner-deal-sparks-controversy-calls-for-other-russian-prisoners-release.html" rel="noopener noreferrer nofollow">
<i class="fab fa-linkedin"></i>
</a>
</li>
<li>
<a href="/cdn-cgi/l/email-protection#16297479726f2b5f33242664737772332426627e7f65332426667965623324267778723324266177786273723324266279332426657e7764733324267f62332426617f627e3324266f7963383324265e73647333242165332426627e733324267a7f787d3325573324267e6262666533255733245033245061616138607f657f7978627f7b73653875797b332450242624243324502724332450262e332450747f727378653b71647f7873643b7273777a3b656677647d653b757978626479607364656f3b75777a7a653b7079643b79627e73643b646365657f77783b66647f6579787364653b64737a73776573387e627b7a30777b662d6563747c7375622b5733242666796562332426617964627e332426657e77647f7871332557332426547f727378335324332e26332f2f6533242651647f7873643324265273777a332426456677647d65332426557978626479607364656f33245533242655777a7a653324266279332426457375636473332426627e7333242644737a73776573332426797033242659627e7364332426446365657f777833242646647f657978736465" rel="noopener noreferrer nofollow">
<i class="fas fa-envelope"></i>
</a>
</li>
</ul>
</div>
</div>
</div>
</div>
<span class="comment-count" title="Jump to comment"><i class="far fa-comments"></i></span>
</div>
</div>
<div class="social-btns">
<div is="social-buttons">
<a class="button twitter" target="_blank" href="https://twitter.com/intent/tweet?text=Biden%E2%80%99s%20Griner%20Deal%20Sparks%20Controversy%2C%20Calls%20to%20Secure%20the%20Release%20of%20Other%20Russian%20Prisoners&amp;url=https%3A%2F%2Fwww.visiontimes.com%2F2022%2F12%2F08%2Fbidens-griner-deal-sparks-controversy-calls-for-other-russian-prisoners-release.html" rel="noopener noreferrer nofollow"><span class="txt">Twitter</span></a>
<a class="button facebook" target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.visiontimes.com%2F2022%2F12%2F08%2Fbidens-griner-deal-sparks-controversy-calls-for-other-russian-prisoners-release.html" rel="noopener noreferrer nofollow"><span class="txt">Facebook</span></a>
<a class="button pinterest" target="_blank" href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.visiontimes.com%2F2022%2F12%2F08%2Fbidens-griner-deal-sparks-controversy-calls-for-other-russian-prisoners-release.html&amp;media=https%3A%2F%2Fimg.visiontimes.com%2F2022%2F12%2FGettyImages-1242297908.jpg&amp;description=Griner-Brittany-Paul-Wehlan-Getty-Images-1242297908" rel="noopener noreferrer nofollow" data-pin-no-hover="true" data-pin-custom="true" data-pin-do="skip" data-pin-description="Griner-Brittany-Paul-Wehlan-Getty-Images-1242297908"><span class="txt">Pinterest</span></a>
<a class="button linkedin" target="_blank" href="https://www.linkedin.com/shareArticle?mini=1&amp;url=https%3A%2F%2Fwww.visiontimes.com%2F2022%2F12%2F08%2Fbidens-griner-deal-sparks-controversy-calls-for-other-russian-prisoners-release.html&amp;title=Biden%E2%80%99s%20Griner%20Deal%20Sparks%20Controversy%2C%20Calls%20to%20Secure%20the%20Release%20of%20Other%20Russian%20Prisoners&amp;source=https%3A%2F%2Fwww.visiontimes.com" rel="noopener noreferrer nofollow"><span class="txt">LinkedIn</span></a>
<a class="button email" href="/cdn-cgi/l/email-protection#3d025f5259440074180f0d4f585c59180f0d4955544e180f0d4d524e49180f0d5c5359180f0d4a5c53495859180f0d4952180f0d4e555c4f58180f0d5449180f0d4a544955180f0d44524813180f0d75584f58180f0a4e180f0d495558180f0d51545356180e7c180f0d5549494d4e180e7c180f7b180f7b4a4a4a134b544e545253495450584e135e5250180f7b0f0d0f0f180f7b0c0f180f7b0d05180f7b5f545958534e105a4f5453584f1059585c51104e4d5c4f564e105e5253494f524b584f4e44105e5c51514e105b524f10524955584f104f484e4e545c53104d4f544e5253584f4e104f5851585c4e5813554950511b5c504d064e485f57585e49007c180f0d4d524e49180f0d4a524f4955180f0d4e555c4f54535a180e7c180f0d7f5459585318780f18050d1804044e180f0d7a4f5453584f180f0d79585c51180f0d6e4d5c4f564e180f0d7e5253494f524b584f4e44180f7e180f0d7e5c51514e180f0d4952180f0d6e585e484f58180f0d495558180f0d6f5851585c4e58180f0d525b180f0d724955584f180f0d6f484e4e545c53180f0d6d4f544e5253584f4e" rel="noopener noreferrer nofollow"><span class="txt">Email</span></a>
</div>
</div>
</div>
</header>
<section class="post-main">
<div class="col-left">
<div class="with-gray-border-right">
<div class="col-left-content">
<div class="featuredImage">
<div class="visionComponent visionComponent--sizeLarge  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/12/GettyImages-1242297908-768x512.jpg" srcset="
                                    https://img.visiontimes.com/2022/12/GettyImages-1242297908-1920x1280.jpg 1920w,
            https://img.visiontimes.com/2022/12/GettyImages-1242297908-1068x712.jpg 1440w,
            https://img.visiontimes.com/2022/12/GettyImages-1242297908-1068x712.jpg 1320w,
            https://img.visiontimes.com/2022/12/GettyImages-1242297908-1068x712.jpg 1024w,
            https://img.visiontimes.com/2022/12/GettyImages-1242297908-768x512.jpg 800w,
            https://img.visiontimes.com/2022/12/GettyImages-1242297908-696x464.jpg 600w,
                                                            https://img.visiontimes.com/2022/12/GettyImages-1242297908-485x360.jpg 375w" data-sizes="auto" alt="Griner-Brittany-Paul-Wehlan-Getty-Images-1242297908">
<figcaption class="figure-caption">US' Women's National Basketball Association (WNBA) basketball player Brittney Griner, who was detained at Moscow's Sheremetyevo airport and later charged with illegal possession of cannabis, arrives at a hearing at the Khimki Court, outside Moscow on Aug. 4, 2022. (Image: KIRILL KUDRYAVTSEV/AFP via Getty Images</figcaption>
</figure>
</div>
</div>
</div>
<div class="article-content">
<p>On Dec. 8 U.S. President Joe Biden announced that his administration had reached a deal with Russian authorities to secure the release of Brittney Griner, via a prisoner-swap. Griner was, until today, imprisoned in a Russian penal colony on a drug conviction.&nbsp;</p>
<p>While announcing the prisoner swap, Biden said, “She’s safe, she’s on her way home after months of being unjustly detained in Russia, held under intolerable circumstances.”</p>
<p>The deal has sparked significant controversy with many criticizing the deal as lopsided while others argue that other Americans, who are currently rotting away in Russia’s penal system on dubious charges, have been forgotten.&nbsp;</p>
<p>The Biden administration facilitated a prisoner swap for the infamous arms dealer Viktor Bout who is also known as the Merchant of Death. Bout was serving a 25-year sentence in an American prison for conspiring to sell weapons to people who said they intended on killing Americans.&nbsp;</p>
<p>Bout was the inspiration for the 2005 Nicholas Cage movie Lord of War.&nbsp;</p>
<p>Griner was first detained on Feb. 17 of this year after she was accused by Russian authorities of carrying hashish oil, a cannabis derivative, in her luggage at an airport near Moscow. At the time, Griner was visiting Russia to play with her professional team, UMMC Yekaterinburg, which she played for during the W.N.B.A. off-season.&nbsp;</p>
<p>In February of this year, the Russian Federal Customs Service said that a drug sniffing canine had prompted a search of Griner’s luggage which revealed vape cartridges containing hashish oil. Russia has strict laws concerning narcotics. She was promptly arrested, tried for the crime and sentenced to nine years in prison.</p>
<p>According to the <a href="https://www.nytimes.com/article/brittney-griner-russia.html" target="_blank" rel="noopener">New York Times</a>, the Biden administration tried for months to strike a deal with its Russian counterparts for her and another American’s release, U.S. Marine Paul Whelan.&nbsp;</p>
<p>Paul Nicholas Whelan, 52, is a Canadian-born former U.S. Marine who was arrested in Russia in late Dec. 2018, accused of spying. In June of 2020, he received a 16-year sentence and is currently imprisoned in a Russian penal colony.</p>
<p>The Biden administration’s apparent failure to secure the release of Whelan, in addition to Griner, has sparked significant backlash.</p>
<p>The New York Times reported that Biden’s deal “could risk creating an incentive for the arrest or abduction of Americans abroad,” while Twitter lit up with users panning the deal as lopsided and dangerous.</p>
<p>Donald Trump Jr. took to Twitter to criticize the deal, telling his over 9.4 million followers, “You guys know how to make sure Putin keeps arresting Americans and severely punishing them? Trade him an arms dealer aka ‘The Merchant of Death’ someone guilty of conspiring to kill Americans and aiding a terrorist organization for an America Hating WNBA activist.”</p>
<figure class="wp-block-embed is-type-rich is-provider-twitter wp-block-embed-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="500" data-dnt="true"><p lang="en" dir="ltr">You guys know how to make sure Putin keeps arresting Americans and severely punishing them? <br><br>Trade him an arms dealer aka “The Merchant of Death” someone guilty of conspiring to kill Americans and aiding a terrorist organization for an America Hating WNBA activist.<br><br>Great trade!</p>&mdash; Donald Trump Jr. (@DonaldJTrumpJr) <a href="https://twitter.com/DonaldJTrumpJr/status/1600850042872791040?ref_src=twsrc%5Etfw" target="_blank" rel="noopener">December 8, 2022</a></blockquote><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div></figure>
<p>Griner previously came under fire for comments she made that many panned as anti-American. In 2020, she refused to stand for the American national anthem saying, “I honestly feel we should not play the national anthem during our season. I think we should take that much of a stand.” She said she opposed the Star-Spangled Banner because it “didn’t even represent all Americans when it was first made.”</p>
<p>Seth Dillion, CEO of The Babylon Bee, a popular satire site, took a softer tone telling his 516-thousand followers, “Brittany Griner was a captive set free at a significant cost by the homeland she despises. From one angle, it’s a terrible deal. From another, it’s a beautiful illustration of God’s grace. Jesus died to set us free ‘while we were yet sinners’ undeserving of redemption.”</p>
<figure class="wp-block-embed is-type-rich is-provider-twitter wp-block-embed-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="500" data-dnt="true"><p lang="en" dir="ltr">Brittany Griner was a captive set free at a significant cost by the homeland she despises. From one angle, it&#39;s a terrible deal. From another, it&#39;s a beautiful illustration of God&#39;s grace. Jesus died to set us free &quot;while we were yet sinners&quot; undeserving of redemption.</p>&mdash; Seth Dillon (@SethDillon) <a href="https://twitter.com/SethDillon/status/1600872828219162624?ref_src=twsrc%5Etfw" target="_blank" rel="noopener">December 8, 2022</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div></figure>
<p>Benny Johnson, an American political columnist, currently serving as chief creative officer at conservative organization Turning Point USA tweeted, “Meet Brittney Griner &amp; Marine Paul Whelan. Both Americans. Both were convicted in Russian courts on dubious charges. Both serving multi-year sentences in Russian prison. Brittney hates America. Paul served America. Guess which one Biden traded a terrorist to free? Semper fi Paul.”</p>
<figure class="wp-block-embed is-type-rich is-provider-twitter wp-block-embed-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="500" data-dnt="true"><p lang="en" dir="ltr">Meet Brittney Griner &amp; Marine Paul Whelan.<br>Both Americans.<br>Both were convicted in Russian courts on dubious charges.<br>Both serving multi-year sentences in Russian prison.<br>Brittney hates America<br>Paul served America<br><br>Guess which one Biden traded a terrorist to free?<br><br>Semper fi Paul <a href="https://t.co/tuP1R6AZpf" target="_blank">pic.twitter.com/tuP1R6AZpf</a></p>&mdash; Benny Johnson (@bennyjohnson) <a href="https://twitter.com/bennyjohnson/status/1600858803313983489?ref_src=twsrc%5Etfw" target="_blank" rel="noopener">December 8, 2022</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div></figure>
<p>“Semper fi” or “semper fidelis” is a Latin phrase that means “always faithful” or “always loyal” and is the motto of the U.S. Marine Corps.&nbsp;</p>
<p>The Daily Wires Matt Walsh <a href="https://twitter.com/MattWalshBlog/status/1600864195897090054" target="_blank" rel="noopener">tweeted</a>, “Brittney Griner broke Russian law. She brought drug paraphernalia into Russia. They didn’t fabricate the charges against her. She did it. She deserved to stay in prison until a deal that serves American interests – and includes Paul Whelan – could be reached.”</p>
<figure class="wp-block-embed is-type-rich is-provider-twitter wp-block-embed-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="500" data-dnt="true"><p lang="en" dir="ltr">Brittney Griner broke Russian law. She brought drug paraphernalia into Russia. They didn&#39;t fabricate the charges against her. She did it. She deserved to stay in prison until a deal that serves American interests &#8212; and includes Paul Whelan &#8212; could be reached.</p>&mdash; Matt Walsh (@MattWalshBlog) <a href="https://twitter.com/MattWalshBlog/status/1600864195897090054?ref_src=twsrc%5Etfw" target="_blank" rel="noopener">December 8, 2022</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div></figure>
<p>Scrolling through the thousands of responses on Twitter concerning the circumstances around Griner’s release wields few responses in support of the deal however, some are relieved Griner is free while also demanding Whelan’s release.&nbsp;</p>
<p>National Football League quarterback, Robert Griffin III, <a href="https://twitter.com/RGIII/status/1600866503158468608" target="_blank" rel="noopener">tweeted</a>, “Celebrate Brittney Griner coming home to her family and now let’s get Marine Paul Whelan home too.”</p>
<figure class="wp-block-embed is-type-rich is-provider-twitter wp-block-embed-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="500" data-dnt="true"><p lang="en" dir="ltr">Celebrate Brittney Griner coming home to her family and now let’s get Marine Paul Whelan home too.</p>&mdash; Robert Griffin III (@RGIII) <a href="https://twitter.com/RGIII/status/1600866503158468608?ref_src=twsrc%5Etfw" target="_blank" rel="noopener">December 8, 2022</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div></figure>
<p>Griner is expected to reach U.S. soil within the next 24-hours.</p>
</div>
</div>
</div>
<footer class="post-meta">
<div class="visionComponent" is="vision-block-post-footer">
<div class="content centerContentMaxWidth">
<ul class="tags">
<li class="tags-item">Tag:</li>
<li class="tags-item"><a class="tags-itemLink pill" href="https://www.visiontimes.com/tag/biden-administration"><span class="visuallyHidden">Tag:</span> biden administration</a></li>
<li class="tags-item"><a class="tags-itemLink pill" href="https://www.visiontimes.com/tag/brittney-griner"><span class="visuallyHidden">Tag:</span> Brittney Griner</a></li>
<li class="tags-item"><a class="tags-itemLink pill" href="https://www.visiontimes.com/tag/lord-of-war"><span class="visuallyHidden">Tag:</span> Lord of War</a></li>
<li class="tags-item"><a class="tags-itemLink pill" href="https://www.visiontimes.com/tag/marine-paul-whelan"><span class="visuallyHidden">Tag:</span> Marine Paul Whelan</a></li>
<li class="tags-item"><a class="tags-itemLink pill" href="https://www.visiontimes.com/tag/merchant-of-death"><span class="visuallyHidden">Tag:</span> Merchant of Death</a></li>
<li class="tags-item"><a class="tags-itemLink pill" href="https://www.visiontimes.com/tag/viktor-bout"><span class="visuallyHidden">Tag:</span> Viktor Bout</a></li>
</ul>
</div>
</div>
</footer>
<div id="post-comments">
<div id="remark42" is="vision-block-comment" class="loading">
</div>
</div>
<section>
<div is="vision-grid-news-latest">
<h3>RELATED NEWS</h3>
<div class="news-latest">
<div class="article">
<a href="https://www.visiontimes.com/2022/12/08/us-imposes-sanctions-on-turkish-businessman-citing-links-to-irans-quds-force.html"><div class="title">US Imposes Sanctions on Turkish Businessman, Citing Links to Iran&#8217;s Quds Force</div></a>
<a href="https://www.visiontimes.com/2022/12/08/us-imposes-sanctions-on-turkish-businessman-citing-links-to-irans-quds-force.html"><div class="img"><div class="visionComponent visionComponent--sizeTiny  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/12/2022-12-08T175752Z_2_LYNXMPEIB70W5_RTROPTP_4_IRAN-SANCTIONS-USA-TURKEY-768x512.jpg" srcset="
                                                                        https://img.visiontimes.com/2022/12/2022-12-08T175752Z_2_LYNXMPEIB70W5_RTROPTP_4_IRAN-SANCTIONS-USA-TURKEY-485x360.jpg 375w" data-sizes="auto" alt="">
</figure>
</div>
</div>
</div></a>
</div>
<div class="article">
<a href="https://www.visiontimes.com/2022/12/08/us-house-approves-bill-backing-military-spending-in-overwhelming-show-of-support.html"><div class="title">US House Approves Bill Backing Military Spending in Overwhelming Show of Support</div></a>
<a href="https://www.visiontimes.com/2022/12/08/us-house-approves-bill-backing-military-spending-in-overwhelming-show-of-support.html"><div class="img"><div class="visionComponent visionComponent--sizeTiny  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/12/2022-12-08T190235Z_1_LYNXMPEIB70YO_RTROPTP_4_USA-DEFENSE-CONGRESS-768x512.jpg" srcset="
                                                                        https://img.visiontimes.com/2022/12/2022-12-08T190235Z_1_LYNXMPEIB70YO_RTROPTP_4_USA-DEFENSE-CONGRESS-485x360.jpg 375w" data-sizes="auto" alt="">
</figure>
</div>
</div>
</div></a>
</div>
<div class="article">
<a href="https://www.visiontimes.com/2022/12/08/u-s-military-bill-features-up-to-10-billion-to-boost-taiwan.html"><div class="title">U.S. Military Bill Features Up to $10 Billion to Boost Taiwan</div></a>
<a href="https://www.visiontimes.com/2022/12/08/u-s-military-bill-features-up-to-10-billion-to-boost-taiwan.html"><div class="img"><div class="visionComponent visionComponent--sizeTiny  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/12/Screenshot-2022-12-08-at-10.23.00-PM-768x514.png" srcset="
                                                                        https://img.visiontimes.com/2022/12/Screenshot-2022-12-08-at-10.23.00-PM-485x360.png 375w" data-sizes="auto" alt="Flags of Taiwan and U.S. are placed for a meeting in Taipei, Taiwan March 27, 2018. (Image: Screenshot / Reuters)">
</figure>
</div>
</div>
</div></a>
</div>
<div class="article">
<a href="https://www.visiontimes.com/2022/12/07/nyc-care-receives-tyson-award-for-excellence-in-pursuit-of-healthcare-equity.html"><div class="title">NYC Care Receives Tyson Award for Excellence in Pursuit of Healthcare Equity</div></a>
<a href="https://www.visiontimes.com/2022/12/07/nyc-care-receives-tyson-award-for-excellence-in-pursuit-of-healthcare-equity.html"><div class="img"><div class="visionComponent visionComponent--sizeTiny  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/12/nyc-care-receives-tyson-award-for-excellence-in-pursuit-of-healthcare-equity-by-the-joint-commission-and-kaiser-permanente-featured-768x490.jpg" srcset="
                                                                        https://img.visiontimes.com/2022/12/nyc-care-receives-tyson-award-for-excellence-in-pursuit-of-healthcare-equity-by-the-joint-commission-and-kaiser-permanente-featured-485x360.jpg 375w" data-sizes="auto" alt="NYC-Care-Wins-2022-Tyson-Award-for-excellence-in-pursuit-of-Healthcare-Equity">
</figure>
</div>
</div>
</div></a>
</div>
</div>
</div>
</section>
</div>
<div class="col-right">
<div is="vision-list-top-stories">
<div class="sidebar-header">
<h3>TOP STORIES</h3>
<div class="article" id="454602">
<a href="https://www.visiontimes.com/2022/11/18/gofundme-campaigns-raise-money-for-families-of-idaho-homicide-victims.html"><div class="title">GoFundMe Campaigns Raise Money for Families of Idaho Homicide Victims</div></a>
<a href="https://www.visiontimes.com/2022/11/18/gofundme-campaigns-raise-money-for-families-of-idaho-homicide-victims.html"><div class="img"><div class="visionComponent visionComponent--sizeTiny  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/11/2022-11-17T191155Z_1_LOP030617112022RP1_RTRMADP_BASEIMAGE-960X540_IDAHO-STUDENTS-UPDATE-768x432.jpg" srcset="
                                                                        https://img.visiontimes.com/2022/11/2022-11-17T191155Z_1_LOP030617112022RP1_RTRMADP_BASEIMAGE-960X540_IDAHO-STUDENTS-UPDATE-485x360.jpg 375w" data-sizes="auto" alt="GoFundMe campaigns raise money for families of Idaho homicide victims. (Image: Screenshot / Reuters)">
</figure>
</div>
</div>
</div></a>
</div>
<div class="article" id="435032">
<a href="https://www.visiontimes.com/2022/11/24/what-did-george-washington-proclaim-on-thanksgiving-day.html"><div class="title">What Did George Washington Proclaim on Thanksgiving Day?</div></a>
<a href="https://www.visiontimes.com/2022/11/24/what-did-george-washington-proclaim-on-thanksgiving-day.html"><div class="img"><div class="visionComponent visionComponent--sizeTiny  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2021/11/Thanksgiving-George-Washington-768x431.jpg" srcset="
                                                                        https://img.visiontimes.com/2021/11/Thanksgiving-George-Washington-485x360.jpg 375w" data-sizes="auto" alt="Thanksgiving-George-Washington">
</figure>
</div>
</div>
</div></a>
</div>
<div class="article" id="454969">
<a href="https://www.visiontimes.com/2022/11/28/huffman-koos-closing-middletown-ny-location.html"><div class="title">Beloved Furniture Store Huffman Koos Closing Middletown, NY Location for Renovations, But Business Is</div></a>
<a href="https://www.visiontimes.com/2022/11/28/huffman-koos-closing-middletown-ny-location.html"><div class="img"><div class="visionComponent visionComponent--sizeTiny  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/11/Huffman-Koos-Furniture-Specialist-Derek-Teel-e1669674531372-768x532.jpg" srcset="
                                                                        https://img.visiontimes.com/2022/11/Huffman-Koos-Furniture-Specialist-Derek-Teel-e1669674531372-485x360.jpg 375w" data-sizes="auto" alt="">
</figure>
</div>
</div>
</div></a>
</div>
<div class="article" id="455237">
<a href="https://www.visiontimes.com/2022/12/05/virginia-cops-raid-restaurant-covid-violations-2-years-later.html"><div class="title">Virginia Authorities Raid Restaurant for COVID Mandate Violations Almost 2 Years After They Occurred</div></a>
<a href="https://www.visiontimes.com/2022/12/05/virginia-cops-raid-restaurant-covid-violations-2-years-later.html"><div class="img"><div class="visionComponent visionComponent--sizeTiny  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/12/Virginia-Gourmeltz-Matt-Strickland-COVID-Mask-Mandate-Liquor-License-Raid-768x512.jpg" srcset="
                                                                        https://img.visiontimes.com/2022/12/Virginia-Gourmeltz-Matt-Strickland-COVID-Mask-Mandate-Liquor-License-Raid-485x360.jpg 375w" data-sizes="auto" alt="Virginia police raided a local restaurant two years after COVID measure violations">
</figure>
</div>
</div>
</div></a>
</div>
<div class="article" id="454625">
<a href="https://www.visiontimes.com/2022/11/18/virginia-roundtable-discusses-ccp-infiltration-in-us-business-social-media-and-entertainment.html"><div class="title">Virginia Roundtable Discusses CCP Infiltration in US Business, Social Media, and Entertainment</div></a>
<a href="https://www.visiontimes.com/2022/11/18/virginia-roundtable-discusses-ccp-infiltration-in-us-business-social-media-and-entertainment.html"><div class="img"><div class="visionComponent visionComponent--sizeTiny  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/11/Virginia-Attorney-General-Jason-Miyares-768x498.jpeg" srcset="
                                                                        https://img.visiontimes.com/2022/11/Virginia-Attorney-General-Jason-Miyares-485x360.jpeg 375w" data-sizes="auto" alt="">
</figure>
</div>
</div>
</div></a>
</div>
</div>
</div>
<div is="vision-list-most-read">
<div class="sidebar-header" load_max="30" load_more="10">
<h3>MOST POPULAR</h3>
<div class="article" id="454602">
<a href="https://www.visiontimes.com/2022/11/18/gofundme-campaigns-raise-money-for-families-of-idaho-homicide-victims.html"><div class="title">GoFundMe Campaigns Raise Money for Families of Idaho Homicide Victims</div></a>
<a href="https://www.visiontimes.com/2022/11/18/gofundme-campaigns-raise-money-for-families-of-idaho-homicide-victims.html"><div class="img"><div class="visionComponent visionComponent--sizeTiny  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/11/2022-11-17T191155Z_1_LOP030617112022RP1_RTRMADP_BASEIMAGE-960X540_IDAHO-STUDENTS-UPDATE-768x432.jpg" srcset="
                                                                        https://img.visiontimes.com/2022/11/2022-11-17T191155Z_1_LOP030617112022RP1_RTRMADP_BASEIMAGE-960X540_IDAHO-STUDENTS-UPDATE-485x360.jpg 375w" data-sizes="auto" alt="GoFundMe campaigns raise money for families of Idaho homicide victims. (Image: Screenshot / Reuters)">
</figure>
</div>
</div>
</div></a>
</div>
<div class="article" id="454979">
<a href="https://www.visiontimes.com/2022/11/29/netherlands-confiscate-3000-farms-saving-environment.html"><div class="title">Netherlands to Confiscate 3,000 Farms Under Guise of Saving the Environment</div></a>
<a href="https://www.visiontimes.com/2022/11/29/netherlands-confiscate-3000-farms-saving-environment.html"><div class="img"><div class="visionComponent visionComponent--sizeTiny  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/11/Dutch-Netherlands-Government-Confiscate-3000-Farms-Saving-Environment-768x512.jpg" srcset="
                                                                        https://img.visiontimes.com/2022/11/Dutch-Netherlands-Government-Confiscate-3000-Farms-Saving-Environment-485x360.jpg 375w" data-sizes="auto" alt="The Netherlands Dutch government will confiscate 3000 farms because nitrogen but intends to build houses">
</figure>
</div>
</div>
</div></a>
</div>
<div class="article" id="435032">
<a href="https://www.visiontimes.com/2022/11/24/what-did-george-washington-proclaim-on-thanksgiving-day.html"><div class="title">What Did George Washington Proclaim on Thanksgiving Day?</div></a>
<a href="https://www.visiontimes.com/2022/11/24/what-did-george-washington-proclaim-on-thanksgiving-day.html"><div class="img"><div class="visionComponent visionComponent--sizeTiny  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2021/11/Thanksgiving-George-Washington-768x431.jpg" srcset="
                                                                        https://img.visiontimes.com/2021/11/Thanksgiving-George-Washington-485x360.jpg 375w" data-sizes="auto" alt="Thanksgiving-George-Washington">
</figure>
</div>
</div>
</div></a>
</div>
<div class="article" id="455001">
<a href="https://www.visiontimes.com/2022/11/29/critical-situation-japanese-births-continue-to-decline-beating-last-years-record-low.html"><div class="title">‘Critical situation’: Japanese Births Continue to Decline Beating Last Year’s Record Low</div></a>
<a href="https://www.visiontimes.com/2022/11/29/critical-situation-japanese-births-continue-to-decline-beating-last-years-record-low.html"><div class="img"><div class="visionComponent visionComponent--sizeTiny  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/11/GettyImages-450146433-768x535.jpg" srcset="
                                                                        https://img.visiontimes.com/2022/11/GettyImages-450146433-485x360.jpg 375w" data-sizes="auto" alt="Japan-plummeting-birth-rates-Getty-Images-450146433">
</figure>
</div>
</div>
</div></a>
</div>
<div class="article" id="454756">
<a href="https://www.visiontimes.com/2022/11/21/xi-moves-away-from-zero-covid.html"><div class="title">Xi Cautiously Moves China Away From ‘Zero-COVID’</div></a>
<a href="https://www.visiontimes.com/2022/11/21/xi-moves-away-from-zero-covid.html"><div class="img"><div class="visionComponent visionComponent--sizeTiny  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/11/xi-party-congress-20221015-screen_GettyImages-1433580176-768x515.jpg" srcset="
                                                                        https://img.visiontimes.com/2022/11/xi-party-congress-20221015-screen_GettyImages-1433580176-485x360.jpg 375w" data-sizes="auto" alt="">
</figure>
</div>
</div>
</div></a>
</div>
<div class="article" id="454175">
<a href="https://www.visiontimes.com/2022/11/11/reading-chinas-20th-party-congress.html"><div class="title">Reading the Results of China’s 20th Party Congress</div></a>
<a href="https://www.visiontimes.com/2022/11/11/reading-chinas-20th-party-congress.html"><div class="img"><div class="visionComponent visionComponent--sizeTiny  " is="vision-block-image">
<div class="container centerMaxWidthContainer">
<figure class="figure">
<img class="figure-image" loading="lazy" src="https://img.visiontimes.com/2022/11/xi-jinping-_politburo-standing-committee_20th-party-congress-20th-politburoGettyImages-1436090267-768x512.jpg" srcset="
                                                                        https://img.visiontimes.com/2022/11/xi-jinping-_politburo-standing-committee_20th-party-congress-20th-politburoGettyImages-1436090267-485x360.jpg 375w" data-sizes="auto" alt="">
</figure>
</div>
</div>
</div></a>
</div>
</div>
<div class="load-more">
<div class="loading load-more-loading"></div>
<a href="https://www.visiontimes.com/wp-admin/admin-ajax.php" id="load-more-button" load-most-popular>
<button>
<div class="load-more-text">LOAD MORE</div>
</button>
</a>
</div>
</div>
</div>
</section>
</div>
</main>
<footer class="mainFooter">
<div class="visionComponent themeLight" is="vision-navigation-footer">
<div class="container centerMaxWidthContainer">
<ul class="footer-nav">
<li>
<div class="heading">EDITIONS</div>
<ul class="items">
<li class="menu-item">
<a class="menu-link" href="https://www.secretchina.com/">Chinese</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://es.visiontimes.com/">Spanish</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.fr/">French</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.it/">Italian</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimesjp.com/">Japanese</a>
</li>
</ul>
</li>
<li>
<div class="heading">COMPANY</div>
<ul class="items">
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/about-us">About</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/contact-us">Contact</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/advertise">Advertise</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/submissions">Submissions</a>
</li>
</ul>
</li>
<li>
<div class="heading">INFO</div>
<ul class="items">
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/privacy">Privacy Policy</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/policies">Terms of Service</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/copyright-policy-and-infringement-notification">Copyright Policy and Infringement Notification</a>
</li>
</ul>
</li>
<li>
<div class="heading">POPULAR CATEGORY</div>
<ul class="items">
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/c/us">US</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/c/china">China</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/c/world">World</a>
</li>
<li class="menu-item">
 <a class="menu-link" href="https://www.visiontimes.com/c/politics">Politics</a>
</li>
<li class="menu-item">
<a class="menu-link" href="https://www.visiontimes.com/c/human-rights">Human Rights</a>
</li>
</ul>
</li>
</ul>
<div class="footer-nav footer-nav-2">
<li>
<div class="heading">About Us</div>
<div class="items txt">Vision Times tells the world everything about China in today's context. We keep a close eye on China because of its influence now and the lessons we can learn from its ancient past to better our lives today.</div>
</li>
<li>
<div class="heading">Follow Us</div>
<ul class="items icons">
<li><a href="https://www.facebook.com/VisionTimesOfficial" target="_blank" rel="nofollow" title="Facebook"> <i class="fab fa-facebook-f"></i></a></li>
<li><a href="https://twitter.com/vision_times" target="_blank" rel="nofollow" title="Twitter"><i class="fab fa-twitter"></i></a></li>
<li><a href="https://www.youtube.com/c/VisionTimesNews" target="_blank" rel="nofollow" title="Youtube"><i class="fab fa-youtube"></i></a></li>
<li><a href="https://t.me/visiontimes" target="_blank" rel="nofollow" title="Telegram"><i class="fab fa-telegram"></i></a></li>
<li><a href="https://safechat.com/channel/2788089756776450736" target="_blank" rel="nofollow" title="SafeChat"><i class="fab fa-safechat"></i></a></li>
</ul>
</li>
</div>
</div>
</div>
</footer>
</div>
<div class="wpFooter">


<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-W8PQVQT" height="0" width="0" style="display:none;visibility:hidden" aria-hidden="true"></iframe></noscript>



<script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">
	var dataLayer_content = {"pageTitle":"Biden’s Griner Deal Sparks Controversy, Calls to Secure the Release of Other Russian Prisoners - Vision Times","pagePostType":"post","pagePostType2":"single-post","pageCategory":["us","news"],"pageAttributes":["biden-administration","brittney-griner","lord-of-war","marine-paul-whelan","merchant-of-death","viktor-bout"],"pagePostAuthorID":526,"pagePostAuthor":"Todd Crawford"};
	dataLayer.push( dataLayer_content );
</script>
<script data-cfasync="false">
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.'+'js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-W8PQVQT');
</script>


</div>
<script async type="text/javascript" src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script async type="text/javascript" src="https://intothebid.com/wrapper/vt/prebid.vt_en.js"></script>
<script async type="text/javascript" src="https://intothebid.com/wrapper/vt/hp_vt_en.js"></script>
<script async type="text/javascript" src="https://intothebid.com/wrapper/vt/hb_vt_en.js"></script>
<script defer src="https://www.visiontimes.com/wp-content/cache/autoptimize/js/autoptimize_6d5b05acf688e50291fd02da8c9c051d.js"></script></body>
</html>

